13 Replies Latest reply: Jan 10, 2013 9:13 PM by Sam O'Daniel
vicki21 Level 1 (0 points)

I am trying to connect Airport Express 802.11n with my new Sony BDP-S390 Blu-Ray Disc Player with Wi-Fi

When I go to set up I see my network name on the tv screen with a lock. it asks for a WEP password. I've tried my network password (which works with my iPhone and iPad) - and it doesn't work (I get an error message - wrong number of characters). Then I tried my base station password - and got the same error message. Where is my WEP password? I did some searches online and got lots of different answers from - it's the same as your base station password - to - you need a special code. I'm at a loss. It looks as thought it requires 8 characters.


This is so frustrating. All my Mac devices connected so easily. Any help would be appreciated. I had no problem setting up Apple TV. It worked in 2 minutes. I think the people at Apple feel the same way and maybe that is why they are working on a TV as well.



AirPort Express 802.11n (1st Gen), Mac OS X (10.7.4)
  • Tesserax Level 9 (50,060 points)

    FYI ... Sony does provide online support for configuring this player to a wireless network for specific routers. The following link takes you to that information.


    I didn't find the AirPort Express in their list, but any of the Extreme models should work. Unfortunately, they do not show specific step-by-step instructions for Mac, but again, using the Windows 7 choice is relatively close.


    The key is the Wireless Security type that your AirPort is using. The example in the instructions uses WPA2 Personal. This is the same as WPA2-PSK in Windows-speak. If your Express is set for either WPA2 Personal or WPA/WPA2 Personal, the Sony should recognize this as WPA.

  • vicki21 Level 1 (0 points)

    Nothing happened when I clicked on "link" - but I just retried to connect again and noticed it said WEP key (not WEP password) if that matters. I also found one answer on web - that said you have to find the full hexadecimal key (some MAC secret) located somewhere under system preferences > network. And that you need this key to use if you're not using a Mac compatible device. Has anyone ever heard of this?

  • Bob Timmons Level 10 (95,485 points)

    Open Macintosh HD > Applications > Utilities > AirPort Utility 6.0


    Click on the Base Station menu at the very top of the computer screen....up where the Help menu and Apple icon are visible.  Do not look at the Base Station tab in the window in the center of your screen.


    Click on Show Passwords and your very long "key" will be revealed.  Unfortunately, this rarely ever seems to help users who ask for it, but you never know.

  • vicki21 Level 1 (0 points)

    When I do this the showpasswords . . .  restart . . .  and restore default settings . .  are all greyed out. Any ideas?

  • Bob Timmons Level 10 (95,485 points)

    When you open AirPort Utility, click on the AirPort Express icon and then click Edit.



    Then see if that will Show Passwords

  • Tesserax Level 9 (50,060 points)

    Sorry, please try this link instead. Then select the "Connect our Sony Blu-ray Disc player to a wireless router" item.

  • vicki21 Level 1 (0 points)

    I will try this tonight and let you know if it works. It's a lot of steps - I don't want to mess up my IP connection because everything else works so great - but I'm going to try and I'll update. Thanks for your help.

  • HACKINT0SH Level 5 (5,760 points)

    and got the same error message. Where is my WEP password?

    Seems your sony may be suffereing the faults of many third party devices...  WEP isn't going to work with WPA. These are totally different encryption schemes.


    WEP is a horrible method, that was broken before it was even standardized. The fact it was standardized is even a mystery, as its name is basically false advertising. Wireless Equivalent Privacy?  Certainly not.


    Is there a chance you can do some sort of firmware update for your Sony?

  • vicki21 Level 1 (0 points)

    There is a firmware update! But ok now - does this sound really stupid. How would I update the firmware if I can't connect to the internet?

  • HACKINT0SH Level 5 (5,760 points)

    Can you connect the ethernet from your MODEM directly into your Sony through an ethernet cable?

  • vicki21 Level 1 (0 points)

    Unfortunately the tv is in another room so I can't. But I don't think that's the problem because like I said the DVD player does SEE my network. It just won't accept any password that I type in.

  • a brody Level 9 (65,405 points)

    I would recommend temporarily leaving your network unprotected clearing all knowledge of the passwords from the router and not connecting it to a machine with personal data while you update the firmware of your other devices.   Once you are done, you can see if it supports the new WPA2 protocol.  If it doesn't contact the vendor who makes the device and tell them WEP has been antiquated by 10 years.

  • Sam O'Daniel Level 1 (5 points)

    Hi Vicki - I was just wrestling with this tonight. Hope the answer isn't too late.


    I noticed that going through the regular setup, it kept defaulting to WPA and not WEP, even though there was a choice for WEP and I would choose that and put in my 13 character password, and even tried putting in the 26 character WEP key (thanks for the help Bob Timmons!) - no dice. It would say Wireless: OK but Internet Access: Failed.


    So, I tried Manual. When I chose WEP, the next screen asked me to put in my WEP password - *not* WPA! Aha. So, I put in my normal password, clicked next and voila! it connected fine. Wireless: OK, Internet Access: OK.


    Hope this helps someone save 2 hours.