Previous 1 2 Next 16 Replies Latest reply: Jun 4, 2013 2:14 PM by TJ Skywasher
s2b999 Level 1 (0 points)

My Desktop & Screensaver preference pane (Lion 10.7.4) is not storing changes to the "Folders" section.  Does anyone know how I can fix this problem?

 

I added folders under "Folders" and later deleted the folders from my hard drive.  The Desktop & Screensaver preference pane turned these folders into "ghost" folders.

 

So now I have several ghost folders under "Folders" in the Desktop tab of my Desktop & Screensaver preference pane.  I can highlight each ghost folder and click the "-" button to delete it, but when I relaunch Desktop & Screensaver they return.  Also, I can add new folders to the "Folders" section, but when I relaunch Desktop & Screensaver, they aren't there anymore.

 

Can anyone help?


iMac, Mac OS X (10.7.4)
  • Kenichi Watanabe Level 7 (32,908 points)

    Sounds like it might be a bug, triggered when you move or delete a folder that is currently shown in the sidebar of that System Preferences pane.

     

    What happens if you do this...?  Put new folders back where those "ghost" folders were previously located.  They don't have to have anything in them, but give them the same names as before.  Then open System Preferences to the Desktop pane and try to remove the folders from the sidebar. Are they now gone permanently?

  • KTGHowie Level 1 (65 points)

    Sounds like you have corrupt prefs for Desktop and Screensaver.  Go to your home folder /Library/Preferences/ and locate a file called com.apple.preference.desktopscreeneffect.plist and delete it. Also, get rid of the lock file associated with it.  Log off and log back in.  Then, launch System Preferences, and go back to Desktop and Screensaver.

     

    I haven't tried this myself yet, but it's the first thing that I would do if I had this problem.  You're not going to hurt anything.  It should just reset the preferences for Desktop and Screensaver back to their defaults.  You might see your desktop background change back to Lion's default Galaxy background.

  • s2b999 Level 1 (0 points)

    b

  • s2b999 Level 1 (0 points)

    I looked for com.apple.preference.desktopscreeneffect.plist using the path HD/Library/Preferences, but it wasn't there; lots of other com.apple.... files were there, though.  Did I use the correct path?  Or could the files have a different name?

  • captfred Level 7 (26,290 points)

    On Finder's menubar, Finder > Go > hold option key down > select Library.

     

    In the Preferences folder, delete com.apple.desktop.plist.

     

    Logoff/Logon

  • TJ Skywasher Level 1 (15 points)

    I have the same problem and tried deleting the preference files detailed in this post.  It's gotten rid of all my old wallpaper folders which is what I wanted but if I add new ones in it doesn't remember them and when I go into Desktop the new folders have disappeared.  If I'm currently using a wallpaper in an added folder then it doesn't initially appear but after a second or two it will force itself to show up.

  • tommyelay Level 1 (0 points)

    Zap your PRAM

     

    Shut down and start up holding Command , Option, P, and R.

     

    Wait for the chime to sound twice

  • TJ Skywasher Level 1 (15 points)

    Sorry, didn't work.

  • Paldeng Level 2 (285 points)

    Make sure you are on Finder's menu> Go > hold option key down and select Library.

     

    Look for Preferences folder and drag com.apple.finder.plist to Desktop. Reboot

  • TJ Skywasher Level 1 (15 points)

    That hasn't worked either I'm afraid.

  • whaletail935 Level 1 (0 points)

    Same problem (folders added to Desktop Preferences via the bottom + menu or drag n' drop don't save) on Mountain Lion. None of the above solutions worked, but thanks anyway for helping. BTW, I'm running 10.8.3 on a 15" rMBP.

     

    Also, what does zapping the PRAM mean, and when would it be advisable?

  • kthersh Level 1 (0 points)

    I'm on 10.8.2 and am having the same problem. We need a new fix!

  • Paldeng Level 2 (285 points)
  • Paldeng Level 2 (285 points)

    Try booting on safe boot then try the folders or check settings then reboot again to normal.

    http://support.apple.com/kb/ht1455

     

    To start up into Safe Mode (to Safe Boot), do this:

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

    To reboot as normal just restart the Mac.

     

    Second option

     

    Try to delete Saved application state of your finder.

    1. Finder Menu>GO (then hold Alt/option to reveal Library) Click on Library

    2. Look for the Saved Application State Folder and delete com.apple.findersavedState. Reboot the machine so that it will create a new fresh findersavedstate file

     

    Might set your finder to default again though. Hope it it helps.

Previous 1 2 Next