Previous 1 2 Next 29 Replies Latest reply: Oct 3, 2014 8:53 PM by ssouthar Go to original post
  • Linc Davis Level 10 Level 10 (164,070 points)

    Read this whole message before doing anything.

     

    Back up all data if you haven’t already done so. Before proceeding, you must be sure you can restore your system to the state it’s in now.

     

    Quit Safari if it’s running. Then select Force Quit... from the menu bar. A small window will open with a list of running applications. Safari may appear in that list, even though you quit it. If so, select it and press return. Close the window.

     

    Step 1

     

    In the Finder, press the key combination shift-command-A to open the Applications folder. Select the Safari icon in that folder and press the key combination command-I to open the Info window. There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder.

     

    Open the Library folder in your home folder as follows:

     

    If running Mac OS X 10.7 or later, hold down the option key and select Go Library from the Finder menu bar.

     

    If running an older version of Mac OS X, select Go Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.

     

    Delete the following items from the Library folder (some may not exist):

     

    Caches/com.apple.Safari

    Caches/com.apple.WebKit.PluginProcess

    Caches/Metadata/Safari

    Preferences/com.apple.WebKit.PluginHost.plist

    Preferences/com.apple.WebKit.PluginProcess.plist

    Saved Application State/com.apple.Safari.savedState

     

    Leave the Library folder open. Try Safari again. If it works now, stop here. Close the Library folder.

     

    Step 2

     

    If Safari still doesn’t work right, quit, go back to the Finder and move the following items from the open Library folder to the Desktop (some may not exist):

     

    Cookies/Cookies.binarycookies

    Preferences/com.apple.Safari.LSSharedFileList.plist

    Preferences/com.apple.Safari.plist

    Preferences/com.apple.Safari.RSS.plist

    Preferences/com.apple.WebFoundation.plist

    PubSub/Database

    Safari

     

    (Note: you are not moving the Safari application. You’re moving a folder named “Safari.”)

     

    Try again. This time Safari should perform normally, but your settings and bookmarks will be lost.

     

    If the issue is still not resolved, quit Safari again and put all the items you moved to the Desktop back where they were, overwriting the newer ones that will have been created in their place. You don’t need to replace the files you deleted in step 1. Stop here and post again.

     

    If Safari is now working normally (apart from the lost settings), look inside the “Safari” folder on the Desktop for a file named “Bookmarks.plist”. Select File Import Bookmarks from the Safari menu bar. Import from that file. Recreate the rest of your Safari settings. You can then delete the items you moved to the Desktop.

     

    Note: This step will remove your Safari Extensions, if any, and their settings. If you choose to restore them, do so one at a time, testing after each step to make sure you haven’t restored the problem.

     

    If you don’t like the results of step 2, you can undo it completely by quitting Safari and restoring the items you moved or deleted in that step from your backup, overwriting any that were created in their place.

  • thecutt Level 1 Level 1 (0 points)

    Results of Step 1 Safari not working.

     

    Results of Step 2 Safari not working.

     

    Please advise.

     

    Thanks!

  • Linc Davis Level 10 Level 10 (164,070 points)

    When you tested in the Guest account, are you sure it wasn't the Safari-only Guest login created by "Find My Mac"?

     

    When you tested in safe mode, are you sure you really were in safe mode? Startup should have been much slower than usual, and you should have seen a dark gray progress bar on a light gray background.

     

    Are Parental Controls active for your account?

  • thecutt Level 1 Level 1 (0 points)

    No I am not sure about that.

     

    I don't believe I have "Find My Mac" installed on this computer.

     

    I created a Guest account to use for that test.

     

    As far as being in Safe Mode I am not too sure now that you explained what I should have seen.

     

    I bet my issue with that is using a bluetooth keyboard possibly?

     

    I will try Safe Mode again with a wired keyboard, as soon as I find it.

     

    No Parental Controls active for my account either.

     

    I will repost after I try a "true" Safe Mode test.

  • Linc Davis Level 10 Level 10 (164,070 points)

    I don't believe I have "Find My Mac" installed on this computer.

    If you're running 10.6.8, as your profile says, you don't, but I wanted to make sure.
    I will repost after I try a "true" Safe Mode test.
    Please do, because if you weren't in safe mode, this discussion has gone way off track.

  • thecutt Level 1 Level 1 (0 points)

    Ok definitely in Safe Mode and Safari works in my user account.

     

    What next?

     

    Stay in Safe Mode for next step or reboot?

  • Linc Davis Level 10 Level 10 (164,070 points)

    Please read this whole message before doing anything.

     

    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Copy or drag — do not type — the line below into the Terminal window, then press return:

     

    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
    
    

     

    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.) You can omit the final line ending in “$”.

     

    Step 2

     

    Repeat with this line:

     

    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
    
    

     

    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3

     

    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
    
    

     

    Step 4

     

    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
    
    

     

    Important: If you synchronize with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5

     

    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null
    
    

     

    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • thecutt Level 1 Level 1 (0 points)

    Output:

     

    Step 1:

    at.obdev.nke.LittleSnitch (2.4.4)

    com.avatron.AVExVideo (1.6.1)

    com.avatron.AVExFramebuffer (1.6.1)

     

    Step 2:

    org.samba.smbd

    org.samba.nmbd

    com.flipvideo.FlipShareServer.launchd

    at.obdev.littlesnitchd

     

    Step 3:

    com.wacom.pentablet

    com.flipvideo.FlipShareAutoRun

    at.obdev.LittleSnitchUIAgent

    at.obdev.LittleSnitchNetworkMonitor

    com.google.GoogleContactSyncAgent

    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae

     

    Step 4:

    /Library/Components:

     

    /Library/Extensions:

     

    /Library/Frameworks:

    NyxAudioAnalysis.framework

    PluginManager.framework

    TSLicense.framework

    XSKey.framework

    iLifeFaceRecognition.framework

    iLifeKit.framework

    iLifePageLayout.framework

    iLifeSQLAccess.framework

    iLifeSlideshow.framework

     

    /Library/Input Methods:

     

    /Library/Internet Plug-Ins:

    .DS_Store

    AdobePDFViewer.plugin

    AdobePDFViewerNPAPI.plugin

    AmazonMP3DownloaderPlugin.plugin

    Disabled Plug-Ins

    Flash Player.plugin

    Flip4Mac WMV Plugin.plugin

    JavaAppletPlugin.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    Silverlight.plugin

    WacomNetscape.plugin

    WacomSafari.plugin

    flashplayer.xpt

    iPhotoPhotocast.plugin

    nsIQTScriptablePlugin.xpt

     

    /Library/Keyboard Layouts:

     

    /Library/LaunchAgents:

    at.obdev.LittleSnitchNetworkMonitor.plist

    at.obdev.LittleSnitchUIAgent.plist

    com.flipvideo.FlipShare.AutoRun.plist

    com.wacom.pentablet.plist

     

    /Library/LaunchDaemons:

    at.obdev.littlesnitchd.plist

    com.apple.aelwriter.plist

    com.flipvideo.FlipShareServer.launchd.plist

     

    /Library/PreferencePanes:

    Air Display Preferences.prefPane

    Flash Player.prefPane

    Flip4Mac WMV.prefPane

    PenTablet.prefPane

     

    /Library/PrivilegedHelperTools:

     

    /Library/QuickLook:

    iWork.qlgenerator

     

    /Library/QuickTime:

    AppleIntermediateCodec.component

    AppleMPEG2Codec.component

    Flip4Mac WMV Advanced.component

    Flip4Mac WMV Export.component

    Flip4Mac WMV Import.component

    QTMpeg4Codec.component

     

    /Library/Spotlight:

    AppleWorks.mdimporter

    Microsoft Office.mdimporter

    iWork.mdimporter

     

    /Library/StartupItems:

     

    /etc/mach_init.d:

    dashboardadvisoryd.plist

     

    /etc/mach_init_per_login_session.d:

     

    /etc/mach_init_per_user.d:

     

    Library/Address Book Plug-Ins:

    AdiumAddressBookAction_AIM.scpt

    AdiumAddressBookAction_ICQ.scpt

    AdiumAddressBookAction_Jabber.scpt

    AdiumAddressBookAction_MSN.scpt

    AdiumAddressBookAction_SMS.scpt

    AdiumAddressBookAction_Yahoo.scpt

     

    Library/Fonts:

     

    Library/Input Methods:

    .localized

     

    Library/Internet Plug-Ins:

     

    Library/Keyboard Layouts:

     

    Library/LaunchAgents:

    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae.plist

    com.apple.FTMonitor.plist

    com.apple.imagent.plist

    com.apple.marcoagent.plist

    com.google.GoogleContactSyncAgent.plist

     

    Library/PreferencePanes:

     

    Step 5:

    iTunesHelper, AirDisplayStatusItem, ScreenCapture, Dropbox

  • Linc Davis Level 10 Level 10 (164,070 points)

    Please read this whole message carefully, especially the warnings, before doing anything.

     

    The changes to your configuration suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, seek help from its developer.

     

    WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not be able to help, if you ignore this warning.

     

    You should either remove or update the following system modification(s), if an update is available from the developer:

     

    LittleSnitch

     

    and definitely remove at least the following:

     

    N/A

     

    Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developer, or to follow his instructions. In some cases it may be necessary to re-download or even reinstall the software in order to get rid of it. I can't be more specific, because I don't install such things myself. Please do your own research.

     

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickyourmac.com. (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, email the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.

     

    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.

     

    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of the Mac OS. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

     

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse.

     

    I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future Mac OS updates, so it may not be clear which one is at fault.

     

    If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • thecutt Level 1 Level 1 (0 points)

    I uninstalled Little Snitch and then rebooted.

     

    Safari worked.

     

    Reinstalled Little Snitch to current version and still works.

     

    Much appreciated all your help.

     

    Thanks Linc !!!

  • Linc Davis Level 10 Level 10 (164,070 points)

    I'm glad you're straightened out, but a word of caution that may save you more trouble in the future. "LittleSnitch" is a very low-level system modification, only suitable for advanced users. If you're going to use it, you first of all need to keep it up to date. You also have to wait before installing updates from Apple until you know whether LS is compatible. Sometimes it won't be. Finally, if you modify your system, you need to become an expert troubleshooter; in other words, the sort of person who answers questions on this site, not the sort who asks them.

  • thecutt Level 1 Level 1 (0 points)

    Understood, Linc.

     

    I am learning and will keep your advice in mind. (Shutting off LS till I learn more how it works)

     

    Thank you very much for helping!!!

  • Druber Level 1 Level 1 (5 points)

    I was having similar problems in both Safari and Firefox.  Safari worked fine in Safe mode.  I unistalled Sophos antivirus and Avast antivirus and now both web browsers operate fine.  Thanks.

  • Glahti Level 1 Level 1 (0 points)

    Removing Sophos worked for me

  • ssouthar Level 1 Level 1 (0 points)

    This is late in the game but I was having a similar problem on all browsers in my Mac running Mavericks.   Finally came across a site suggesting flushing the DNS for similar issues so I gave it a try.  Wow, it worked!   Here's the page with instructions for various operating systems.   I am in fact using the OpenDNS servers for my DNS settings. 

     

    https://support.opendns.com/entries/26336865-Clearing-the-DNS-Cache-on-Computers -Servers-and-Web-Browsers

Previous 1 2 Next