11 Replies Latest reply: Jun 12, 2012 11:46 PM by diggy123
diggy123 Level 1 Level 1 (0 points)

Let me start by saying I've been a big fan of Apple products for years. But lately the system and bundled aps have become less appealing beacause of the stability.

 

Right now I'm running a 2011 MacBook Pro with 4 gigs of RAM, latest Mac OS X and iLife 11. I have about 160 gigs of free space on my HDD, all my movies are on a external HDD with more than 700 gigs of free space.

 

I've just started on working on my vacation video, which is now 14 mins long and thought to export it to 1080 HD just to see if i run into these errors again. And guess what - yes!

 

Error like -49, -101 and similar stop the whole thing. This has happened in the past as well. I can't seem to find any way around it which leaves me in a position I can't export anything.

 

I've tried different resolutions, my movies are shot in HD mostly...

 

I'm running out of ideas what to do.

 

Anyone with any ideas? Re-Install iMovie 9?


MacBook Pro (13-inch Early 2011), Mac OS X (10.7.4)
  • WCabax Level 1 Level 1 (0 points)

    Sorry, I can't help you. I've the same problem (error-108) and no one gave me a solution. We are stuck and i agree whit you. Apple it's not the same and is over valorized.

    To much time spended and no result. The film can only be seen in imovie project. It's impossible to finish or export.

     

    Regardes,

    Manuel Soares

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    What kind of camera?

  • diggy123 Level 1 Level 1 (0 points)

    i don't think it's a camera issue. Most of the footage is recorded with a Canon Legria camcorder (don't have it with me at the moment, can't tell the exact model).

    Some is shot with a Samsung Galaxy S2 smartphone.

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    I would suggest that you right click on the Event name and see if it offers to "Optimize Media". If it does, choose Optimize - Full.

     

    My guess is that the Samsung files are in h.264 and need to be converted to Apple Intermediate Codec so you will get good performance.

     

    If you want to know for sure, right click on one of your Samsung clips. Then choose Show In Finder. Right-Click on the clip in the Finder and choose Open With...QuickTime Player.

    In QuickTime Player, click Command-I to open the Inspector. Tell us everything listed beside the word "Format."

     

    Then go back and do this again for one of the Canon Legria clips.

    Tell us everything listed beside the word "Format."

  • diggy123 Level 1 Level 1 (0 points)

    Thanks for the tip. I'll try that when I get back home and let you know.

  • diggy123 Level 1 Level 1 (0 points)

    it actually doesnt allow me to optimize any clips in that project.... and i double checked - the issues i'm having are with a project which were all recorded with the camcorder. The files are all Apple Intermediate Codec, Linear PCM, Timecode

  • AeroQ Level 2 Level 2 (210 points)

    Error -49: file already open with with write permission

     

    Verify that no other device or application is working with the files that you want to export.

     

    -- Benoit

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    Error 49 could be a Time Machine conflict. I would try to temporarily shut off Time Machine while you share the movie.

  • diggy123 Level 1 Level 1 (0 points)

    i got rid of the -49 by shutting down  Time Machine. But i still get 108. Seems to be a memory issue - it kicks in about when 200 megs is free (as shown by Activity Monitor)

     

    I'm running with 4 gigs. I wonder if i out 8, will i get past it all it will up all the memory anyway....

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    Memory can't hurt anything, and it is very inexpensive. Look at memory from Crucial or MacSales.com.

  • diggy123 Level 1 Level 1 (0 points)

    I've found out, that exporting errors mights be caused something in the specific video.

     

    In that video, something is causing RAM memory to almost run out. When exporting I launched the Activity Monitor and saw free memory constantly dropping to about 200 megs when I got the 108 error.

     

    Fustrated, I started to work on the a new project. When exporting failed with a large format, the new project is full hd (1080p). Did about 20 mins of it and started to export. And it worked. The free memory never dropped below 900 megs.

     

    There isn't a whole lot of difference between the two project. Footage in both has been recorded with the same camcorder, both use photos from iPhoto and include same transitions and text.

     

    The only thing I can think of is, that in the failing project, I included photos straight from Finder (drag-drop) and since then have moved the files to a different location.Although iMovie gave no indication of something being wrong, I did import the same project to Final Cut Pro X which told me there were several missing files in the project. I did replace the photos with new ones but it still failed to export in iMovie.

     

    Maybe this where-actually-is-the-picture thing causes memory to run out...