0 Replies Latest reply: Jun 9, 2012 5:16 PM by Negativ2
Negativ2 Level 1 Level 1 (0 points)

i trying to install 10.5 leapard onto my powermac g4 dual 1.25 cpu with 1.75 ram and 160 gb harddrive.  It tells me mac os x can not be installed on this computer.  But i don't know why.


PowerMac, g4