8 Replies Latest reply: May 4, 2013 11:04 AM by TheGrimMumble
ryannjohnsonn Level 1 Level 1 (0 points)

I recently got a new iPhone 4 and I am unable to connect to my secured WiFi network with it. I can connect to it just fine with my laptop, old droid phone, iPod touch. I can also connect to it if I remove the security but not if the security is on. I've looked all over online, tried everything I've read, even took it into the Apple store where they completely reset the phone, all to no avail. I also brought the phone into a Verizon store, and they were able to connect to a secured wifi hotspot in the store, so I'm going to assume its a problem with my router.

 

ISP: Comcast Perfromance Cable

Modem: Comcast Motorola SB5120 Cable Modem

Router: Belkin N600 D8 Wireless N+ Router (Model: F9K1102v1); firmware up to date as of today.

 

I went to this website, plugged in all those settings and still nothing. I simply get "Unable to connect to <Network>". The one setting that I wasn't able to match to those had to do with DHCP. By going to my cable modem's config, I can tell that the DHCP client on it is turned on. The problem is, I cannot change the modem's settings readily through that page (192.168.100.1) and when I turn off the DHCP on my router my laptop has problems maintaining a connection.

 

Here's some screenshots of the settings, perhaps you guys have better insight/advice/etc. I've been trying to use the 2.4ghz connection for the iPod, I don't use it for anything else so I couldn't care less what the settings are... I just want it to be secured. I use the 5.0ghz connection for my laptop and such.

 

Here's the Channel and SSID settings... renamed the networks for the purpose of this.

Screen shot 2012-06-09 at 5.41.30 PM.png

Security Settings

Screen shot 2012-06-09 at 5.42.53 PM.png

 

WPS Settings (Honestly, no idea what this does).

Screen shot 2012-06-09 at 5.44.09 PM.png

Lastly, LAN settings:

Screen shot 2012-06-09 at 5.44.49 PM.png

 

If it's a problem with the phone itself, I still am with the 14 day return policy.


iPhone 4, iOS 5.1.1
  • randers4 Level 9 Level 9 (62,585 points)

    As far as I can see, your router settings look fine.  A couple of other things to try if you haven/t:

     

    1. Power cycle your wireless router (unplug for 30 seconds, plug back in), even if other devices connect without any problems (restarts a potentially hung DHCP service preventing new devices from being assigned an ip address)
    2. Update your router's firmware
    3. Go to Settings>General>Reset>Reset Network Settings (note: this will erase passwords for previously joined networks so you will have to re-enter these to join these networks again later)
  • ryannjohnsonn Level 1 Level 1 (0 points)

    1) I've tried power cycling both the modem and the router multiple times and it hasnt worked.

    2) I updated the firmware the other day, so it is currently up to date.

    3) I tried to do this, and the Apple store even did a complete reset on the phone, and I still have the same problem.

  • randers4 Level 9 Level 9 (62,585 points)

    OK, the only thing I didn't know about was the WPS section (your second screenshot).  Did you try disabling the "Wi-Fi Protected Setup" setting to see if it made a difference?

  • ryannjohnsonn Level 1 Level 1 (0 points)

    I just tried turning it off again and it still wont connect.

  • randers4 Level 9 Level 9 (62,585 points)

    I guess I'm stumped other than to say that it can definitely create problems if you are trying to run DHCP on your wireless router if it already enabled on your Comcast cable modem.  You only want one device managing DHCP on your network, normally the one that is the furthest "upstream"; in this case that would be your Comcast router.  I would try disabling DHCP on your router just as an experiment, then power-cycle your Comcast router, followed by your Belkin router, followed by your phone, then see if it connects successfully.  If it does, and when you restart your other devices they connect successfully, I would try to figure out how to solve the problem of the laptop not maintaining a connection.  Perhaps it needs an driver update?

  • shonagh-from-farnham Level 1 Level 1 (0 points)

    I found this article: http://www.pcworld.com/article/210480/top_10_iphone_annoyancesand_how_to_fix_the m.html

    which helped me when I had the same problem. Not sure if it's been suggested already - but my phone needed a restart - not just switching off - but off button and home button held down together for longer than it takes for the slide off to appear, hold until the apple appears and then wait for phone to start again. That fixed it for me.

  • Chuy González Level 1 Level 1 (0 points)

    I am having exactly the same problem and I am going crazy because I have no internet on my iPhone and my plan data is almost at its limit.

     

    Does the DHCP solved this issue?

  • TheGrimMumble Level 1 Level 1 (0 points)

    I have the same problem. But i guess you could say I'm lucky as I have two routers and one of them is working like it should. I just wanted to say that I have been using a quick fix for a while, unplugging the router from power, then wait about half a minute and plug it in again, but it does not last! You will have to do this procedure a couple of times a week, which can be annoying. I am looking for a something that will solve this problem permanently but I just wanted to let you know that it can be fixed temporarily.