12 Replies Latest reply: Jun 23, 2012 5:38 PM by Rudolfensis
Rudolfensis Level 1 Level 1 (45 points)

I play music to my AirPort Express via wireless speakers.

 

It used to drop every hour or so, or maybe twice an hour. Now over the past 10 minutes it's been dropping every few seconds, randomly.

 

Why does it normally happen?

 

What do I do to trouble-shoot, and solve?

 

Is it my router's fault (from my ISP)? Or the AirPort Express? Or my MacBook Pros? The internet seems to be fine.

 

[Running latest iTunes, Lion, MacBook Pro]


MacBook Pro, Mac OS X (10.7.2), 2.4GHz Core i7, SSD, Hi-Res Glossy
  • HACKINT0SH Level 5 Level 5 (5,755 points)

    USUALLY, it's an issue of interference.

     

    What NETWORK MODE is the express set up as?

  • Rudolfensis Level 1 Level 1 (45 points)

    Ah, thanks. So other wireless devices interfering?

     

    I have it set up in the way that I still get my WiFi from my router (wireless-N from my ISP), but AirTunes goes through the Express (wireless-G, hence why I don't use it for internet).

     

    Not sure where to find the network mode. I looked through the Airport Utility and didn't see mention of it anywhere. (Version 5.6, because I have an older Express.)

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Yes, unfortunatley the 'G' are not only slower... but they are getting older and a little more prone to break-down.... no thanks to the extra heat apple products pour out.

     

    In airport utility, click on your express, then click on Manual (bottom left).

     

    Click on Wireless tab, and what does it say in the  WIRELESS MODE: dropdown...

  • Rudolfensis Level 1 Level 1 (45 points)

    Thank you

     

    It says "Join a wireless network".

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Ok so you have it set up as a dedicated client. Which means we're already maximizing the throughput to the speakers. So, assuming it's not hardware failure, there isn't anything else we can do except to try and minimize this interference.  You could try to find out whats' causing it (not always possible), or move around the positioning of your routers.... or changing the channels.

     

    You may want to try unplugging BOTH your routers so they can re-start to see if that solves the issues. If not... you want to maybe dig in deeper and try setting your wifi manually to different channels.

  • Rudolfensis Level 1 Level 1 (45 points)

    Thanks for all your help! Will give you 'em points!

     

    So having the Express dedicated to audio is actually better? I thought it was a problem that my internet comes from my router (N), and the express is used only for speakers...

     

    I guess it's about interference...

     

    Thanks for the tips about changing channels, good call! Could also be my neighbors interference, right?

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Yes, an express dedicated to audio (client mode) will solve a lot of streaming issues, because it forces all its processing & throughput on just the speaker side. The downside is that joining a network as just a client won't allow your express to EXTEND the network.

     

    Neighbours networks can compete, so can cell phones and a 100&1 other things.

     

    What band is your express using now? The 2.4 Ghz only has 11 channels to select from (if you're on American continent), and many of these over-lap. Not to mention, they are getting more crowded by the day.

  • Rudolfensis Level 1 Level 1 (45 points)

    I'm in the UK.

     

    It's using channel 6... which is the least popular channel?

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    "It depends!"

     

    A lot of routers use #1 as default.

     

    This causes smart people to shift to channel #6, because as long as you move 5 channels across, you prevent over-lap.

     

    This also causes even SMARTER people to move to channel #11, because they know the smart people use channel #6.

     

    HOWEVER, the super-smarter people then shift to channel #9 now, because of what the SMART, and SMARTER people know.

     

    And then, soon there will be super-duper-smart people on the horizon so......

    Try to experiment.

  • Rudolfensis Level 1 Level 1 (45 points)

    Hey

     

    How do I change the channel while being in the "Join a network" mode? It won't let me pick one.

     

    I changed the channel on my router to 13 (in the UK), and the AirPort seems to adapt that one too... but shouldn't it have a different one to avoid interference? Like 9?

     

    Most people (4x) around me have channel 1, one has 6.

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    It's ok, you won't see the option to change the channel in airport utility when you're joining another network. Go to the other rooter upstream and adjust the channel over there.

     

    If your routers are part of the same network, then they are NOT completing against each other. It's when a different network starts to use similar channels that you run into problems.

  • Rudolfensis Level 1 Level 1 (45 points)

    Thanks again! Maybe I should start another post just to thank you and give you the points