5 Replies Latest reply: Apr 6, 2013 10:17 PM by PAHU
MikeOverThere Level 1 Level 1 (0 points)

Has anyone finally solved problems with getting this type of printer configured on OS X v10.7 Lion.  I have installed the latest drivers, updated the firmware, reset my printer settings, tried a few combinations, but ultimately cannot get my network printer to appear after unplugging the USB cable.  (I can see the MX700 Bonjour Scanner....and I did wait for several seconds after)

 

Is there a setting on the printer that I don't have right?  I couldn't find one via the Canon IJ Network Tool.

 

Thanks for any help or ideas.


iMac, Mac OS X (10.7.4)
  • PAHU Level 6 Level 6 (15,710 points)

    MikeOverThere wrote:

     

    ... but ultimately cannot get my network printer to appear after unplugging the USB cable.  (I can see the MX700 Bonjour Scanner....and I did wait for several seconds after)

    If the printing component of the MX fails to appear, which will be seen as "canonijnetwork" in the Kind column, but the scanner components does then it would suggest either a problem with the driver, as this installs that Canon protocol, or with something blocking the protocol if installed and working.

     

    I see that you have reinstalled the drivers but I would suggest you trash the BJPrinters folder, located in HD > Library > Printers > Canon. With the folder trashed and the Trash then emptied, will would connect the MX via USB so that the driver is downloaded and installed. Once this completes, then disconnect the USB cable and with the printer networked, see if you can add the printer.

     

    If the printer component still fails to appear, and yes it does take several more seconds to appear compared to the scanner that uses Bonjour, then you can enable a setting in the MX for a workaround. You will need to access the internal web page which you can do by entering the MX's IP address into a web browser. If you don't know the IP address then you can use Bonjour to find the MX on the network using Safari. With it open, select Bookmarks and Show Bookmarks. Then select Bonjour in the left sidebar - the MX should be listed in the right pane. Select it to open the internal web page. On the MX700 home page there will be an Advanced button. Press this and then select Other Settings in the left sidebar. From this Other Settings page there is the "LPR Service Notification" setting. Enable this and then OK the change. Exit from Safari and open Print & Scan again to add the printer. It should now appear with Bonjour in the Kind column.

  • MikeOverThere Level 1 Level 1 (0 points)

    Finally!  Thank you PAHU!

     

    This was the key.  I had not seen this description of steps anywhere else.  Getting me to delete the folders and empty the trash was the difference.

    PAHU wrote:

     

    I see that you have reinstalled the drivers but I would suggest you trash the BJPrinters folder, located in HD > Library > Printers > Canon. With the folder trashed and the Trash then emptied, will would connect the MX via USB so that the driver is downloaded and installed. Once this completes, then disconnect the USB cable and with the printer networked, see if you can add the printer.

     

    By the way, I could not get to my printer via the IP address of the printer (192.168.1.6).  There was no response.

     

    Thanks for your help.

  • Log0n123 Level 1 Level 1 (0 points)

    Does anyone know how to disable Bonjour on the Canon MG3260? I cannot print from any iOS Device on my network. I have tried an iPhone (4), and iPod Touch (3 or 4 gen), and an iPad (2), all with iOS 6.1. I got in touch with canon, and they told me to turn off the router and printer to clear the routing tables to disable Bonjour. It didn't work. They told me to take it to a qualified Canon Servicer, but that is a fair way away from me, and want to see if anyone knows anything about it before I take it there. Thanks

  • PAHU Level 6 Level 6 (15,710 points)

    Log0n123 wrote:

     

    Does anyone know how to disable Bonjour on the Canon MG3260?

    Not sure why you would want to turn of Bonjour. It is needed so iOS can locate the device.

     

    Anyway, to disable Bonjour you can connect to the internal web page of the MG (by typing its IP address into a web browser). From the MG home page, select the Advanced tab and then select the Other Settings link. Here you will see an entry of Bonjour setting. Change this from Enable to Disable and then OK the change. That's it.