3 Replies Latest reply: Sep 14, 2012 6:49 AM by aqnguyen87
appleiser Level 1 Level 1 (0 points)

Hi,

I am having issues with my MacBook (late 2010 model) where it freezes after waking from sleep (sometimes, ie about 3 times a week). I have read other posts similar to this but theirs always seems to unfreeze if they wait 20 or so seconds whereas my won't, the only option is to hold down the power button and force a shutdown. Another thing contributing to my problem is that this only happens when I have an external display connected.

 

As I said, it freezes when awakening from sleep so it will show whatever was on my screen before I put it to sleep (and loads that quite quickly) but wont let me do anything, ie can't move the mouse, cant force quit etc. If I close the lid it seems to sleep again but when I reopen it, the same issue is still there. I think it may be freezing when put to sleep rather than when waking from sleep because if I have a download running, the frozen screen shows a regular (static) download speed, whereas if it where freezing when waking from sleep I would assume it would read zero.

 

I can't pinpoint the exact process that triggers the freeze but I think it is related to closing the lid on the MacBook. If press command-option-eject to put it to sleep and leave the lid open, I dont have any issues. But If I close the lid, that's when issues start appearing and I don't think it matters if it is asleep or not before I close the lid (but it doesn't happen all the time).

 

Another thing troubling me is that if I close the lid while it is awake, I would assume this should send it to sleep, which it does sometimes, but sometimes it just turns off the MacBook display and uses the external one as a single display.

 

A final point, I think I only started having these problems after I upgraded to Lion about 6 months ago...

 

Can someone please tell me how to resolve this issue as it is really not good to have to force shutdowns and lose my unsaved data all the time?

 

Cheers.

 

 

MacBook 7,1 (late 2010), Lion 10.7.4


MacBook, Mac OS X (10.7.4)
  • aqnguyen87 Level 1 Level 1 (0 points)

    !!!!!!!!!!!So far only this has worked for me!!!!!!!!!!!!!!!!

     

    Go to System Preferences -> Energy Saver -> and UNcheck the box that says "Put hard disk(s) to sleep when possible on BOTH the Battery and Power Adaptor tabs.

     

    I had this issue when I first installed Mountion Lion on my Aluminum MB 2008. Thought it was 10.8 so I down graded to 10.7 Lion, issue still happened. But after I applied this setting the issue seemed to go away. Before this I also deleted the old wifi settings in Network Utilities and added the Wifi device, ssid, and wep key again (not using WPA2). I will continue testing through the night and will update once I can determine the issue is gone.

     

    Hopefully this works for others too.

  • matias211 Level 1 Level 1 (0 points)

    My MBP (early 2011) also used to freeze sometimes (but maybe 1 time every 2 weeks) with Lion.

    As of Mountain Lion, it has crashed continuously AT LEAST once every week while running considerably light software (iTunes, Pages, Safari, Audition and eventually Traktor).

    Did change the energy saving settings as described above and haven't yet had any crashes, but still.... PEOPLE, THIS BUG IS AT LEAST A MONTH OLD!!

  • aqnguyen87 Level 1 Level 1 (0 points)

    SOLUTION for SSDs machines.

     

    For those of you with 3RD party SSDs, this solution worked for me.

    Update the firmware on your SSDs, after 10.8 something screwy happened to where the mac would not be able to communicate with the SSD, making it freeze and have to do a forced reboot. Manufacturers like OSZ and Sandisk, addressed the issue in seperate firmware updates. I just updated mine and after testing with sleeping for both 20mins and 8 hours, the freezing issue has stopped. Hopefully, this will help others as well.

     

    Go to the manufacturers website for your SSD and update to its latest SSD firmware, reboot and it should all be better now. Goodluck!