7 Replies Latest reply: Jun 12, 2012 4:19 AM by R C-R
dymar Level 1 Level 1 (0 points)

The support doc for the recent Java update (Update 8, for Snow Leopard), entitled "About Java for Mac OS X 10.6 Update 8," advises the following:

 

If you do not use Java applets, it is recommended that you disable the Java web plug-in in your web browser.

 

How does one know whether or not they use "Java applets"?

 

Thanks.

 

URL:  http://support.apple.com/kb/HT5243

 

 



MacBook, Mac OS X (10.6.8), 1.83 MHz
  • R C-R Level 6 Level 6 (14,870 points)

    The simplest way is to disable Java applets in the browser's preferences. If you visit a site that requires them either the features dependent on them won't work or you will get an error message saying you need them.

     

    Few sites use Java applets (not to be confused with Javascript) so in practice this works pretty well.

  • dymar Level 1 Level 1 (0 points)

    R C-R wrote:

     

    The simplest way is to disable Java applets in the browser's preferences. If you visit a site that requires them either the features dependent on them won't work or you will get an error message saying you need them.

     

    Few sites use Java applets (not to be confused with Javascript) so in practice this works pretty well.

     

    Thanks, what would I need to do if I found I that I did require the applet(s)?

     

    In particular, how would I identity which particular applet I needed?

     

    Also, how would I know that a missing applet was causing some feature(s) not to work in a situation where no error mesage was returned?

  • K.S. Level 4 Level 4 (3,690 points)

    dymar wrote:

    Also, how would I know that a missing applet was causing some feature(s) not to work in a situation where no error mesage was returned?

    Sometimes you have to dig to find out: http://earthnow.usgs.gov/earthnow_app.html

    doesn't tell you directly, but it is mentioned in the FAQ that Java is required. If the content is appropriate, you can always ask here.

  • R C-R Level 6 Level 6 (14,870 points)

    In particular, how would I identity which particular applet I needed?

    You don't need to worry about that. It is an all or nothing process, controlled by the browser preference.

  • dymar Level 1 Level 1 (0 points)

    K.S. wrote:

     

    dymar wrote:

    Also, how would I know that a missing applet was causing some feature(s) not to work in a situation where no error mesage was returned?

    Sometimes you have to dig to find out: http://earthnow.usgs.gov/earthnow_app.html

    doesn't tell you directly, but it is mentioned in the FAQ that Java is required. If the content is appropriate, you can always ask here.

     

    Thanks.  According to that webpage, my "Java is out of date."  When an error message like that is returned, I guess it's clear that "it's a Java problem."  Presumably, one would then just go to java.com and download the applet if he/she wanted to view the webpage.

     

    I was wondering more about situation when unexplained problems that involved missing Java applets weren't noted in error messages.

     

    But maybe I'm worrying about something that doesn't really need to be worried about.

  • dymar Level 1 Level 1 (0 points)

    R C-R wrote:

     

    In particular, how would I identity which particular applet I needed?

    You don't need to worry about that. It is an all or nothing process, controlled by the browser preference.

     

    OK, I'm not going to worry then.

     

    Thanks for the follow-up.

  • R C-R Level 6 Level 6 (14,870 points)

    dymar wrote:

    Presumably, one would then just go to java.com and download the applet if he/she wanted to view the webpage.

    Well, it isn't quite that simple. For Mac users, the download button at java.com will take you to http://www.java.com/en/download/apple_manual.jsp, which tells you that "Apple supplies their own version of Java" & you should get it from Apple via Software Update.

     

    That may change in the future -- see this article for more details -- but for now the latest Java version you can run on a Mac is whatever Software Update offers you.

     

    Also note that it isn't an applet. It is a "Java runtime environment" (JRE) that enables Java applets to run on systems with the appropriate JRE installed.