13 Replies Latest reply: Jun 19, 2012 7:21 AM by JeffNY
JeffNY Level 1 Level 1 (0 points)

Hi Everyone,


Last year I bought a new 17" MacBook Pro, that came with Snow Leopard 10.6. I think it was just before I got my new MBP that I got an invitation to try the Developer Preview of 10.7 and offer feed back. Well, after using my new MBP for a couple days and backing up everything with Time Machine to an external hard drive I downloaded and installed 10.7 Preview.


After a few hours of using it I was not happy with it at all (long story short, several things indicated to me this was a pretty early version of 10.7 and I didn't want to use it on this machine). So I erased the drive and restored everything from my Time Machine backup. That must have been around a year ago or so.


Now I want to add a 100 GB partition to this hard drive so I can install Lion on the new partition to try it again. But my version of Disk Utility (11.5.2 (298.4)) won't let me add a partition. It looks like it is going to add a partition but then I get "New partition requires a newer version of OS X".


I think when I installed the Preview of Lion it did something to my drive/partion for some of the new features it supports. But, if I can get a copy of the Disk Utility that comes with 10.7 would that run under 10.6? And let me add a partition?


Also, anyone know if I buy 10.7 now if that includes a free upgrade to 10.8? (I know, 10.8 is $19.99, just curious)




MacBook Pro, Mac OS X (10.6.8)
  • baltwo Level 9 Level 9 (62,210 points)

    Make a bootable backup/clone of your current installation on an ext FWHD, boot the machine with that, and then erase and REFORMAT the HD. That'll wipe out the partitioning map and remove all hints of Lion's Recovery HD. Now, repartition, restore the backup/clone, and install Lion.

  • JeffNY Level 1 Level 1 (0 points)

    It would be way easier if I could just use the latest version of Disk Utility on 10.6. Will have to think about this...


    But thanks,


  • Niel Level 10 Level 10 (289,775 points)

    The Disk Utility which comes with Mac OS X 10.7.4 won't run on 10.6.8. I have both installed and just tried to open it.



  • baltwo Level 9 Level 9 (62,210 points)

    Thanks for the feedback.

  • JeffNY Level 1 Level 1 (0 points)

    Thanks Niel for trying that for me, I guess the "easy solution" won't work hehe


    ahhhhh.....you guys have any recommendations for cloning my drive? Carbon Copy Cloner?


    BTW My thought the other day was to upgrade my 10.6 installation to 10.7, and just keep 10.6 on the 100 GB partition in case I needed it for anything. But then thought put 10.7 on the 100 GB partition to try first, make sure I like it. Decisions, decisions....





    Additional Info on the drive in my MBP:

    Capacity: 749.16

    Available: 627.78

  • baltwo Level 9 Level 9 (62,210 points)

    I only use CCC; however, I'm prejudiced since I moderated the CCC forums for over six years before Mike changed to a new Help Desk mode. IMO, it's still the fastest and most reliable. The model's changed to shareware based on donations.

  • JeffNY Level 1 Level 1 (0 points)

    The problem is, I don't have a spare 130+ GB external hard drive laying around to do this with. I have an external drive I use to backup to, but I don't like the idea of using that for this.....



  • JeffNY Level 1 Level 1 (0 points)

    Well, was just doing some reading and tried something; I restarted my MacBook Pro while holding down the Option key, and what do you know, the "Hidden" Revovery Partition was still there. And I had the choice to startup from my main partition or the "Recovery Partition" (also was given the choice what network to connect to).


    I am guesing there may still be a copy of Disk Utility on there from my "Lion Preview" install. And if I selected that to startup from I would get the opportinity to use that "Lion compatible" version of Disk Utilty on there (normally used in this case to attempt repairs on a damaged volume, but I suspect in this case I might be able to use it add a new partition to my hard drive).


    I am tempted to try this but wonder:

    1. Given this version of Disk Utility is from a "Lion Preview" release would it be reliable?

    2. Any chance if I boot from the Recovery volume that the latest version of Disk Utility for Lion would be downloaded and update the older version I probably have?


    Any thoughts? I am sure there are a few Apple engineers who could answer this, but they are all probably at the Developers Confrence this week



  • JeffNY Level 1 Level 1 (0 points)

    Some additional info; looking back at emails it appears I installed "Mac OS X Lion Seed Build" ("11A419"?) at the very end of March 2011, and after submitting some bug reports just wanted it off my machine. So the version of Disk Utility for Lion I have may be "old". But if I could boot from the Recovery volume and have the latest version of Disk Utility downloaded to update what I have that'd would be great....I would feel more comfortable trying this, but I just don't know if that would happen...?



  • JeffNY Level 1 Level 1 (0 points)

    Ok folks, so I just restarted holding down the Option key and selected the "Recovery" volume as my startup disk (and selected my AirPort Extreme as my network connection, and entered my password for it).


    The my MBP did boot up with the Lion background, and I got a menu of four options:

    - Restore from Time Machine Backup

    - Reinstall Mac OS X

    - Get Help Online

    - Disk Utility

    .....I believe this is collectively known as "Mac OS X Utilities", and it shows me "Version 1.0 (21)"


    Selecting "About this Mac" yeilds no info about what version of 10.7 this is, in fact no window even opens.


    The version of Disk Utility I have on the Recovery volume is "Version 12 (342) Copyright 1999-2010". So it appears I could use this to add a partition to my drive (I am worried it may be a little out of date though).


    I also tried "Get Help Online" and Safari opened, but it could not get to the internet.


    So, I am tempted to use Disk Utilities "Version 12 (342)" to add a partion to my drive. But before I do I want to ask if anyone knew if there is a a way I can get the "Recovery" volume to update itself? So I have the current version of "Mac OS X Utilities" on there?   (I am guessing a version of 10.7 has to be the "Startup Disk" (and running) to have Sofware Update update the software on the Revovery volume?)




  • JeffNY Level 1 Level 1 (0 points)

    I just found and downloaded the "Apple Lion Recovery Update" DMG file (from CNET of all places), hoping it would let me update the "Mac OS X Utilities" on my Recovery partition. It won't. It does not even show me the Recovery partition as a destination drive, and in fact says I need 10.7 to install it. I also tried to install it on a big USB flashdrive I have, could not do that either.


    My MBP does have the EFI Firmware 2.3 Update already applied/installed. But it appears I cannot get this "Apple Lion Recovery Update" into a drive or partition so I can use it unless I have 10.7 installed...


    Still debating what to do here.



  • JeffNY Level 1 Level 1 (0 points)

    Just tried to use Disk Utilities "Version 12 (342)" on my Recovery volume to add a partition, twice. Failed both times. Got "Partition failed. Partition failed with error. Couldn't unmount disk."


    Great. If anyone has any other ideas I'd love to hear them.

  • JeffNY Level 1 Level 1 (0 points)

    Ok Guys/Gals,


    I bit the bullet and decided to copy my system to an external drive using Carbon Copy Cloner. Seems to have worked, BUT something odd happened, I seemed to have "lost" 2GB of data when I copied my my system to the external drive and another 2GB when I copied it back to my MBP internal drive.


    Here is what I did  (total time over 8 hours, this is the short version of the story):

    1. One of the hard drives in my my old MDD G4 system was a 320GB drive, with two partitions, I copied all the files that were on one partition to the other, that gave me a partition with almost 200GB of free space to work with. More than enough. I then had to pull the drive from the computer...


    2. After I connected the drive to my 2011 MBP I discovered the old Firewire hard drive enclosure I had handy only supported drives up to 130GB! So I found my "USB 2.0 to IDE/ATA Cable Adapter", and tried that. Only to get a warning from Carbon Copy Cloner saying I may not be able to use the copy to restore a system because Intel Macs need a different set up or something, I forget the exact wording. So I hooked the drive back up to my MDD G4 (via USB 2.0) to copy ALL the files off that drive so I can erase the whole drive using Disk Utility on my OS X 10.6 MBP.


    3. After that was done (I now have about 4 hours into this so far) I connected the 320GB external drive to my MBP and erased it, so it had just one big volume/partition. I then used Carbon Copy Cloner to to copy my system to the external hard drive using USB 2.0. Before I began the system reported my internal drive has a capacity of 749.16GB and that I used 120.74GB of that.


    After I copied my system to the external drive (2 hours 10 min) I used "Get Info" on the two drives and got this:

    Internal Drive:  Capacity: 749.16    Available: 629.61   Used: 119.55

    External USB drive reported this:

    Capacity: 319.73   Available: 202.7    Used: 117.03

    ….You can see almost a 2GB difference in the space used.


    I then booted off the USB drive and used Disk Utility to erase the internal 750GB drive and add two 30GB partitions to my internal drive, and then used Carbon Copy Cloner to copy my system back to the internal hard drive (1 hour 16 min) and got this:

    External Drive:  Capacity: 319.73   Available 202.66   Used: 117.07

    Internal Drive (after I also added two 30GB partitions)

    Capacity: 689.81      Available: 577.72     Used: 112.09


    Both times Carbon Copy Cloner reported it copied 114.22GB. But I started with 120.74GB (or 119.55GB), but when I was done copying my system to the external drive and back I ended up with 112.09GB. After restarting "Get Info" reported my internal drive used 116.79GB. So 119.55 - 116.79 = 2.76GB "missing".


    I did do a Time Machine backup of my internal drive to another external hard drive before doing all this. Does anyone know of a utility that would compare the contents of my internal hard drive to my Time Machine backup so I could see if I lost any important files while using Carbon Copy Cloner?