1 2 3 Previous Next 31 Replies Latest reply: Nov 1, 2012 9:43 AM by downtownmb
John Reed6 Level 1 Level 1 (5 points)

I think it's happened since maybe the most recent OSX upgrade, but now I seem unable to connect to Photostream with either iPhoto or Aperture on my MacBook Air. Oddly, with the same software and settings, my old MacBook Pro 17" has no trouble connecting. What could be the issue? Whenever I try to enable Photostream, I get the "connecting..." dialog for a few seconds, then "Aperture (or iPhoto) is unable to connect to Photostream."


MacBook Pro, Mac OS X (10.7.4), MacBook Air
  • 1. Re: Aperture and iPhoto can't connect to Photostream
    bmorebill Level 1 Level 1 (0 points)

    Same here!

  • 2. Re: Aperture and iPhoto can't connect to Photostream
    mcpccea Level 1 Level 1 (0 points)

    Yep, tried 4 different iMac and Laptops and no luck here either.

  • 3. Re: Aperture and iPhoto can't connect to Photostream
    nikon is Level 1 Level 1 (0 points)

    How is this marked as solved with no solution?

     

    "aperture was unable to connect to photostream"

  • 4. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    I have no idea why is got marked "Solved," as it's still a big issue with me. I've been escalated up a couple of levels within the AppleCare tech support hierarchy, and maybe one of these days... ?

  • 5. Re: Aperture and iPhoto can't connect to Photostream
    sberman Level 7 Level 7 (24,490 points)

    One simple thing comes to mind ...

     

    Looking at System Preferences --> iCloud:

     

    1.  Are you signed in (do you see your name in the display)?

     

    2.  Is the Photo Stream box checked?  (I've found some issues related to administrator privilege here.)

  • 6. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    Yes, my name does show in the display, and the PhotoStream box isn't checked. You see, I first check it before going to iPhoto to request PhotoStream connection. When iPhoto finally rejects my request (i.e., "iPhoto cannot connect to PhotoStream"), the once-checked box will always be unchecked. Thanks for looking.

  • 7. Re: Aperture and iPhoto can't connect to Photostream
    sberman Level 7 Level 7 (24,490 points)

    OK, I think you're close to a solution

     

    Get your iCloud PhotoStream box checked, don't open iPhoto or Aperture yet, and see if you can keep that box checked for a while (e.g., across a system restart).  Bottom line: the box should never be unchecked after you've checked it.  If it is, make sure you have some machine administrator insert the check in the box.

     

    I learned about this because I got some message about privilege when it disappeared.  I wish I could tell you more about my experience, but I do know I had to clearly be a machine administrator to get the check to remain ...

  • 8. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    Tried your suggestion. Quit Aperture and iPhoto, checked PhotoStream in the iCloud preferences. Shut down computer, restarted. PhotoStream box still checked. Started iPhoto, tried again to connect to Photostream, and the final result was the same as usual, i.e., couldn't connect, and iCloud box unchecked again.

     

    I dunno what you mean by "machine administrator;" as far as I know, I am he.

  • 9. Re: Aperture and iPhoto can't connect to Photostream
    sberman Level 7 Level 7 (24,490 points)

    First, let me clarify "machine administrator":

     

    In System Preferences, check the "Users and Groups" area to see if the account you're using says "Admin".  Hopefully it does.

     

    Now, one more suggestion for your scenario above:  When you start iPhoto, in Preferences --> Photo Stream, are all the boxes checked there?  It seems they got unchecked during my related fiasco.

     

    Thanks.

  • 10. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    I am indeed shown as "Admin" in accounts. All but one of the other boxes in iCloud's box column are checked, the one omitted one being "Back to my Mac." They don't seem to get changed by the PhotoStream issue.

     

    This is a strange issue. I have an older MacBook Pro, circa 2009, running what seems to be the same software and settings, and it does fine with PhotoStream. Moreover, even this machine ran fine with PhotoStream when I first started using it, but something happened along the way to defeat it. I don't know, maybe upgrading the system version from original 10.7.1 or so to the current 10.7.4 has something to do with it?

     

    Just today, I upgraded iPhoto to the 9.3.1 version, but still get the same issue recurring...

  • 11. Re: Aperture and iPhoto can't connect to Photostream
    sberman Level 7 Level 7 (24,490 points)

    It certainly is a strange issue!

     

    Let me clarify the boxes I'm asking about -- not the iCloud's box column, but I'm asking about iPhoto preferences.

     

    When iPhoto is open, if you go to its menu and go to iPhoto --> Preferences... --> Photo Stream, you will see three boxes: Enable Photo Stream, Automatic Import, and Automatic Upload.  Are all those checked?

     

    Thanks.

  • 12. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    Nope. When I check "Enable Photo Stream" on the top checkbox, the other two options, initially greyed out, get checked, but after the little spinning disk icon spins for a few seconds, the dreaded "iPhoto was unable to connect to Photo Stream" message comes up, and all boxes wind up unchecked.

  • 13. Re: Aperture and iPhoto can't connect to Photostream
    sberman Level 7 Level 7 (24,490 points)

    OK, I have a suggestion ---

     

    On the surface, my suggestion will seem completely unrelated, but I'm fairly certain it can't possibly do any harm.  Further, it was helpful in solving my similar (but not identical) problem.

     

    I know this article refers to iTunes, but maybe your problem is also caused by a permissions problem with your "shared" area.  What do you think about trying the sudo commands using the Terminal utility as explained in this article: http://support.apple.com/kb/TS1277

     

    My thought is it may help, and there's nothing to lose.

  • 14. Re: Aperture and iPhoto can't connect to Photostream
    John Reed6 Level 1 Level 1 (5 points)

    I'm a little bit leery of using that chmod command, fearing it could have unintended side effects. I think the "1777" enables the file or folder (everythting in the Shared Folder, the way it's written) for r/w. If I knew what it was changing FROM, I'd be more gutsy?

1 2 3 Previous Next