8 Replies Latest reply: Jun 13, 2012 6:38 PM by X423424X
sdflyguy Level 1 Level 1

Apple Mail stopped working after replacing and restoring the Main Hard Drive in the upper bay.  Internet connection is good, and the Mail client troubleshooting (Comcast) was no help.  I can start the App, but it does not retrieve or send mail through Comcast anymore.  I have a MacBook Pro with the same settings and Mail works fine.

Power Mac G5, 1.8ghz, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10

    In Mail's Window Menu, choose Connection Doctor, any red dots for status, if so what is the message?


    Then click the Show Details button & Check again.


    Also open Mail's Activity window, any clues there?

  • sdflyguy Level 1 Level 1

    Thanks for replying.


    This is odd because my PowerMac G5 with Leopard Mail cannot receive or send email.  Connection doctor is showing all red dots on every email account with Comcast (BTW, GMAIL accounts okay).  On my Blackberry, and my MacBook Pro (Lion), the setting are all the same, passwords, etc., and the later two have no issues.  I even created a test Administrator Account in "Accounts" in System Preferences on the G5, logged into the Test Account and tried to create a new mail account with the same settings, and yet during the set-up (Welcome to Mail), I get an error message that says Mail cannot log into Comcast's POP server with the current settings.  I have also tried changing passwords, no help. Also the usual disk repair, permissions,  motherboard resets, zapping PRAM, etc.


    Out of ideas...


    Thanks for any help...

  • BDAqua Level 10 Level 10

    See if changing the ports & Authentication helps...



  • X423424X Level 6 Level 6

    sdflyguy wrote:


    Apple Mail stopped working after replacing and restoring the Main Hard Drive in the upper bay.


    How did you restore the drive?


    Did you give it the same name or is this a boot drive?

  • sdflyguy Level 1 Level 1

    Thanks for replying, sorry I could not respond right away.


    I have changed the ports back and forth from 587 to 465.  I also used Network Utility and did a port scan to see if they were blocked by Comcast.  Ports are good, but still no change.

  • sdflyguy Level 1 Level 1

    I installed the new drive ( a Mercury Electra SSD from OWC) in the Upper bay and the original drive in the lower bay.  I started up the G5 with the Leopard install disk and used Disk Utility to Format the new drive and copy the old drive to the new drive.  I gave the new drive a new name. After completing the start up, I checked the new drive and it started okay, unmounted the old drive, shut down and physically removed it.  Then Mail stopped working with Comcast.


    Very strange.

  • sdflyguy Level 1 Level 1

    The next thing I am going to try is unplugging and reseting both the Comcast supplied broadband modem, and my network router.

  • X423424X Level 6 Level 6

    Oh there's a router in the mix.  Skip it for testing purposes.


    Did Mail's Connection Doctor show any useful info about what the problem is?  BDAqua suggested you try that at the beginning of this thread.