1 2 3 4 5 Previous Next 64 Replies Latest reply: Jun 20, 2012 4:18 PM by André Tenenbaum Go to original post
  • 15. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Hi Léonie:  Well the repair completed and it looked like it indicated approximately all my versions were restored.  However, when Aperture finally opened, very few of my images are there.  It appears as if the omissions are by project.  In other wirds, if one photo is present in a project, then all are.   Unfortunately I can't be 100% sure that all are present if any are in a project.  However, most of the projects are completely empty.

     

    Also, I need to leave for a meeting in Denver, so I won't be able to respond for several hours.  But I would really appreciatge any additional ideas.

     

    Thank you

    Ted

  • 16. Re: Aperture 3.3 upgrade failure
    léonie Level 9 Level 9 (51,665 points)

    Is there a folder "Recovered items"? Sometimes Aperture stores images, that cannot be assigned to projects in a kind of "lost and found" folder.

     

    Check the search fields, if any filters are set.

     

    Is your library referenced? Can it be, that you cannot see some images, because the original masters are missing?

     

    If none of this applies, you might try the last Library First Aid and add a "Rebuild Database".

     

    Regards

    Léonie

  • 17. Re: Aperture 3.3 upgrade failure
    t7000 Level 1 Level 1 (0 points)

    Hi ted_s,

     

    My guess is that Aperture is rebuilding all the snapshots, and before it's done you can't see anything in projects.

    Check if your Aperture is "processing" something.

  • 18. Re: Aperture 3.3 upgrade failure
    t7000 Level 1 Level 1 (0 points)

    Sorry please ignore my last reply. I now have the same issue as ted does.

    Although in the process it says thousands of versions were restored, when it's done only a few are available in the "Recovered Project." All is left are empty projects. I've tried all the three options of the first aid tool but to no avail...

  • 19. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    HI t7000:

     

    Aperture is "processing"  so maybe you're on to something.  However, I am able to see some snapshots in some projects.  When I left several hours ago, I closed Aperture, so unfortunately I didn't have it running continuously.  I'll let it run overnight if necessary to see if it finishes whatever it's doing.  I have a very large library, over 70GB, so I know some of this is a slow process.

     

     

    Hi Léonie:

     

    I could not find a "Recovered Items" (or somolar) folder.  Part of my library is referenced, but the more recent downloads are not.  The missing versions definitely span both the referenced and non-referenced files.  I'll wait until tomorrow to see whether Aperture finishes processing.  If not, I'll kill it and restart by tryng that third Library First Aid approach.

    --------------------

     

    If none of these work, do either of you see any danger in trying to reload my library from my backup vault?  Or could this create additional problems?

     

    Thanks again both of you.  Your suggetions have been very helpful.

     

    Regards

    Ted

  • 20. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Guys:  I've been monitoring Aperture's Activity Log.  It is indeed slowly generating Preview and thumbnail versions.  Looks like I have over 19K files (guess I need to do even more clean up), and it has processed about 25%.  So running it overnight may do the trick.  I'll keeo my fingers crossed. 

     

    t7000, perhaps you are experiencing the same processing lag.

     

    I'll send an update in the morning.

  • 21. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Well, Aperture finished processing all my previews.  However, I still can't see them.  As before, most of my projects show zero files in the library.  I guess I'll try the other First Aid option, but based on t7000's experience, I don't expect much out of it.

     

    Any thoughts on doing a recovery from the Vault?

  • 22. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Hi t7000.  I created a new library and am doing a restore from my Vault.  Let you know how it goes.

  • 23. Re: Aperture 3.3 upgrade failure
    t7000 Level 1 Level 1 (0 points)

    Hi ted,

     

    Looking forward to hearing some good news from you. I'm now trying to extract all the RAWs from layers of folders.

  • 24. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Restore completed.  However because the vault files were from an earlier version, I had to relaunch Aperture and am now going through the entire Upgrade process again on this new library.  Fells like deja vu.  More later.

     

    If this doesn't work am thinking of trying to reload my old version of Aperture from TimeMachine.  Ugh!

     

    Only thing that's somewhat reassuring is that I think my library does have the files.  It's just getting them connected properly. 

     

    Also wanted to let you know that the Aperture team at Apple saw our thread and contacted me.  I'm sending them information so they can try to reconstruct the issue and understand what happened and fix whatever the issue is.  I'm pleased that they initiated this contact and are taking the lead in addressing it.

  • 25. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    t7000:

     

    Well I'm back in business!!  The Vault resore and subsequent rebuild worked!!  What a painful process.  DO you have a vault backup you coul use?  For future protection I am thinking of using referenced masters exclusively so that if something like this happens again & I can't recover, at least I'll have the originals of everything. 

     

    How are you doing with your manual master restore?

     

     

    Léonie: 

     

    I also wanted to thank you so much for you help.  It got me over the first hurdle when things were looking the most grim.  Hopefull Apple will be able to reconstruct and fix the issue and release a patch for 3.3.

     

    Regards

    Ted

  • 26. Re: Aperture 3.3 upgrade failure
    léonie Level 9 Level 9 (51,665 points)

    You are welcome, Ted,

    I am very glad you could recover your Library!

     

    I am still concerned, though:

     

    Part of my library is referenced, but the more recent downloads are not.

     

    Your vault will only have contained the managed images. Could you reconnect your referenced masters/originals?

     

    Regards

    Léonie

  • 27. Re: Aperture 3.3 upgrade failure
    ted_s Level 1 Level 1 (0 points)

    Léonie. 

     

    Thanks for your concern and the great question.  I've done an extensive check and the referenced masters' locations are known by Aperture.  Just to be sure, I've also done a few spot checks to make sure Aperture successfully can get to the master, by creating a new version from the original; & that appears to work as well.

     

    Thanks again for the question.  I hadn't done that check before you inquired.

     

    BTW what kind of photography do you enjoy?

     

    Regards

    Ted

  • 28. Re: Aperture 3.3 upgrade failure
    martinfaint Level 1 Level 1 (0 points)

    Having read through this thread I am having many of the same problems after upgrading and have tried many of the same solutions. At one point I opened my 50K photos library to discover only 116 were visible and even some of those were corrupted.

     

    To make the nightmare worse after I discovered the upgrade process was hanging after step 5 I restored my whole 500GB library to my iMac from Time Machine, without deleting the corrupt library. I should have foreseen this happening: Time Machine then backed up my now giant internal HD, overwriting all previous backups. Yikes!

     

    Now I'm pretty nervous. I'm trying to rebuild the library from the Aperture First Aid right now, and I assume it will take a long time. I'll be buying another HD tomorrow to make an extra backup of my uncorrupt version 3.2 library.

     

    I have to say this is about the third time I've spent multiple days trying to undo some horrible mess caused by Aperture and I have just about lost all faith in it.

     

    I'll update you on how the rebuild goes.

     

    Good luck everyone!

  • 29. Re: Aperture 3.3 upgrade failure
    Jim Bridger Level 1 Level 1 (5 points)

    Wow, I can't believe what I'm reading. How is it that these upgrades with Aperture produce so much turmoil. I'm having the same Upgrade Failure issues. I've tried twice now to Upgrade a library with 400,000 images and twice it first stopped at the 4-10 steps. Just hangs. I shut it down, start it again and it tells me it's damaged. I do repair permissions and off it goes to 6-10. Then crashes. I try to open the library and have to go through all three of the First Aid processes finally reuilding the catalog. All of this has taken two full days so far and still no luck. This is just so hard to believe. I have time machine backups that I've had to pull from twice. No current Vault since my issues first started several weeks back with issues with the RAW OSX update that didn't like Lumix GX1 files. Lots of troubles started then and kept me from getting a quality current Vault in place. Thankfully, all images are referenced so I don't have Aperture hijacking my originals. Thank god those are safe. However, about 50,000 images will be missing Metadata if I can't get this catalog up and running. This is the reason I've put a suggestion into Apple several times in the past year to give us the XMP side car files that Lightroom has. I came over from Lightroom having worked with that program for four years. My time with Aperture has been incredibly rocky and unstable from the get go. I justified moving to Aperture due to the better ability to work with all other Apple programs but it's looking like enough is enough! I've wasted so much time trying to love this program and if I can get my catalog up and running I most likely will be looking for a way to get the Metadata exported and into Lightroom. This is so disappointing and virtually almost impossible to believe.

     

    It really is a bad sign when an update like this comes out and there's virtually nothing but one thread after another that is an issue of some sort. It's not uncommon to have some but one after another after another after another. Incredible with a capitol I.