Previous 1 2 3 4 5 Next 64 Replies Latest reply: Jun 20, 2012 4:18 PM by André Tenenbaum Go to original post
  • Christinag612 Level 1 Level 1 (0 points)

    Hi,

    I am having the same upgrade issue. Mine gets stuck at step 7. I did a disk repair and it said everything is ok. When I open my library all of my folders are still there but no photos. I have tried some of the suggestions to no avail.  I do have most of my photos backed up on Time Machine, but neglected to back up the last senior photo shoot before I did an upgrade. Any ideas that may get it all back would be greatly appreciated.

  • ted_s Level 1 Level 1 (0 points)

    Did you have any of your photos backed up using an Aperture vault?  I was able to recover by creating a new Aperture library and then doing a restore from the vault into that library.  Of course that didn't include my most recent set of images that weren't yet backed up, but fortunately I had not yet deleted them from the camera's memory card.

     

    Another thought is that assuming those photos backed up on Time Machine are your masters, you might be able to re-import them into a new library.  This wouldn't recover any adjustments you've made, but at least you'd have them.

     

    During my recovery process, Apple had suggested reloading my previous version of Aperture (3.2.4, I think) and linking back to my library that way.  I never attempted that, but possibly, since you're using Time Machine, you could go back to before you loaded 3.3 and restore the older version.   You might try creating a new user on your Mac or something, so that the two versions don't get mashed up somehow.  If this worked, you'd presumably have all your images.  Only good news is that your library of images is probably there.  It appears to me that the problem is with 3.3 not being able to see them appropriately.

     

    Good luck.

  • drolling Level 1 Level 1 (0 points)

    So I thinking I'm having the same problem as everyone else.  The upgrade process went smoothly until Step 10 of 10.  For the last 24 hours I've had a chicld window saying, "Upgrading: Step 10 of 10 (99% complete)"

     

    I don't shoot much RAW (yet) and have a modest 131GB collection.  The application has not hung (I checked).

     

    Should I kill Aperture and restart?  I'm not intersested in opening my Vault or remoting my backup if at all possible.

     

    UPDATE (6:00p EST):

    I killed Aperture process and restarted the application.

    It prompted me to upgrade the database.

    This time it stepped through 7 steps (verse 10 before) and I'm prompted with, "Upgrading: Step 7 of 7 (99% complete)"

  • jasonfromsanta barbara Level 1 Level 1 (0 points)

    I am having the exact same experience. Library has been hung at "Upgrading: Step 10 of 10 (99% complete)" for over 24 hours. The application seems stable and is somewhat responsive, it just isn't finishing the upgrade. I've had vault updates take days before on this large library, but they go over a network and so are slower. This seems like a lost cause. Any thoughts about how to restart the process, or if there is a better way to handle this than "Force Quit with fingers crossed"??

  • drolling Level 1 Level 1 (0 points)

    So its been 2 hours and 20 minutes and still "Upgrading: Step 7 of 7 (99% complete)".  The library file maintains a date/time stamp of 5:52p EST today so its not refreshing the date if its doing anything.

     

    I'll let it run over night and report back tomorrow.

  • jasonfromsanta barbara Level 1 Level 1 (0 points)

    2 Hours since last post. No change...

     

    Upgrading: Step 10 of 10 (99% complete)"

     

    Losing hope...

  • p.andersen69 Level 1 Level 1 (0 points)

    Losing hope to. What a disaster........

  • léonie Level 9 Level 9 (77,995 points)

    @drolling + jasonfromsanta barbara

    "Upgrading: Step 7 of 7 (99% complete)".

    If it is hung without progress for hours,

    Force Quit and try to "Rebuild" using the Aperture Library First Aid Tools, if you have not done so already.

     

      Hold down the command and options-key combination (⌘⌥) while you launch Aperture, and try if the "Rebuild Database" tool works on your Library. For many this did fix the problem.

     

    Regards,

    Léonie

  • martinfaint Level 1 Level 1 (0 points)

    I would add to that try to find a backup of your old library and keep that in addition to the one you are working on. I would keep at least one untouched old library handy if you can. That way you know you can't lose everything.

     

    I was able to fix the permissions on my restored 3.2 library, but attempting to fix the 3.3 never worked for me.

     

    Good luck!

  • Jim Bridger Level 1 Level 1 (5 points)

    So my last post on this issue was June 13th and today I walk in to the studio to see if the suggestion by Aperture Phone support worked. They suggested that I make a brand, new fresh library and Import the old (Library with issues) in to the new library. Well that was six days ago and after watching it go through the process for six days, progress bar making slow and sporadic movements forward, this morning I'm greeted with the Aperture Crash window, the one that gives some sort of report and is sent to Apple. I click on reopen and up comes 98% of my projects, some missing. I click on one of the projects and though it shows an image in the Project window NO PHOTOS EXIST in the project itself. It shows 0 for number of photos in project and I get an empty screen when I click in to the project.

     

    Interestingly I was also contacted by Dave at Apple Support via my previous thread and was asked if I would be willing to send my library to Apple for review. I agreed whole heartedly. That was two days ago and I've never heard back from him. Was jazzed I might be getting some help, but so far no response to my agreement to send them my 435GB Library. I use Aperture for my business virtually everyday and I've been dead in the water since the release of the new Aperture update.

     

    For those of you who might be interested in why I've not been shut down completely, due to this failure on Apple's part, it's because I also use Lightroom. Even with all the problems, I plan to keep moving forward with Aperture but just to make sure I'm never at the mercy of a situation like this I run both programs. It's not tough to do since I use a Referenced Files workflow with both programs. Costs a little more to have both and there may be a day I move to just one, but for now at least I'm protected. Good luck to everyone fighting this ridiculous problem!

  • martinfaint Level 1 Level 1 (0 points)

    Jim, I'm sorry if you have already covered this one - did you have a backup of the unaltered 3.2 library?

     

    If so did you try fixing the permissions in the library before launching it? That's how I fixed my problem.


    If you do have that backup library I would duplicate it again though and try the experiment on the duplicated library so you still have an original copy of 3.2 that can't get messed up.

     

    Good luck.

  • jasonfromsanta barbara Level 1 Level 1 (0 points)

    OK, Day 4, or 5 - who can remember?

     

    No progress.

     

    "Upgrading: Step 10 of 10 (99% complete)"

     

    - Fortunately, my workflow is based on external drives (so we can launch from many computers. Side note, I used to keep all the libraries on a linux server running AFP, and this worked great for 2 years, but eventually started having permissions problems and errors, so went back to sneaker net).

     

    We have Aperture Drive 1, which is the working drive for photo work, and a clone of it (Aperture Drive 2) which is kept as a backup as well as used for creating vaults on our server (so as not to tie up the production drive all the time). Additionally, we back up all images as RAW files on the fileserver on import.

     

    So I had to go back to the clone, which was missing the last import. I reimported the missing images from the RAW backup on the server and am making a new vault from the clone library before trying to upgrade again. I guess I will do a disk repair on the external drive, and do a permissions repair on the library, before attempting to upgrade the database again. Will report back...

  • lips Level 1 Level 1 (30 points)

    Good luck everyone. The ONLY thing that worked for me was to replace my 3.3 with an onlder copy of 3.2 then restore my database from a timemachine backup. It is obvoius to me that Apple really doesn't have a pro version of Aperture ready or in the works. I'm jumping to LR4 as of today. Wish you all the best.

     

    Mark

  • léonie Level 9 Level 9 (77,995 points)

    and do a permissions repair on the library, before attempting to upgrade the database again. Will report back...

    A permissions Repair may not suffice - Apple's recommendations are to "rebuild" the library before upgrading a library to a new version - see the Aperture 3 Release Notes ( you have to scroll down far to the bottom of the page to see this tidbit ).

     

    The problems we are discussing here probably are caused by corrupted libraries -inconsistent entries in the database files. A permissions repair does not help in this case.

  • jasonfromsanta barbara Level 1 Level 1 (0 points)

    SUCCESS!!

     

    So before doing all that complicated stuff I mentioned before, i forced quit, an took the drive to another mac and did a rebuild on the recently upgraded database/library. It took 10 minutes and popped right open...

     

    I am just starting the process with rebuilds on other pre 3.3 libraries, and it seems to do a nice job of cleaning up and upgrading them. Just did a small library (33Gb) and it rebuild, upgraded and opened in about 10 minutes total.