Previous 1 2 3 Next 41 Replies Latest reply: Jul 21, 2015 6:18 PM by flash7gordon
wsaggie1 Level 1 Level 1 (0 points)

Itunes download error "You do not have enough access privileges for this operation"

iPod nano (3rd generation), Windows XP
  • b noir Level 9 Level 9 (72,035 points)

    What's the full text of that error message, please? (There's a few different ones I can think of that you might be getting.)

  • wsaggie1 Level 1 Level 1 (0 points)

    There were problems downloading some purchased items.

    For more information on the items that could not be downloaded, click below.


    There was a problem downloading

    You do not have enough access privileges for this operation.

    Please check that the connection to the network is active and try again.

  • atobteam Level 1 Level 1 (20 points)

    Had the same thing happen to me today.  Go to User(your home folder)/Music.  Select/highlight your "Music" folder.  Then do Command-I ("Get Info" from the File menu), click on the padlock icon in the lower right of the new window.  Enter your user password.  Click on your username just above the now-open padlock.  Select "Read & Write" if it's on "Read Only," "Write Only," or "No Access."  Now having your user account with "Read & Write" privileges (it may have been this way already; still do this next step), click on the gear on the bottom-center of that window.  Click on "Apply to all enclosed items."  When the pop-up says "Are you sure?" (or the equivalent), say "yes."  This will grant access privileges to your user account for all the music files inside your music folder--all your iTunes stuff included).  Then you should be good to go.

  • Mike Jawn Level 1 Level 1 (0 points)

    Thanks atobteamthat tip solved the problem for me. I was starting to get very frustrated.

  • atobteam Level 1 Level 1 (20 points)

    You're welcome!  Glad it worked for you, too.

  • huff95 Level 1 Level 1 (0 points)

    atobeam's suggestion fixed the same problem for me.  Thanks!

  • Bill Page Level 1 Level 1 (5 points)

    I've been experiencing this issue for several months. I knew to try to repair permissions AND changing the Read/Write status on the iTunes folder in the Finder.


    However, none of these remedies resolved my issue.


    I had to basically setup a brand new iTunes library, download everything from the iTunes Store and setup every single device associated with iTunes all over again.


    Now that I've done this, it's been 1 week without any issues...until today.


    I've repaired the permissions more than I care to admit. Nada.


    I've got the iTunes folder (and everything within it) so writable that my dog has access to write to the folders... (yes that's you can grin)...


    ...aaaand still iTunes will NOT let me add any media, downloads, or anything to the library because I do not have access privileges. I want to shoot myself. This has been hours & hours of repairing, restarting, setting another itunes library, moving everything again and again...


    Something's got to be wrong at the root level and this is affecting my phone, and all other devices... Can anyone help?


    (By the way I'm not a total noob since I've been using and advising with Apple products for over 20 years--so any advice you can bring OTHER than repairing permissions and "Get Info" in the Finder will be most appreciated.)

  • atobteam Level 1 Level 1 (20 points)

    Hi, Bill,

    I hate to ask, since this refers to my "get info"-related solution above, but I'll ask anyway just in case.  Two  things:

    1.  Did you highlight your whole "Music" folder under your User folder?

    2.  After you gave write access to your dog (ha ha!)  , did you click on the gear-looking icon on the bottom-center of that get-info window, click on "Apply to all enclosed items," and when the pop-up said "Are you sure?" (or the equivalent), click on "yes"? 

    This gear maneuver was the key for me and others above.  The mere giving of write access didn't do it.

    You may have done all that already.  Hope this or something else quickly gets this solved for you!

  • Bill Page Level 1 Level 1 (5 points)

    Hey there!


    To answer your questions (just to remove these items from consideration)...


    1. Yes I did highlight the entire music folder.


    2. I did apply the new permissions (that included my dog) to every stinkin' thing inside every folder imaginable. So yes, I did click "Apply to all enclosed items." And yes, I did click "yes" when it asked me "if I was sure."


    Oh trust me, I wouldn't have even posted my reply if I hadn't even done that. I actually knew to do this procedure AND repair permissions before coming to the forums.


    I just noticed I did not mention that my iTunes media is all so large, I had to place it on an external drive (it's been on that 1 TB drive for several years now). And yes, I did the same procedure to THAT music library & media folder as well...multiple times. Again, again, and again...and one more time to be sure.


    Still nothing...


    Up to now iTunes has worked great and I've loved it, but now these issues have seriously affected all my devices (and I do mean ALL of them). I have had to reset my iPhone, iPad, and AppleTV too many times to accommodate this procedure.


    I'm so frustrated with all this "new" they keep giving us. I love new stuff. I love fixes. But if it isn't broken, why "fix" it? I still wonder if this has something to do on the root level. Some preference file somewhere probably needs to be trashed and then it would all be fine. I just don't know which...


    Again... I want to blow my head off... (sarcasm only folks...nobody needs to call the po po).

  • kneedrag32 Level 1 Level 1 (0 points)

    I'm in the same boat as Bill Page - I can't get rid of this error.  I've tried everything mentioned in this post. I can download songs/apps to my iPhone, but they won't sync to on my Mac.


    I hypothesize that this has something to do with my iTunes / iCloud ID being different, since I started getting this error around the time that I synced with the cloud. What do you think?


    Here's the detail:

    Years ago - before owning a Mac - I bought an iPod and set up my Apple Store ID using a Yahoo email address.  A few years later I got smart and bought a Mac & signed up for MobileMe - thus creating an email address.  With the recent iCloud updates, I now have a separate iTunes/Apple Store ID (Yahoo email) and separate iCloud ID (


    Any thoughts on whether the iTunes vs. iCloud IDs are causing an issue?

  • kneedrag32 Level 1 Level 1 (0 points)

    For the fun of it, I tried the Read & Write trick again... and it worked. It must have been the computer's fault right? Not user error... right? RIGHT?  doh.

  • Robynize Level 1 Level 1 (0 points)

    I don't get anything when i push command i. file menu doesn't have get info option. any other suggestions, please? Im tearing my hair out. this never happened to me bf, and now, i can't download my fav tv show that i have a paid season pass to!!



  • atobteam Level 1 Level 1 (20 points)

    Double-click on your user file ("Robyn" or whatever) within your hard drive (to do this:  double-click your hard drive icon on your desktop, then double-click the folder called "Users," then double click your "user file," which you titled when you first got your computer:  "Robyn" or whatever).  Then you should see a list of folders that includes "Music."  Single-click this (just single-click), just to highlight it (not to open it).  Thus, you should now be looking at the list of folders that includes "Music," with the "Music" folder highlighted.  Now, go to "File" at the top line of your screen  and drop down to select "Get Info."  Then follow the rest of my instructions in my first post in this discussion.


    I hope that does it for you!

  • kennethfromwest end Level 1 Level 1 (0 points)



    I often have the same issue.  I just looked at my itunes folder and noticed that some of the songs I recently purchased from my computer were showing up outside their folder.  For example, I downloaded "Too Close" by Alex Clare.  The song was located on its own in the "itunes media" folder and nothing was located in the "Alex Clare/The Lateness of the Hour" folder.  I double clicked on the music file and it disappeared.  It showed up in the Alex Clare/Lateness of the Hour folder.  I did that for all the other rogue music files that were listed under "itunes media."  I tried to sync, and it worked without getting the access privileges error.

Previous 1 2 3 Next