Previous 1 2 3 Next 44 Replies Latest reply: Dec 10, 2015 3:57 AM by kennygwood Go to original post
  • fcphun Level 1 Level 1

    I have same problem as Bill... have tried the suggestions in this thread and still get that danged error message.

    What this means is that I get no new podcasts, which renders my iPod useless and my iPhone less useful.

    Super frustrating... have spent several hours trying to figure this out.
    Does anyone think that deleting iTunes entirely and reinstalling it would work? My fear is that I have some old tracks burned from CDs in my library, and that I might lose them?

    I am really missing my weekly does of This American Life and RadioLab.


  • fcphun Level 1 Level 1

    Oh happy day. I now have Ira back in my life.

    Anyway, while the "Read Write" fix by itself didn't work by itself, I was able to get this fixed finally. Here's how:


    1) I found this post: about shared folders, screwed up my courage and went into Terminal and pasted in the 'sudo..." command.

    2) Then I went to the music folder, checked privilges were at "read write" and hit the update on the gear menu.


    3) Then I restarted my mac.


    4) I opened iTunes, clicked on refresh podcasts and it worked.


    I don't know about dents in the universe, but this kind of crap is really putting a dent in my view of Apple. Problems that show up out of nowhere are not what I expect from the supposed design leader. Recent comments/reviews of the new OS have me concerned that they have some real issues on the software side these days. Bug free, user friendly, rock solid... that isn't Apple, that's Dropbox.

  • nodenetter Level 1 Level 1

    We have the exact same issue. I've tried every possible resolution, chenged permissions, took ownership of the directories, command line. My wife finally decided to give up on iTunes and is buying stuff from Amazon and Google music from now on. This is really annoying.


    I've been a faithful apple user for the last 10 years, but enough is enough. We both decided to buy Androids and will probably end up getting Windows 8 laptops. We are done with Apple, it's not the same it used to me. The new software just *****. Sorry Apple, you've gotten too big. And I know I am not alone in being dissatisfied. All Apple carss about is making money. They've turned their backs on their customers. Guess what? You will slowly decline, because we're on to you. Build inferior crap, just care about profit, and guess what, we will all leave.

  • winklerjw57 Level 1 Level 1

    I had this same error after creating a backup image of my boot drive.  But I had not included the "Shared" folder on the destination disk.  iTune uses, and requires, access to this shared folder for temporary files to support the sharing capabilities.  This Shared folder is the one that is parallel (or at the same level as) your personal folder just under the Users folder on your main drive.  Make sure that folder exists, and everyone has read/write permission there.


    - jw -

  • nodenetter Level 1 Level 1

    Tried fixing the "Shared" folder permissions as well, it didn't fix the issue. Maybe the right chmod at the command line might work. But of course, no peep from any Apple support person as to the right approach.

  • Webhead68 Level 1 Level 1

    Dude you rock, I've been f'in witht this for the last few hours.

  • co5 Level 1 Level 1

    I had the same problem, I solved it applying read/write permissions for me on my whole user folder (HD/users/your name) and enclosed items , not only on the music folder. Note : doing this will change all permissions of all elements in this folder, you may not want this (exemple : you may have to set back public/dropbox to "write only" for everyone if you want to keep using it).

  • ksamiot Level 1 Level 1

    This one worked for me. Turns out I had tampered with the "Shared" folder's priviledges via Terminal my self. Thanks a lot. :-)

  • warmgeoff Level 1 Level 1

    FC--you rock!  The article you linked saved me the agony of messing with this @#$%! any longer...just did my first restore from a [small] Time Machine backup volume, only to find I had lost ALL my itunes music [prolly didn't include in the small backup--Thank God I had a copy of most? of the library in another disk/OS version...

    Anyways, been messing with this crapola too long, and it's time to cozy up with a brewsky and relax for now; CHEERS! to you

  • GerardoGerardo Level 1 Level 1

    thanks fcphun!!!
    I also had the exact same problem that bill. I have my itunes media in an external drive and the problem wouldn´t solve changing the access privileges of the external drive folders. I wanted to cry for a while but then I notice that the share folder on my computer hadn´t the read/write privileges activated. I change them the old fashioned way and everything is working now. Thanks man.

  • rbhix Level 1 Level 1

    Here's another fix:  When I got my first iPhone, I created an album in iPhoto that contained photos I wanted on the iPhone.  I told iTunes to sync photos with that album.  Fast forward several years, I started using Aperture.  Still no problem until Apple "unified" the databases for iPhoto and Aperture.  Recently I decided to clean up the Aperture/iPhoto library and noticed some duplicate items.  Guess what, they were the albums I'd created in iPhoto to sync with.  I deleted those albums.  Then on the next iTunes sync I began getting the "you do not have enough access  privileges for this operation" message.  I tried several of the suggested permissions fixes for the Finder and the Aperture/iPhoto databases, but nothing worked.  Then I noticed the error message popped up when iTunes was trying to sync the photos.  I told iTunes not to sync any photos but to keep the current photos on the iPhone.  Now the iTunes sync works to install app updates, podcasts, music, etc.  Later I'll go back to figure out how to recreate the photo syncing albums so I can add new photos to the iPhone.

  • Brad Shuler1 Level 2 Level 2

    I downgraded from Mavericks to Mountain Lion (time machine restore) today and received the error. 


    By creating a /Users/shared directory with full read/write/execute (777) privilege this instantly fixed the problem for me.


    Strange.  I do not remember deleting my shared directory.  You will need to lookup how to get root (sudo) permission in OS X.  Then do this:


    cd /Users

    sudo mkdir shared

    ls -l

    sudo chmod 777 shared

    ls -l


    You should see (all accounts + shared):


    drwxr-xr-x@ 56 jerry   staff  1904 Nov  6 18:38 jerry

    drwxrwxrwx   4 root   admin   136 Nov  6 19:04 shared


    The drwxrwxrwx allows anyone to create directories or add files in shared.  Here is what iTunes created under shared:

    drwxrwxrwx@ 2 jerry  admin  68 Nov  6 19:04 SC Info

    drwxrwxrwx@ 2 jerry  admin  68 Nov  6 19:04 adi


    Nothing in either directory (I looked for hidden with ls -la).  A mystery..

  • Maksi Level 1 Level 1

    Had the same problem after a OS X.9 Timemachine restore. Here's how I fixed it:


    Hold down the Option key while starting iTunes

    Reselect your own iTunes Library


    When I did this, it opened right up and started "Updating the iTunes Library"


    It was correctly pointed to the correct Library before but this did the trick.

  • Maksi Level 1 Level 1

    Follow up, after the update was complete, same error!

    Deleted all iTunes Library files, same problem

    Deleted iTunes and reinstalled, same problem

    Ran permissions fix from command line, same problem

    Ran permissions fix via recover partition, same problem

    Created entireley new library, same problem

    Created a new user, SAME PROBLEM!!!


    At this point it seems my only option is to reinstall OS X.9 and then reinstgall all my programs and move files back over. I don't trust restoring it from Time Machine because that's what started this fiasco in the first place...

  • gtonthebus Level 1 Level 1

    This was it! After hours of frustrating searching and trying all the wrong things THIS was the winner and the key for me was "apply to all enclosed files." That extra step, which I had not been aware of before by clicking the little cog, was the winner and my downloads in iTunes kicked in instantly once I had done that and tried again.


    Thank you SO much!