Previous 1 2 3 Next 44 Replies Latest reply: Dec 10, 2015 3:57 AM by kennygwood Go to original post
  • greerjb Level 1 Level 1

    I was encountering this issue on an external hard drive I use to store my music and videos. This fix worked like a charm. Thanks!

  • Maksi Level 1 Level 1

    So the problem definitely occurred because of the Time Machine restore and it had nothing to do with the iTunes Library permissions. The only way I could fix this issue was to completely reinstall OS X.9 which I first had to do by using the recovery partition online.

  • Mattlowe1974 Level 1 Level 1



    I went through all these steps and it still didn't work, eventually i reset the preferences and pointed back to itunes folder and now seems fine again...

  • dallasphotog1 Level 1 Level 1

    Thanks- After trying every method about five times, the Apple instructions for creating a new shared folder using the command line actually worked. I had tried to start up iTunes about a hundred times and kept getting the message about not having enough privileges and another one saying unknown error -45054, so that iTunes would never even start up.

    This problem resulted from my new dual drive setup with an SSD as the boot drive. I have the iTunes application on the SSD and my users folder with all the music etc. on the old hard drive.

    Anyway, thanks fcphun for solving my problem!

  • Loogey Level 1 Level 1

    I had the very same problem but, Changing the permissions of the folder did not help.  My iTunes folder is on an external network drive.



    My Solution was :-

    1. I ejected the external network drive (actually it was listed twice on my Mac - so I ejected all of them).
    2. I then reconnected to my network drive.
    3. I restarted iTunes.
    4. the download worked for me.
  • Mexican Stew Level 1 Level 1

    I had the same problem and found that atobteam's solution worked but the key was finding the iTunes folder not necessarily the music folder. Thanks for the help!

  • TLHolz Level 1 Level 1

    This seems to have cured the problem for me. I had installed an SSD as boot drive, used Carbon Copy Cloner to copy the system files over to it. Afterward Office or Mac 2011 required re-input of the Key, and iTunes said I didn't have enough access privileges. Tried a lot of different thing, this seemed to fix it. Thanks!

  • petersherman56 Level 1 Level 1

    Thank you - I was having a similar problem (copying an iTunes Media folder from one external HD to another) and this was just about driving me nuts when I was trying to edit the metadata on the files in the new location. Your advice worked a charm and my sanity is restored!

  • shalafarky2 Level 1 Level 1

    Thank you!  Several years later & this was what I needed!

  • kennygwood Level 1 Level 1

    I had four tunes that appeared to have failed to download due to "not enough access privileges" issues.

    I did a spotlight search which located one of the tracks and so when played in iTunes they were then accessible in the iTunes library.

    Still can't access the other 3 though !

  • flash7gordon Level 1 Level 1

    I think the people having this problem moved iTunes music/movies from an older computer manually, maybe using networked drives.  I would love to "Apply to all Enclosed Items" and I understand what you're trying to do with this (add the permissions all the way down the directory structure) but even though I click on my userid and have "Read/Write" that option is greyed out for me.  It's also strange because the manual move worked for all my music and music videos, it's only movies that it won't download.   I have high bandwidth and don't think it's that good an idea to download all my movies, but I would like to see them as available on my new machine.

  • flash7gordon Level 1 Level 1

    Bill, I was in your situation and I think I have a solution but it's pretty radical.   I thought I wasn't only able to see the movies that I bought but then I found that I couldn't buy a new song so it was a pretty serious situation (funny Apple took my money but the download to my hard drive failed so Apple doesn't expect that to happen very often).  atobeam is suggesting the "Apply to All Enclose Items"  but that option was greyed out for me.  So this guy in the url below is saying to fix this at the Unix level (final note at the bottom of the page).  Fixing Mac problems at the Unix level makes me nervous as **** but this is just loosening permissions so I gave it a try and it worked.   All this GUI stuff is fine but chmod -R 1777 /users/shared is a hammer that has to work.  You have to know the root password on your machine but I think with most mac's that's just your signon password.  I chmod'd /users/shared and /users/mypersonaluserid (sub in your userid).   If this bhall suggestion makes you nervous (you don't know how to do what he describes with Terminal), network around and find a friend who is familiar with Unix.


  • paragaspb Level 1 Level 1

    home/ music?

    where do i start?

  • Matson-Man Level 1 Level 1

    Perfect step by step answer to problem FIXED upload into iTune Library.

  • kennygwood Level 1 Level 1

    Just to update on this , my solution, which was a bit "belt and braces" was to move my library location onto an external usb drive, and then having done that, move it back onto my Macbook Pro. This restored  all the permissions. :-)

Previous 1 2 3 Next