1 2 3 Previous Next 35 Replies Latest reply: Jan 25, 2014 7:11 AM by brec Go to original post
  • 30. Re: Ipad will not connect to new Xfinity router
    samwillhelp Level 1 Level 1 (125 points)

    This fixed a similar issue for me; see if it helps you: http://ipadnerds.com/fix-wifi-issue-ios-7/

  • 31. Re: Ipad will not connect to new Xfinity router
    ZintainUSA Level 3 Level 3 (945 points)

    keriah wrote:

     

    tgeds wrote:

    ... called comcast and had them shut off the wifi feature and used my own router..

    FWIW, we had a 5-yr old router sitting on the shelf so we hooked it up to the Comcast modem/router box a couple of weeks ago and put it back into service, giving it a different network name.  We never did call Comcast to shut off their router and we just take care to have everything (computers, ATV, iOS devices) always connect to the 3rd-party router as the default.  We're now back to flawless WiFi streaming in our home. 

     

    For the first week or so I used iStumbler to monitor the connections.  At times the Comcast signal was actually the stronger one.

     

    I don't know if there are implications to leaving the Comcast router in operation.  Does anyone know if itit causes any kind of problem by simply leaving it in operation from Comcast's perspective? ... would we gain any advantage if we had them shut it off?

    I work for Comcast and install these things all day.  It may be working for you, however, I can tell you that having both of them on when the router gets assigned a new IP address when the current lease runs up on yours, you are going to loose your Internet connection.  You are going to be doing a lot of reboots of your router and modem at this point.  You can call and get the router put in Bridged mode which will turn the router into a basic modem where you just plug the router into the #1 port and you'll be fine at that point.

  • 32. Re: Ipad will not connect to new Xfinity router
    MK615 Level 1 Level 1 (0 points)

    I found the IP (vs.the MAC address) for my device was listed as an "unknown" device under parental controls and was blocking it. Once I granted it access, I was back in business.

  • 33. Re: Ipad will not connect to new Xfinity router
    MK615 Level 1 Level 1 (0 points)

    Similar issue. Downgraded to "low" security on the Xfinity ARRIS TG862 router and now I can connect. Since all my devices have additional layers of security on them, I'm not too concerned.

  • 34. Re: Ipad will not connect to new Xfinity router
    mannyUFWD Level 1 Level 1 (0 points)

    Thanks kassinki,

     

    Changing WPA/WPA2-PSK (TKIP/AES) to WPA-PSK (AES) as you point out fixed the problem I was having maintaining a connection between a Samsung TV, iMac and Comcast - thanks!

     

    Previously the Samsung TV would start playing the video and then stop and show this error message "portable device is disconnected"

  • 35. Re: Ipad will not connect to new Xfinity router
    brec Level 1 Level 1 (15 points)

    chainapalm's solution worked for me while visiting someone with a Comcast/Xfinity WiFi router.  No problem with my MacBook Pro, but  my iOS7 devices -- iPad 2 and iPhone 4s -- could see the network but couldn't join. I touched Other, entered the network name, selected WPA2 under Security,  entered the password, touched Join.

1 2 3 Previous Next