Previous 1 2 3 Next 36 Replies Latest reply: Sep 12, 2014 1:10 PM by cheetobanzai
mad4games Level 1 (0 points)

Not sure if I am posting to the correct community or not but will give it a shot.  I just moved from a home where I had the Comcast cable modem and my airport Extreme.  No issues there.  Now Comcast has given me the new Xfinity modem/router combination and I'm unable to maintain a connection to the network with my ipad.  This is not an issue on my G5 Mac, or my Apple TV, but our two Ipads (original Ipad and an Ipad 2) simply say "unable to connect to network".  Network is there, strong signal, it just won't connect.   Today I tried to see if my iPhone would connect to the network via Wi-fi and of course it won't either.  I've called Comcast 3 times now in the past week.  When they reset the modem/router it fixes the problem - for a few hours - then it drops the network and can't reconnect.    I've seen others on the internet with the same issue.  What is going on?   My wife wants to dump Comcast she is so irritated and I'm about there myself.  This is clearly an issue with my Apple mobile devices and their router, anyone have any ideas what I should do?   Calling Comcast is not working, they are clueless.  Ipads worked fine for about a week when we first moved in, now this connection issue is the standard.


iPad 3G
  • Templeton Peck Level 9 (61,417 points)

    Get rid of the comcast router and just stick with a cable modem and your own airport extreme or other router.

  • Texas Mac Man Level 8 (46,565 points)

    Look at iOS Troubleshooting Wi-Fi networks and connections  http://support.apple.com/kb/TS1398

     

    iPad: Issues connecting to Wi-Fi networks  http://support.apple.com/kb/ts3304

     

    iOS: Recommended settings for Wi-Fi routers and access points  http://support.apple.com/kb/HT4199

     

    Additional things to try.

     

    Try this first. Turn Off your iPad. Then turn Off (disconnect power cord) the wireless router & then back On. Now boot your iPad. Hopefully it will see the WiFi.

     

    Go to Settings>Wi-Fi and turn Off. Then while at Settings>Wi-Fi, turn back On and chose a Network.

     

    Change the channel on your wireless router. Instructions at http://macintoshhowto.com/advanced/how-to-get-a-good-range-on-your-wireless-netw ork.html

     

    Another thing to try - Go into your router security settings and change from WEP to WPA with AES.

     

    How to Quickly Fix iPad 3 Wi-Fi Reception Problems

    http://osxdaily.com/2012/03/21/fix-new-ipad-3-wi-fi-reception-problems/

     

    If none of the above suggestions work, look at this link.

    iPad Wi-Fi Problems: Comprehensive List of Fixes

    http://appletoolbox.com/2010/04/ipad-wi-fi-problems-comprehensive-list-of-fixes/

     

    Fix iPad Wifi Connection and Signal Issues  http://www.youtube.com/watch?v=uwWtIG5jUxE

     

    Unable to Connect After iOS Update - saw this solution on another post.

    https://discussions.apple.com/thread/4010130?tstart=60

     

    ~~~~~~~~~~~~~~~

     

    If any of the above solutions work, please post back what solved your problem. It will help others with the same problem.

     

     Cheers, Tom

  • Philly_Phan Level 6 (13,261 points)

    Turn off the Xfinity radio and use your Extreme.

  • mad4games Level 1 (0 points)

    Thanks for the suggestions.  I will work on these.  Just to clarify in case it wasn't clear.  The issue is not that the Ipads in the house can't see the network, I just get an "unable to connect to network XXXXX" message.  Same thing happen on my iphone if I try to connect to Wi-Fi.  It's clearly an issue with the Apple mobile devices in some way.  My desktop Mac G5 connects wirelessly just fine as do the PC's in the house.  Very frustrating.

  • Gomnel Level 1 (0 points)

    Im experiencing the same problem. Were you ever able to fix the problem?

  • justicelee26 Level 1 (0 points)

    I had a similar problem. I did a software update on the router and it fixed the problem. If you haven't already make sure the router is up to date.

  • mad4games Level 1 (0 points)

    Had Comcast reset the routre to factory settings which also did a software update.  They also fixed it to a static channel vs. Auto.  Thought we had it fixed but only lasted 3 hours then dropped me and the ipads and iphones would not connect.  Was about to give up and then got another tech person from Xfinity support who had experienced the issue.  He said the problem was likely that the apple products were not able to handle the WPA-WPA2 encryption on a consistent basis although they say they can.  So he dropped my security level down to WPA  vs WPA2 and I think we may have solved the issue.  Woke up this morning and Ipad and Iphone were still connected to network which is a first.  This may have been the trick.  Worth nothing that this same tech had two calls yesterday on this same issue but prior to that he had never heard of it.

  • whackamole99 Level 1 (0 points)

    I had the same issue...  Could see the wireless connection on my phone but would get "cannot connect" message while trying to connect.  I was able to get it to connect by turning off / on my iphone

  • Diavonex Level 9 (66,550 points)

    Deleted

     

    Message was edited by: Diavonex

  • EssentialFloss Level 1 (0 points)

    So far changing the security setting to WPA seems to have solved the "unable to connect to network" problem for my 2010 MBP. Must be some sort of issue with the implementation of WPA2 on the Motorola Xfinity router.

  • kassinki Level 1 (0 points)

    I had the same issue and just did the following fix on my IBM laptop.  My iphone, ipad and mac book pro just connected with no problem.  I tried to call comcast to get them to do this and after talking to 4 people that said it couldn't be done I figured out how to do it on my own.  Go to the following website and use this information to sign on (i think you need to be on a device connected to your internet)

    • Admin Site – http://10.0.0.1
    • User Name – admin (not case-sensitive)
    • Password – password (case-sensitive)

     

    Click on Connection - WiFi along the left side.  Click "edit" next to your network.

     

    Here my security mode was set to WPA/WPA2-PSK (TKIP/AES).  Using the drop down I selected the WPA-PSK (AES) instead.  (not sure what the difference is between TKIP and AES).  I changed my password while I was at it because the preset one was nuts.  Then saved my settings.

     

    It then kicked me offline and I had to go into my network connections to change my security settings as I used different settings when I initially set it up.  Once I changed those settings to WPA and AES I was able to sign back on the internet on my IBM.  I had all of my devices forget the network and signed on to my network again and it worked on all of my devices. 

     

    I am keeping my fingers crossed that this is a permanent fix.  I hope this helps you because this has been driving me nuts and it took it interfering with football for me to take some action.

  • Johnathan Burger Level 6 (15,882 points)

    Yep.  I have a buffalo router using wpa2.

    Not a single problem.

  • dcoplon Level 1 (0 points)

    This was super helpful for my new iPhone 5 as well

  • kassinki Level 1 (0 points)

    One week update:

    It worked well for a few days and then it went back to the same error.  I changed it from AES to TKIP and will see if that works better.

Previous 1 2 3 Next