Previous 1 2 Next 16 Replies Latest reply: Jul 9, 2012 6:06 AM by léonie
Rich Fenton Level 1 Level 1

Merging Aperture with iPhoto


Just upgraded Aperture and iPhoto to the latest versions to have a single consolidated library (great update Apple)


My Aperature library is 9.53GB

My iPhoto library is 41.79GB


Why when I try and merge is Calculating disk space saying it needs over 209GB of free space  ??

What is going on here ??? and any way to reduce the space overhead ?

  • Rich Fenton Level 1 Level 1








  • CorkyO2 Level 4 Level 4

    I would guess it has something to do with the fact that Aperture (and perhaps iPhoto) uses extra space when upgrading a library.


    See the 'Additional Information' section at bottom of this page:



    If the process were to make hidden copies of each library as a backup, as well as hidden copies being worked with and some overhead; that may account for such a large amount of space being needed.


    We saw this problem occur for a number of users going from AP 2 to AP 3 and also from AP 3 to AP 3.2 if memory serves. Some users copied their libraries to a larger external drive while upgrading and then copied back, but I am not sure what that would do with both an Aperture library and an iPhoto library merge.


    If no users post with certain knowledge of the issue, you might want to contact Apple on this one.

  • mattalexcohen Level 1 Level 1

    Having the same problem, only it's even larger. I have a 100 GB Aperture library and I'm trying to merge in a 30GB iPhoto library. Have 90 GB free space and the operation is asking for 667 GB, which is larger than my entire hard drive? Is there a way to fix this without resorting to an external hard drive?

  • Rich Fenton Level 1 Level 1

    I'm having a REAL nightmare with this...  I've ended up creating a new iPhoto library and then opening the containing folder for the aperture library and copying stuff back in and manually workign thru it YUK YUK YUK


    One thing I did notice is there is a load of data swamped up in the iPod Cache directory which can be deleted and may alleiviate your problem


    Wish I never went to Aperture and stayed with iPhoto

  • léonie Level 10 Level 10
    Photos for Mac

    Why when I try and merge is Calculating disk space saying it needs over 209GB of free space  ??

    What is going on here ??? and any way to reduce the space overhead ?

    Are your Libraries referenced? During the conversion Aperture probably needs temporary storage for the images in high quality lossless format.


    I found that not so much temporary storage will be required, if you upgrade the libraries before you try to merge them:

    1. Open your main Aperture Library in Aperture 3.3 and rebuild it in Aperture 3.3 before you merge the libraries.
    2. Open the iPhoto Library in Aperture and rebuild it in Aperture before merging it into the Aperture Library.
    3. Then open again the main Aperture Library and merge the iPhoto Library into it using "File > Import > Library"


    To force to open your iPhoto Library in Aperture 3.3. launch Aperture and select "File > Switch to Library" from the main menu bar. or ctrl-click the iPhoto Library and select "Open with > Aperture" from the pop-upmenu.


    To rebuild the Library hold down the cmd-option key combination (⌘⌥) while you double click the library.


    Post back, if you still need so much disk space after this.




  • svenbrocking Level 1 Level 1

    Ok i understand it needs additional space for conversion/merge but this must be a bug.


    I even tried to create an empty library and import a 50gb library into it.


    This is what I get:


    Screen Shot 2012-06-16 at 1.49.35 PM.png

    Any suggestions?

  • léonie Level 10 Level 10
    Photos for Mac

    This looks like a corrupted Aperture Library. Does Aperture work at all, if you start from an empty library and new images to that library? You said you tried that.


    And could you run the Library First aid and rebuild your main Library, as I described above? What was the result?

  • svenbrocking Level 1 Level 1

    Aperture works properly, i can add and edit photos.

    I rebuild all libraries with the first aid tool, still the same result.


    I found out that this only happens when importing an iphoto library, not when importing an aperture library.

  • léonie Level 10 Level 10
    Photos for Mac

    Have you tried to repair the iPhoto Library before importing it to Aperture? You can launch iPhoto 9.3 into repair mode just like Aperture. Have you upgraded to iPhoto 9.3?


    See TD's post on how to repair an iPhoto Library: Re: iPhoto library too old for Aperture?

  • svenbrocking Level 1 Level 1



    Aperture is 3.3 iPhoto is 9.3.

    Also tried the repair from iPhoto.


    Actualy I think this all started after the upgrade to 3.3 and 9.3 with the unified library thing.

  • Rich Fenton Level 1 Level 1

    I'm back up and running - first I tried to manually copy the libraries to consolidate them but that got horribly screwed up with missing referenced files...


    I ended up restoring back to a Vault (taken before I started this sorry mess) and then tried the upgrade process again - this time it worked and seems to have consolidated both my libraries into one and is accessible from iPhoto and Aperture (which is where i wanted to get too)


    Only weird thing I notice now is the Faces DB has a lot of blank entries in the thumbnails but I performed a rebuild on this and when I mouse over them they seem to come back.... Whole sorry episode hasn;t changed my opinion of Aperture in that it's not a Apple Quality Product - the only feature worth my time in future is Vaulting which ironically in this instance saved me... backup flatters restore matters

  • léonie Level 10 Level 10
    Photos for Mac

    Thanks for lettimg us know. You are the second one now, who reports that restoring from the vault saved the library when the upgrade failed.

  • Craig Hockley Level 1 Level 1

    I've also discovered this problem, but unfortunately don't have an up-to-date, pre-update vault from which to restore from.


    I have a 15G iPhoto library that I am trying to merge with a 49G Aperture library (granted, most photos are duplicates, but until now, that's been my only easy option) and when I try to merge as per the instructions, I'm informed that I need 4 Terabytes of disk space to do so. Which is, well a little excessive I would have thought.


    I have deleted all iPhone movie files, emptied both trash folders, rebuilt both databases and I'm still finding the same issue.


    If the above is anything to go by, am I best to create a new vault now and restore from that, or go back with Time Machine to before I upgraded the Aperture library, restore the old Aperture library, create a new vault, then restore today's Library from that new (old) vault and manally re-add the photos added in the meantime?


    Sounds like a bit of a silly way to do things.


    I'm guessing it would be easier to try and identify which photos are in iPhoto that aren't in Aperture, import those by themselves, and use the Aperture library in iPhoto from here on?


    Anyone else remember the good old days when Macs 'just worked'?

  • léonie Level 10 Level 10
    Photos for Mac

    One thing that worked for me, was to convert the iPhoto Library into an Aperture Library before importing:

    1. I opened the iPhoto Library to be merged in Aperture,
    2. and then I selected all Library items at once and exported the selection as a new Aperture library.


    This was very quick, and when I imported this converted library into Aperture not much space additional was required.

Previous 1 2 Next