Skip navigation

How to restore iPhone 3gs with error code 21

8629 Views 9 Replies Latest reply: Sep 19, 2012 8:53 AM by evie70 RSS
pscott47 Calculating status...
Currently Being Moderated
Jun 13, 2012 5:30 PM

I have an Iphone 3GS. I replaced the battery and digitizer. When I plug in to Itunes the Iphone wants to "restore", but I recieve an error code 21, and it will not "restore.

 

Any suggestions?

 

Thank you,

 

Peter

iPhone 3GS, iOS 5
  • fccrepair Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 14, 2012 12:02 AM (in response to pscott47)

    Why did the iPhone need a restore in the first place?  It shouldn't have needed one just because of a battery and digitizer.  I've seen a number of bad batteries that were supposedly brand new.  So that could be the cause as well.  You might also double check the battery and make sure it says 4.51 Whr on it.  If it says 4.26 it is a 3G battery which isn't compatible. 

     

    One way to quickly know if it's a bad battery is if you unplug the iPhone from a charger and it immediately shuts off.  That means the phone isn't charging or pulling anything from the battery itself.  You could technically put the phone together without a battery and it would bootloop with the Apple Logo. 

     

    Jonathan

  • fccrepair Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 14, 2012 5:09 PM (in response to pscott47)

    Peter,

     

    In the past, I have had some devices show that error but I was able to simply hard reset the device and it booted fine. 

     

    Was the phone jailbroken before?  Also, I would make sure you are attempting the restore in DFU mode versus Recovery mode.  It sounds like it is having a conflict with the baseband which is why the device is not allowing itself to boot.  You might also try using TinyUmbrella to fix recovery. 

     

    If you continue having issues, let me know.  Also let me know if you are using PC or Mac and which OS you are running. 

     

    Let me know how it goes!  If it doesn't work I may have a few other tricks up my sleeve. 

     

    Jonathan

  • fccrepair Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 15, 2012 2:06 PM (in response to pscott47)

    Peter,

     

    Thanks for narrowing it down!  The baseband is the modem firmware.  Usually if iTunes errors out at the end of a restore it is due to a conflict with the baseband.  I am almost positive that TinyUmbrella would solve your problem.

     

    At this point, the easiest thing to try without downloading any additional programs would be to try a different computer.  Of course, if you haven't tried restarting your computer and using a different USB port you might try that. 

     

     

    Let me know!

     

    Jonathan

  • evie70 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 8:53 AM (in response to fccrepair)

    hi

    i was given an iphone3gs recently and it was jailbroken and unlocked, i accidently restored it on itunes and now it wont activate and when i try to restore it it comes up with error 21, my dad said he had upgraded it as well once beofe and he got it reversed at a phone repair shop, cani fix this problem at home or would i need to take it to a shop,

    thx

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.