Previous 1 2 Next 29 Replies Latest reply: Jun 18, 2013 3:58 PM by Jascha Lee Go to original post
  • Sebastien S. Level 1 (35 points)

    Yes I should add that I tested with adding the missing text so the line is the same than previous but with a different index location. But it was not working.

    But now you wrote a reply I tested again and it works !

    It's strange but maybe I should had restarted the mac before (with the edit of the plist).

    So it works and I had the HP printer updates correctly took from my server !


    Thanks !

  • Mark23 Level 3 (975 points)

    Look here: Point clients to a Software Update server and look in the sidebar for more SUS info...

  • NightFlash Level 1 (0 points)

    I changed all this told to do in this post.

    Everything on the server seems fine, the lines are still in the files and when I check the SUS service I can see that the 10.8.* updates has been downloaded on the server.


    But the clients still says cannot connect to the server error 1004

    hde tried multiple computers and all OS's except 10.8 is working.


    I can still update 10.6 and 10.7 clients.


    have also tried to login and logout on apple store accoutns no luck there either.

    have restarted the server and reinstalled clients. Not much more I can test that I know of.


    Anyone got any suggestions?

  • Sebastien S. Level 1 (35 points)

    If you made the correct rewrite rules but with the 10.7 server needs another format (as tols before)

    RewriteCond %{HTTP_USER_AGENT} Darwin/12

        RewriteRule ^/index\.sucatalog$ http://%{HTTP_HOST}/cgi-bin/SoftwareUpdateServerGetCatalog?/index-mountainlion-lion-snow leopard-leopard.merged-1.sucatalog


    And be carefull that the client points to …:8088/index.sucatalog only via WorkGroup Manager or Profile Manager settings. If you made it manually, then the URL is

    http://SERVER.local:8088/ catalog


    If on the client you put this URL in your Safari, do you see the calatog ? (replace of course SEVER by your server and SERVER.local by your full server name if needed).

  • NightFlash Level 1 (0 points)

    The server is 10.6.8 sho shall I still use the revised RewriteRule on the 10.8 line


        RewriteCond %{HTTP_USER_AGENT} Darwin/10

        RewriteRule ^/index\.sucatalog$ /index-leopard-snowleopard.merged-1.sucatalog

        RewriteCond %{HTTP_USER_AGENT} Darwin/11

        RewriteRule ^/index\.sucatalog$ /index-lion-leopard-snowleopard.merged-1.sucatalog

        RewriteCond %{HTTP_USER_AGENT} Darwin/12

        RewriteRule ^/index\.sucatalog$ http://%{HTTP_HOST}/cgi-bin/SoftwareUpdateServerGetCatalog?/index-mountainlion-l ion-snow leopard-leopard.merged-1.sucatalog


    like this?


    I'm using a DNS server to send all clients to the correct update server.


    Still same error with revies line.


    And if I try to go to the link with safari I get page cannot be viewed on all versions not only the 10.8. <-ignore I forgot the port 8088 =)

  • NightFlash Level 1 (0 points)

    Seems like 10.8 is ignoring the port and the http thingie cause the logs on the 10.8 computer is saying cannot find



    instead of



    As the 10.6 computer does.


    So of cource it can't find the files but how do I change so it looks at the right place.

  • xiao zhong Level 1 (0 points)

    On one your Mountain Lion client, try run:


    sudo defaults write /Library/Preferences/ CatalogURL “ http://updateserverIPorDNS:8088/index-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog”

    sudo chown root:wheel /Library/Preferences/

    sudo chmod 644 /Library/Preferences/

    sudo rm -rf /Library/Preferences/ &>/dev/null

    sudo defaults write /Library/Preferences/ restrict-store-softwareupdate-only -bool yes

  • Jascha Lee Level 1 (5 points)

    Here's what worked for me:


    Use Server Admin to stop the Software Update service


    edit /etc/swupd/swupd.plist, add the following line:




    between the <array> </array> delimiters


    edit /etc/swupd/swupd.conf, add the following two lines to the existing list in the <IfModule mod_rewrite.c>: stanza


    RewriteCond %{HTTP_USER_AGENT} Darwin/12

    RewriteRule ^/index\.sucatalog$ /index-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog


    From the terminal, run:


    sudo chflags uchg /etc/swupd/swupd.conf

    Start Software Update Service, and you are done!

  • Daniel Ball Level 2 (225 points)

    Thats what I did and have 200 clients, some work and some don't.  The ones that don't work may work on another day or may not.  Its mixed at times.  Makes no sense!

  • Jascha Lee Level 1 (5 points)

    Not sure this will help, but I also changed from using a host name to using an IP address for OD binding, SUS, etc.  Seems to have increased reliability.

  • Daniel Ball Level 2 (225 points)

    I did try changing the config file on the client to the IP instead of a FQDN, but no changes.  Still fails here.  Very odd, how it can work one time and not the next.

  • xiao zhong Level 1 (0 points)

    How is run:


    sudo softwareupdate -i -a



  • Daniel Ball Level 2 (225 points)

    Yes, using Apple Remote Desktop and sending a Unix command of pretty much what you said, run as root with command: softwareupdate -i -a


    Can take a lab of say 100 that are exactly the same in hardware and OS image installed and probably 10 maybe 15 will fail.  Come back the next day and try them again and another 10 or 15 will fail or maybe all of them.  Very odd.

  • Daniel Ball Level 2 (225 points)

    Ahhh feel stupid....I see what is happening finally!   If there are no updates to download then I get an error on the clients.  If there are updates available then everything works fine. 


    The server just must not be responding correctly when no updates are available and it simply throws an error instead of something readable like no updates are available now or something like that.

  • Jascha Lee Level 1 (5 points)

    I don't think it's that.  I suspect the error results when the server is in the process of downloading updates.  It does something with the URLs or something.  If you have a slow connection and a large update downloading from Apple, this error state can last for a while.


    Once you are out of the error condition, you won't get an errror on the clients when there are no updates available.

Previous 1 2 Next