4 Replies Latest reply: Mar 11, 2013 7:55 AM by ecb21
wyvern-eater Level 1 Level 1

I administer an account with parental controls set to restrict web and application access, and interface customization. (It's for a very young child).


It seems random whether the parental controls work or not. Most of the time, they do work, but only some of the allowed applications run. Most don't get proper icons (just the generic dog-eared page), which is a serious problem for pre-literate, illiterate and poor-sighted users. Some, like PhotoBooth, won't run at all.


Occasionally, the app restrictions disappear, and the child has access to every app.  At the least, they all get their icons.  But they shouldn't be appearing at all.


I've checked the account pref settings over and over, and found nothing that looks wrong.


Where else should I be looking?  Are there some known causes that are likely to be behind this?


My admin account on the same machine is working just as I'd expect, no problems at all.

MacBook Pro, Mac OS X (10.5.6), 2.2 GHz, 2 MB
  • Klaus1 Level 8 Level 8

    You might find this useful regarding Parental Control in Leopard:




    Note in particular:


    To enable Internet content filtering:

    1. From the Apple menu, choose System Preferences.
    2. From the View menu, choose Parental Controls.
    3. Select the user account on the left side of the window that you would like to enable filtering for. Note: Parental Controls cannot be enabled on administrator accounts. Check Accounts preferences in System Preferences to see which account(s) have what level of access (Admin, Managed, and so forth).
    4. Click "Enable Parental Controls".
    5. Click the Content pane.
    6. Chose a mode under Website Restrictions. See below for a description of each.
    7. Repeat steps 3 through 6 for other non-administrator accounts for which you would like to enable filtering.


    As an alternative for Apple's Parental Control for those who do not want to use a non-admin account, there is Open DNS's Parental Controls:



  • wyvern-eater Level 1 Level 1

    Thank you for taking the time to post, Klaus.


    I see that I must clarify that the problem is


    1. erratic behavior of application access restriction, not Internet access restriction,
    2. Finder not always giving allowed applications their proper icons,
    3. Finder not permitting allowed applications, without their proper icons, to run.


    And only in the controlled account.

  • nidnoy Level 1 Level 1

    Hi, I haven't got a solution, but I run 10.6.8 on my MacBook & iMac. I appear to have the same problem. I run two user accounts for my two children. I restrict their Internet access (which works fine), and I limit their access to only certain apps. The same thing happens with me. Sometimes the apps appear, sometimes they don't. Sometimes they show the proper icon, sometimes not. Sometimes the apps work, sometimes not.

    A prime example is I have now upgraded my Firefox, it works fine on my account (which has admin privelages). I check the box in parental controls so they can use it. If I log in as the children, sometimes the icons appear, I click on them & the screen goes crazy with the access box flashing on & off. I try & click "allow always", but it doesn't work. Then the icon disappears. I log back in as myself & the icon box has been unchecked!!! Sometimes the icon just does not appear, even though it shows as checked when I have set up the parental controls.

    It is all very, very frustrating. I have spent hours seemingly going round in circles. Tried all the usual stuff, repairing permissions, resets etc, but to no avail.

    Before I get answers about Firefox, let me confirm, I am using that as an example. The same thing happens with a variety of apps. I have also had similar problems when trying to install games for the children. I have installed them on my log-in, i have tried installing them on individual user accounts, i have tried shared access but all to no avail. I have tried searching the forum but just don't seem to be able to find a comprehensive answer to any of this.

    Apologies for not being any use in solving your problem I hope someone it their is abe to help.

  • ecb21 Level 1 Level 1

    I have the same problems as the person above.

    a clear answer would help a lot from Apple