Previous 1 2 Next 27 Replies Latest reply: Jan 12, 2015 8:28 AM by Old Toad
Susu3 Level 1 (0 points)

Each time I open iPhoto this pops up. A photo has been found in the iPhoto library that was not imported. Would you like to import it. How do I stop this?


MacBook Pro (13-inch Late 2011)
  • Terence Devlin Level 10 (137,940 points)

    Go to your Pictures Folder and find the iPhoto Library there. Right (or Control-) Click on the icon and select 'Show Package Contents'. A finder window will open with the Library exposed.

     

     

    Look there for a Folder called 'Import' or 'Importing'.

     

     

    Drag it to the Desktop. *Make no other changes*.

     

     

    Start iPhoto. Does that help?

     

     

    If it does then look inside that folder on your desktop. Does it contain anything you want? If not you can trash the folder.

  • SweetThunder73 Level 1 (0 points)

    Thank you Terence Devlin for your tips and expertise.

     

    I followed your instructions, but when I dragged my import file over to desktop, it says masters in it. When I clicked on masters it contained three of my videos. I don't want to lose these videos, so I opened up "show package contents" again and dropped it back in there. Should my import folder contain the word masters? Or did I somehow scoop it up with my novice dragging and dropping methods??

     

    Thanks,

    Jennifer

  • Terence Devlin Level 10 (137,940 points)

    Repeat the process again.

     

    Open iPhoto.  Do you get the message?

     

    If not then import those three video once more.

     

    Regards

     

     

    TD

  • R.S.N Level 1 (0 points)

    THis has been plaguing me for months! I really should have checked the forum sooner - your fix above worked first time Thank you! and thank you to Susu3 for asking the question

  • LAR16 Level 1 (0 points)

    I moved the Import folder to the Desktop and the problem disappeared.  I found the video (.avi file) that was causing the problem and tried to import it but I get the following message:

     

    "a necessary data reference could not be resolved."

     

    Is there any way I can save the file?  If I look at it in Finder and hit the "Play" button, the video does play in the thumbnail.

  • Calw Level 1 (0 points)

    Worked for me too.  I had a long list of empty folders inside of folders called masters and thumbnails.  There were actually 5 items (even though the messages only reported 2.  Glad that is fixed.  You might also go in and delete all those Recovered Photo file folders (if empty - mine were) that accumulate in your photos folder.

  • flashkube2 Level 1 (0 points)

    This helped me, too.  Thanks!

  • Ben-Turner Level 1 (0 points)

    Perfect, fixed the same problem for me, thank you very much

  • Old Toad Level 10 (135,418 points)

    What is the file size of the .avi file and where did it come from. 

     

    OT

  • Katherine Milo Level 1 (5 points)

    Help.  I did this exact procedure a month or so ago.  Now I'm getting the same message again--and followed the instructions to no avail.  My import folder is gone!  How do I get it back, more importantly how do I get iPhoto to stop displaying this message each time I launch it?

     

    Any help is much appreciated.

  • iphoneuser8 Level 1 (0 points)

    I followed all of your steps, but don't have an 'import' file under 'package contents'. What now?

  • Terence Devlin Level 10 (137,940 points)

    What do you have when you click view the package contents?

  • Old Toad Level 10 (135,418 points)

    Do you have an "Auto Import" folder?

  • Katherine Milo Level 1 (5 points)

    Yes, there is one in that folder.

Previous 1 2 Next