Previous 1 2 Next 27 Replies Latest reply: Jan 12, 2015 8:28 AM by Old Toad Go to original post
  • Old Toad Level 10 (135,388 points)

    What's inside?  It should be empty.  If there are any files in there move them to the desktop and relaunch iPhoto.

  • Katherine Milo Level 1 (5 points)

    It is empty.  Another idea?

  • Old Toad Level 10 (135,388 points)

    Try this:

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button,

                                iPhoto Library Manager002.jpg 

        navigate to your Home/Pictures folder and select your iPhoto Library folder.

         

      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option

     

                  iPhoto Library Manager001.jpg

     

     

      1. In the next  window name the new library and select the location you want it to be placed.
      2. Click on the Create button.
      3. Open and close the new library to see if the problem is fixed.

     

    Note 1: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost.


    Note 2:  Your current library will be left untouched for further attempts at a fix if so desired.

  • Katherine Milo Level 1 (5 points)

    It worked!  Took a long time but it worked.  I bought the program so I could delete duplicates.  Thank you.

     

    So here's the next/last question:  I have 24,000 photos in my collection.  I do use Time Machine, but I think I'd like to store the library on a new external hard drive I bought.

     

    What steps should I follow to do that?

     

    Thank you very much.

  • Old Toad Level 10 (135,388 points)

    It's simple to copy the a library to an external hard drive:

     

    1 - make sure the drive is formatted OS X Extended (journaled) with Ownership set to be ignored.

    2 - drag the library from your boot disk to the EHD.

    3 - launch iPhoto with the Option key held down and open the library on the EHD to make sure it copied correctly and works as expected.

    4 - launch iPhoto again with the Option key held down and open your working library on the boot drive.

  • Katherine Milo Level 1 (5 points)

    Thanks so much.  Your expertise has been so helpful.  Every so often it's possible to feel like you're not managing your computer very well.  Today yielded big improvement.  Cheers to you!

  • LAR16 Level 1 (0 points)

    The file is a .avi file.  If I place the file itself on my desktop, I can play it.  If I drag it to iPhoto, it shows it in "Last Import".  However, when I try to play it, I get the message

     

    "a necessary data reference could not be resolved." 

     

    Then when I close and reopen iPhoto, the original problem comes back.

  • Terence Devlin Level 10 (137,920 points)

    Then that avi isn't supported by iPhoto.

  • Old Toad Level 10 (135,388 points)

    What system and iPhoto versions are you running?  Do you have QuickTime Player 7 for Mac OS X v10.6.3 or later installed.  It you do it would be in the Applications/Utilities folder. If not install it and try again.

  • Ninthlegion Level 1 (0 points)

    Thanks! I had exactly the same problem, with a whole bunch of imported photos that couldn't be imported! I think they were not photos in the end but the solution given here worked fine!

     

    Thanks again from across the pond in England...

     

    Chris

  • Clara Sieber Level 1 (0 points)

    Dear Terence

     

    I have the same problem. Where do I find the pictures folder? In the Finder? I cannot find it anywhere there. I am using OS X Yosemite 10.10.1

  • Terence Devlin Level 10 (137,920 points)

    HD/Users/Your Name/ Pictures

  • Old Toad Level 10 (135,388 points)

    Screen Shot 2015-01-12 at 8.28.29 AM.jpg

Previous 1 2 Next