Previous 1 5 6 7 8 9 Next 133 Replies Latest reply: Apr 29, 2013 2:49 PM by EcoGreg Go to original post
  • Grant Bennet-Alder Level 9 Level 9 (52,125 points)

    That [removing parallels drivers and having a USB3 device perk up and run right] is remarkable!

  • Grant Bennet-Alder Level 9 Level 9 (52,125 points)

    But that seems to be the way these USB-3 problems go.

     

    Each device that seems not to work may have a different reason. You looked into kexts, and took the extra step of removing ones that "shouldn't be an issue", but were an issue.

     

    Some readers and the press have reported that Bluetooth devices and some WiFi equipment can cause cross-problems with USB-3.

     

    Sonnet reports that the standard Mac OS X drivers [in conjunction with their PCIe card] do not support USB-3 devices other than drives, and have real trouble shifting back to USB-2.

     

    Some readers reported that they had to remove and re-insert the cables to get things to perk up and be seen at USB-3 speeds.

     

    I think the best general advice is to chip away at these things one at a a time, and Apple is no doubt doing the same and will come up with improvements that help SOME devices.

  • vopt Level 1 Level 1 (0 points)

    One more thing...

     

    I reinstalled Parallels with what I think is the same version (ParallelsDesktop-7-1.0.15104.778994). The Magnum USB3 memory stick still works properly. I can't remember how I got Parallels onto the machine in the first place, it may have been using the Migration Assistant. Maybe the migration went poorly?

     

    So bottom line, of my 4 USB3 devices, now 2 of them work properly, and the other two work, but at USB 2 speeds. The drive dock remains fussy, sometimes it has to be unplugged and reconnected to be recognized.

     

    So yes, there is work to be done.

  • Dan Bryk Level 1 Level 1 (5 points)

    Parallels has been pimping their "OMG!! YOU MUST BUY A $50 UPGRADE TO 8 NOW!! FOR MOUNTAIN LION SUPPORT" emails to me for weeks now. It would not surprise me in the least if their USB kexts were proprietary and off-spec.

     

    That's just part of why I WOULD NOT do an Assisted Migration to an rMBP. Take the time and spend a couple of hours reinstalling apps and plug-ins from current DMGs as needed, selectively dragging and dropping .plists and App Support folders based on caution. (My retina shipped with 10.7.4 like everyone else's I know of.)

     

    I've been running the a Glyph PortaGig RAID 0 through the OWC eSata->USB3 adapter with >150MB/s results since I got my retina, but a similarly priced StarTech adapter (with a smaller, simpler form factor) was only getting 25MB USB2 speeds.

     

    Otherwise, everything was working fine and I was hesitant to f*** with it by running any upgrades (at least until Apple's TB->FW800 adapter de-sublimates. I am running a $250+ Sonnet TB->EC34 Adapter->StarTech twin FW800 Expresscard->Apollo/UAD Satellite setup that personally offends me but ****, I need to work, right? There's another thread for whining about the missing FW adapter.)

     

    After 48 hours deliberation, I did the SMC and MBPr 1.0 upgrades this morning.

     

    The sky didn't fall, everything is still running well, and the StarTech eSATA->USB3 adapter is now finally running the Glyph at <>160MB/s speeds.

     

    Based on a few reports that USB2 audio devices weren't working well with the rMBP's USb3 ports, I experimented with a Targus USB3 Combo Hub -- 3 x USB3 ports and 4 x USB2 ports, all powered. My 7-port Belkin USB2 hub is daisychained to one of the USB2 ports.

     

    Most important to me was the latency and timing of both an Apogee Duet USB2 and an Emagic Unitor 8 MIDI interface (USB 1.1!). Soon after I plugged in the Unitor, Software Update offered a Unitor update. Everything has worked fine with those pieces, both before and after the Apple upgrades. (Once again, I took the time to download current DMGs for all my hardware.)

     

    Apple hasn't sent me a Mountain Lion UTD code yet, but I have a feeling I'll wait for 10.8.2 before I take that plunge.

  • Kaleberg Level 1 Level 1 (5 points)

    There is a problem with the MB Retina and USB 3. I can usually use it just fine, but every two weeks or so, USB 3 stops working. USB 2 works fine, even for disk mounts, but USB 3 disks just sit there. (The MBP Retina is plugged in.) The USB 3 disks do not show up in System Info. I'm lucky, rebooting seems to fix the problem, but I worry that the problem will get more serious. I don't want to be rebooting all the time.

  • Grant Bennet-Alder Level 9 Level 9 (52,125 points)

    Kaleberg-

     

    did you install the 18-July Software Update?

     

     

     

    MacBook Air and MacBook Pro Update 1.0

  • g2fx Level 1 Level 1 (0 points)

    I had troubles loading this via USB2.0 earlier today...and I was really ****** off that it wouldn't load on my MacBook Pro Retina.  I scanned the forums...and the one thing that finally worked was checking the actual cables.  Now...the cable I used to connect to an older device worked with my drive but not my MacBook Pro Retina.  However, sorting through my cables...I tried another USB 2.0 cable...and viola!  It worked.

     

    It may be the cable isn't up to snuff.  I weeded out the cables that my "Retina" didn't like with my drive (I have 7 of these drives...so I have a drawer full of cables.  Thank you g-tech.)

     

    681779.jpg

  • Kaleberg Level 1 Level 1 (5 points)

    Thanks. Just did the install. Let's see how things go over the next few weeks. (This is a rather sporadic problem, but annoying. Granted, the MBP with an SSD reboots so quickly and Lion restores everything so nicely, it's an endurable problem, but if an update fixes it, great!)

  • Barry Breen Level 1 Level 1 (70 points)

    Stuart,

     

    I have a MBP-R (Sep '12) and Thunderbolt 27" external display for desktop use running 10.8.2 and I have both USB-3 and Thunderbolt working fine. I do have USB-3 SSD (Elgato 240 GB) and I have Thunderbolt SSD (LaCie 240GB--2 of them). In my setup, I have a USB-3 4 port Hub. My USB 3 devices are the Elgato drive indicated above and a USB-3 card reader. Those work okay too. I also have a SuperDrive, Mac Extended Keyboard and Turbo Mouse connected to the Thuderbolt Display USB 2 ports.

     

    An examination of my System Information for USB shows the following:

     

    USB1.jpg

    Note that all my USB-3 devices are shown under the USB 3 Superspeed Bus. I did have an earlier problem where I had connected the devices in such a manner that I had a USB 2 device slowing down my USB-3 and when that happened the USB System Information indicated indicates a USB-3 device utilzing a USB-2 pathway. To verify, devices are actually using the fastest bus (with, obviously, all compatible USB 3 Superspeed equipment in the chain) check the USB information. If it shows the device in the Superspeed path, nothing should prevent its operation at the fastest USB rates.

     

    I hope this is helpful. Just a novice since '89 on Macs, slow learner I am...........

     

     

    Regards,

    Barry

     

    Message was edited by: Barry Breen (just added some info)

  • Barry Breen Level 1 Level 1 (70 points)

    Just a correction.  My Elgato drive is also Thunderbolt interface (not USB3). My USB 3 drive is a "My Passport - Edge" 500 GB HD. It transfers to/from the MBP-R at about one-half the Thunderbolt interface speed (172,000 GB in 60 min for the USB 3 and about 30 min for Thunderbolt--both to an empty drive with all zeros stored to start.

     

    Sorry about the error in the above post.

     

    Barry

  • Barry Breen Level 1 Level 1 (70 points)

    I just found the following link in Apple Discussions:

     

    http://support.apple.com/kb/HT5172#7

     

    The FAQ's answer something that has been discussed here. If you want to run at USB-3 (Superspeed) rates, the FIRST device you plug in to a computer USB 3 port MUST be a USB 3 device (with all compatible USB 3 hardware (i.e., USB 3 cable). So, plugging in a USB 3 Hub must be accomplished first PRIOR to any other device being plugged into one of the two USB 3 ports. Once that is accomplished you could plug in USB 3 or USB 2 devices to the USB 3 Hub and it will be assigned to an appropriate USB 2 (highspeed) or USB 3 (superspeed) bus. I did not know this until I read the FAQ. Apple actually indicates that the first device plugged into the computers USB 3 ports will confiture the port (so, if you plug in a USB-2 device first, that's what the external port will run at.

     

    Again, see the above Apple FAQ if you haven't already. Sorry if this is repetative.

     

    Barry

  • FatMac>MacPro Level 4 Level 4 (3,395 points)

    Barry Breen wrote:

    ...Apple actually indicates that the first device plugged into the computers USB 3 ports will confiture the port (so, if you plug in a USB-2 device first, that's what the external port will run at...

    Having read that link and not having a Mac with a built-in USB 3.0 port to test it (my Mac Pro has a CalDigit USB 3.0 PCIe card which doesn't need configuring, it just works), configuring a port means to me establishing the behavior of the port from first use onward. In other words, is what you plug into the port the very first time going to determine how that port will behave forever after, so to speak? If so, that means using a USB 2.0 device first can screw up the port big time. Is that interpretation correct or only from one boot to another, or is there some way to revert to USB 3.0 configuration after such an error?

     

    Or, are we only talking about daisy-chaining so that a single device plugged into the port is a different situation and whichever device type is plugged in will just be handled correctly and automatically?

  • Barry Breen Level 1 Level 1 (70 points)

    No, they don't mean configure as in forever. But, I'm pretty sure it is after a boot (power up or re-start). What I'd like to check is whether they mean the ability to "configure" each port individually, or does configuring one affect the other too. So, there are a couple of things to check. These are not too difficult to do for me, and I will probably fool around to clarify what it all means.

     

    Your question about "re-configuring" is also good. Can one re-configure without re-booting? Again, I'll try and mess around with this and see what I find out. Thanks for asking those questions.

     

    Regards,

    Barry

  • FatMac>MacPro Level 4 Level 4 (3,395 points)

    Thanks for the feedback and interest.

     

    Another question which I've raised elsewhere. If an external USB 3.0 drive has a bootable partition, can you boot from it? I know it'll show up in Startup DIsk and maybe in the boot manager, but will it boot just like an internal partition and at USB 3.0 speeds?

  • Barry Breen Level 1 Level 1 (70 points)

    Yes. But, make sure it is a "GUID" partition map and formatted "Mac OS Extended (journaled)". I have done that many times with both USB, Firewire and Thunderbolt interfaces on external drives. Even though USB 3 is fast I must tell you that it still seems like a slow process. I actually think Firewire boots faster from an external drive. Of course, Thunderbolt is almost like having the external drive act as an internal drive it is so fast.

     

    Of course ensure that the backup or copy software you use can create a bootable clone (Carbon Copy Cloner, Tri-Backup, etc)

     

    At least that has been my experience, but remember I'm using the MacBook Pro i7 at 2.7 GHz. Other experiences can vary.

     

    Barry

Previous 1 5 6 7 8 9 Next