5 Replies Latest reply: Sep 21, 2012 12:01 AM by floridajoseph
Thomasaab Level 1 Level 1 (0 points)

I had hidden photos in iPhoto, but they can't be found in Aperture. The "projects" show the correct number of photos (i.e. 684), but there are only two photos. None of the hidden ones.  What's up?  I have more than 30,000 photos, with quite a number of hidden ones that I just don't need to see on a regular basis...

iMac, Mac OS X (10.7.4), iMac 27", 3.06 dual with 12 gigs
  • léonie Level 10 Level 10 (82,265 points)


    Hi Thomas,

    Have you checked the search fields in the Browser and Viewer if any filters are set? If they do not show "All items" or "Showing All" clear them.




  • Thomasaab Level 1 Level 1 (0 points)

    Vielen dank, Léonie,


    No filters are on, and the library spotlight shows "All items."  But still not there. I'll really hate having to go back to figure out what photos are hidden. I want them to move over, but what a pain. And see the lovely colored icons in your clip? that all get's lost in 3.3.

  • léonie Level 10 Level 10 (82,265 points)

    You may have an invisible filter set. This can be cleared by the method described in Frank Caggiano's User Tip:

    Images not appearing in browser, search filter is cleared


    If that does not work, I'd try to repair or rebuild the Aperture Library using the First Aid Tools:


    Launch Aperture with the cmd-option key combination (⌘⌥) firmly held down. From the "First Aid" panel that appears try the three options: Repair Permissions, Repair Library, and Rebuild Database in turn. Hopefully one of them will bring your images back.

  • dangerD81 Level 1 Level 1 (10 points)

    Yeah, it looks like if the images are hidden in iPhoto you will need to unhide them if you want to see them in Aperture.


    They've described the workaround in a kb article.



    From the kb article:

    Photos hidden using iPhoto's Hide command cannot be accessed in Aperture. If you open the library in iPhoto, unhide the photos and then open the library in Aperture, the previously hidden photos are accessible.

  • floridajoseph Level 1 Level 1 (0 points)

    I recently had the same issue and did the following to correct it.


    1. Open iPhoto and create a new Smart Album.

    2. Set the criteria to "Photo" "is" "hidden."

    3. In order to export these photos, they must be unhidden, so set some other attribute that will keep them unique from the rest of your library, such as flagged or 1-star (you will have to un-flagged all other items in your library to keep these hidden photos sequestered).

    4. Now that they are all flagged or have 1-star, highlight them all and unhide them.

    5. Change the criteria on the Smart Album to flagged or 1-star.

    6. Highlight all the images, click export. You can export the originals to your desktop with their event names as folder names, and simply drag and drop them into the placeholders in Aperture.


    It was a pain but it did the trick.