2 Replies Latest reply: Jun 19, 2012 6:29 PM by BoB 64
TeEtOs Level 1 Level 1 (0 points)

I'm from Egypt, iMessage works and activated perfect on iOS device (Facetime too) on all careers.

The problem is when you intend to use your Apple ID on your Mac or iOS to activate iMessage or Facetime, You will not find Egypt listed in country selection menu. so you will choose another country ( USA for Example ) and it will activated and send iMessage to another Apple IDs successfully BUT not to Mobile numbers because when you choose USA iMessage automaticlly adds +1 to the Mobile number you send an iMessage to.

Moreover I can't use Express Lane Support to call Apple because it's not supported for Egypt.

By the way I tested this on iMessage Beta and iMessage on Mountain Lion DP4 (I'm not a developer I got this copy from a friend who is a developer).

So Guys how I can send this bug or send a suggestion to Apple with this issue ?!


MacBook Pro (13-inch Mid 2010), Mac OS X (10.7.4), iMessage
  • 1. Re: iMessage Bug
    Topher Kessler Level 6 Level 6 (9,340 points)

    Developers have the opportunity to submit bugs in the AppleSeed or Developer communities, so your friend could submit such a feature request or bug. Beyond this your options are to use the Apple feedback page: http://www.apple.com/feedback/

     

    In the feedback page you can use the iChat feedback, or the OS X feedback submission forms.

  • 2. Re: iMessage Bug
    BoB 64 Level 1 Level 1 (0 points)

    I would have to agree with you, this has been driving me crazy on both my phones for 2 days, and I'm the guy that always solves everyone's problem with Macs or IOS device.

     

    I've reset, restored, erased all contents and settings and and and, nothing seems to work.

     

    I'm currently in Saudi Arabia, with a local Saudi number that I've been using for years with no problem, I was actually in Saudi just 6 days ago and everything was working fine, now all of a sudden, I can activate for my apple ID, but not the number, and the funnu part is that when I go to setting and choose phone, I see my number, but when I go to iMessage or face time, I see the number that was in the phone, and I've restored and reset my networkd settings many time, I even did erase all contents and settings, and activate it as a new phone, with iCloud and without and still does not verify the number.

     

    Then I thought let me try one of my other numbers, so I inserted my Orange number from france and restarted and it all worked fine, then I tried it on my other phone and it also worked fine. Then I put my stc 'Saudi provider" chip in and natha, stoped working, show my phone number in the phone settings, and my french number in iMessage and FaceTime settings and verifying forever, rest the network setting, no go. it is driving me crazy, I'm going to try to change my location to somewhere other than the US and see if it works if the adding 1 to the number bug does exist.