Previous 1 2 3 4 Next 52 Replies Latest reply: Jul 5, 2013 11:23 AM by Old Toad Go to original post
  • moarfish Level 1 Level 1

    What did you do to solve the problem? I still have the same problem even I have updated to 10.8.1.

  • craigmcg Level 1 Level 1


  • ATC7 Level 1 Level 1



    Still having this issue and I'm also on 10.8.1.

  • sk2001 Level 1 Level 1



    On each start iPhoto tries to update thumbnails and fails just immediately ("cannot find xyz1234.jpg"). I then try to cancel that dialog and immediately cancel the update process just before the next "cannot find" dialog pops up. I have to use the space bar as using the trackpad is too slow.


    After that, iPhoto can be used and my library seems to be OK, but the application ist extremely slow.

    I'm using an iPhoto library with about 53k pictures on an external USB harddisk, iPhoto '11 (9.3.2), still on Lion. Some of the former iPhoto versions were quite fast, some as slow as this one, so it's not a hardware issue, I think.


    I have tried all kinds of repairing / refreshing / salvaging the library.


    Btw, Aperture hangs on startup, too. Cannot even cancel that — the application is just unusable. I purchased Aperture just because I had hoped to circumvent the iPhoto problems.


    Very annoying at the moment. I hope some future version will get this fixed.

  • Terence Devlin Level 10 Level 10

    That's a different issue. it's trying to find a photo - ("cannot find xyz1234.jpg") - and it's missing. In other words a corrupted Library.


    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)



    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.



    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.  

  • ATC7 Level 1 Level 1

    Sorry to bump an old thread. FWIW, with Apple's latest update to iPhoto to version 9.4 (released today), I no longer see the "Updating Thumbnails" come up on iPhoto startup. My library is 100GB+ and this is awesome news. I tried closing and restarting iPhoto several times today and nothing. It's working great now.

  • craigmcg Level 1 Level 1

    Unfortunately, still not working here.

  • moarfish Level 1 Level 1

    Thank you very much!! The iPhoto 9.4 also solved my problem!!!

    Here's the run down.


    1. Updating Mountain Lion to 10.8.2.

    2. Reboot

    3. Run Software update again, iPhoto 9.4 show up as update.

    4. Install Update.

    5. Run iPhoto

    6. It will ask to Upgrade the Library. Let it update!!

    7. After a long upgrading, it will "Updating Thumbnails...". (Yes Again! but don't give me, let it complete, don't skip this)

    8. After it updating thumbnails complete. Close iPhoto

    9. When you close iPhoto, it will say Updating library.... For this first time closing iPhoto, it takes very long time. Be patient. Don't Force Quit.

    10. After it successfully close the program, Launch iPhoto again.

    11. Yes!!! No more Updating thumbnails!!. Close iPhoto. (THis time very fast)

    12. Open iPHoto again. YEAH!! Really no updating thumbnails. DONE. test is done.


    This long long problem finially solved in 9.4

  • craigmcg Level 1 Level 1

    Not solved in 9.4 here.

  • dawideksl Level 1 Level 1

    9.4 update worked for me.

  • BenjaminP Level 1 Level 1



    if this can help - I had the same problem and was stuck trying to reconstruct thumbnails (iPhoto 8). I looked a bit into the iPhoto library package content, and the problem was that the folders for the thumbnails (Data in my case) was a file - and the original structure cannot be rebuilt by iPhoto.


    open the terminal and navigate to the iPhoto folder (type cd and then drag and drop the iPhoto library into the terminal, then type the return key).


    Then type


    if test -f AlbumData.xml; then sed -n  '/ThumbPath/{n;p;}' AlbumData.xml |   sed -E -e 's#.*<string>(.*)</string>#\1#g' | sort | uniq |  while read f; do f=$(dirname "$f");   if ! test -d "$f"; then if mkdir -p "$f";  then echo "Created directory $f";  else echo "Failed to create directory $f";  fi; fi;  done;  else echo "You are not in a iPhoto library";  fi



    If there are some folder created (you will see some output), then that must be the reason. If it fails to create some directories, then you have to fix this manually (please post a message if you need some help).

  • Tornad0 Level 1 Level 1

    I'm still having the issue in 9.4.2. Anyone else?

  • craigmcg Level 1 Level 1

    yup still broken here.

  • crickfrompalo alto Level 1 Level 1

    I have this "upating thumbnails" problem too.

    iPhoto 9.4.3, OSX 10.8.1

    Have rebuilt data base using iPhoto, and using iPhoto Library Manager.

    Problem is persistent.

    Library is located on a NAS fwiw.

  • Old Toad Level 10 Level 10
    Photos for Mac
    Library is located on a NAS fwiw.


    That's the problem.  The iPhoto Library must be located on a volume that's formatted OS X Extended (journaled) for it to work properly.  I belive it's how the NAS assigns permissions compared to OS X. 


    Bottom line: move the library to a correctly formatted hard drive, repair it and all should be well.