Previous 1 2 3 4 Next 52 Replies Latest reply: Jul 5, 2013 11:23 AM by Old Toad Go to original post
  • Tornad0 Level 1 (0 points)

    Would this be the case for a 2 drive software RAID created by Disk Utlity? Because that is what I'm using (2x512 SSDs as my boot and main drive in a RAID 0).

  • Old Toad Level 10 (135,551 points)

    How are they formatted?  I believe if they are OS X Extended (jourlaned) it will work. The problem your having is with the thumbnails being updated each time your open iPhoto?  What fixes have you tried so far?

  • Tornad0 Level 1 (0 points)

    It does indeed create a single journaled volume. I do have thumbnails being updated every time I open iPhoto as well. I have tried all the standard ones, just short of doing the full rebuild with iPhoto Library Manager that some others have suggested. For my Library that would not be doable in a timeframe that made sense, but I've done all the rebuilding options built in to iPhoto. Any other suggestions are welcome.


  • Old Toad Level 10 (135,551 points)

    At this point I'd try the iPLM rebuild.  It will leave your current library untouched so that you can keep working on a fix for it if you don't want to use the iPLM library.

  • crickfrompalo alto Level 1 (5 points)

    I run my ~118 MB iPhoto library on an iSCSI drive formated OSX extended (journaled) set up on a 12 TB QNAP TS-469L accessed via globalSAN iSCSI initiator from a late 2008 Mac Pro running iPhoto v9.4.3 on OSX 10.8.3 with 12 GB of RAM over GB Ethernet.


    From the literature I can find, this is the recommended setup for running iPhoto libraries on a NAS.


    Yet, whenever I launch iPhoto, the application "updates thumbnails" - even if the app is closed and reopened with no actions taken when opened. 


    I have launched iPhoto with option-command pressed and run a database recovery, thumbnail update, and permission repair.  What I have not done is rebuild the database (I really don't want to do that as I will lose years of work).


    So this does not appear to be a file system formatting issue (btw, I did put the file on an ext4 formatted partition of my NAS and iPhoto behaved exactly the same though took longer do it's thumbnail bit and was sluggish compared to the HFS+ iSCSI partition).


    Still - whenever I launch iPhoto, the application "updates thumbnails" - even if the app is closed and reopened with no actions were taken when opened. 


    Since nothing else seems to be problematic with iPhoto and my library, should I conclude that "updating thumbnails" is expected behavior?

  • Old Toad Level 10 (135,551 points)

    The format is right.  Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import a number of photos and test to see if the same problem persists. If it doesn't you may wnat to try one of two things:


    1 - r ebuild the library with  iPhoto Library Manager.


    2 - use the paid version of iPLM to copy events from your current library to the new one.  Test the new one after every 10 or so events have been transferred.  The only items you'll loose are books, cards, and slideshows.  I beliewve slideshows can be brought over as album so you can easily recreate the slideshow.  Not sure about books.

  • crickfrompalo alto Level 1 (5 points)

    I created a new test library and imported about 2,000 photos.  No updating thumbnails behavior.


    I have the latest paid version of iPLM, so attempted a rebuild of my main iPhoto library.  iPLM got to through the rebuild priview but failed to actually to the rebuild with this error message: "An error occurred decompressing the default library archive (2)."


    So I contacted Brian Webster of Fat Cat Software (iPLM) who was incredibly responsive and helpful.  Brian actually looked through the log files from iPLM and replied:



    Thanks for the log files, I took a look through them, and I definitely see something funky going on there. It appears that all the paths to the photos reported in the log have an additional component in the path which should not normally occur. For example, instead of "/Volumes/iPhoto_iSCSI 1/Crick iPhoto Library.photolibrary/Masters/2013/01/13/20130113-143828/s800IMGA0127.JPG", it instead reports "/Volumes/iPhoto_iSCSI 1/Crick iPhoto Library.photolibrary/Masters/2013/01/13/20130113-143828/.@__thumb/s800IMGA0127.J PG" (note the additional ".@__thumb" part).


    I've never seen something like this before, so I think the next step would be for me to take a look at the data files from that library myself and try to figure out why that's showing up there.


    After a bit of back and forth, Brian concluded:



    I did a Google search for that ".@__thumb" string, and found a couple forum threads on the QNAP forums (e.g. from people who had similar folders show up on their setups with the same name. I looks like they get created by some software related to the NAS.


    I think the next step was, once those thumbnails were there, at some point iPhoto did a photo recovery (possibly using one of the rebuild/repair functions of the program), found all those thumbnail photos sitting inside the library package, and added them to the iPhoto database. I see there is an event named "Recovered Photos" which appears to have 36795 photos, which is what I would expect from how iPhoto's recovery routine works.


    Finally, at some point after that, the thumbnail files got deleted (most likel by some intervention from the NAS software), so now all those references in the library point to now-deleted photos, and thus are not included when iPLM does its rebuild.


    So, as far as I can tell, it appears that all the photos that are supposed to be there are there, and it's just all those thumbnails that are "missing".


    So, end of the day:


    1. Use iSCSI GlobalSAN formated in OSX extended with iPhoto
    2. Use iPLM to rebuild the library and eliminate ".@_thumb" files


    All working now! 

  • Old Toad Level 10 (135,551 points)

    Thanks for the feedback.  Glad it's all straightened out and working.

Previous 1 2 3 4 Next