11 Replies Latest reply: Jan 28, 2013 12:36 PM by _smed
Tim's Tree Level 2 Level 2

I did Apple's update for Java yesterday (1.6.0_33).  Now none of the sites that I must use that require Java work. 


In Safari the Java applet logo appears on the page, I click to load it and instead the applet, it just disappears with no trace left on the page.  Very similar behavior in Chrome and Firefox. 


I searched for the previous updater to see if that would work, however, it just appears now to redirect to the current updater.


Any suggestions on what I can do?





P.S. Yes to those will say it, I understand the dangers of going back to a previous version of Java, but I have no choice but to try, I simply cannot do my work anymore with the current version. 

Mac OS X (10.7.3), 5 GB RAM
  • Barney-15E Level 8 Level 8

    Does this page work?



    Try rearranging the order of the JRE's in Java Preferences so that the 32-bit one is on top.


    What pages don't work?

  • Tim's Tree Level 2 Level 2

    Yes that page shows that Java is working on my Mac.  I just tryed rearranging 64/32 and that did not work either. 

    This happened a year or two ago, when I think I was using Snow Leopard and I had to go back a version, but back then the old versions were still available.

  • Barney-15E Level 8 Level 8

    Java Update 1 (.29) is on the Apple Downloads site. I imagine you would have to uninstall Java somehow. I believe installing the 10.7.4 update would likely remove Java.

  • Tim's Tree Level 2 Level 2

    I've tried that link many, many times, it always redirects to the current Java release. 

  • Barney-15E Level 8 Level 8

    Click on the download button instead of the link.

  • X423424X Level 6 Level 6

    Make sure you have a bootable backup before you attempts this.  There is no simple way to uninstall a java installation since it has stuff installed in a lot of different places in the OS.  So unless the older java installer (a) doesn't have a version check prohibiting it from installing in the first place and (b) installs all the same stuff the newer installer installed in the same locations, then there is no guarantees you will end up with a working java.  Thus you will have to revert from your bootable backup.

  • GGPP Level 1 Level 1



    Just came across this thread and hope you don't mind my asking (not wanting to hijack your thread, but it seems related). I'm wondering if you ever figured out the problem?


    While my issue doesn't involve work, it's annoying. I can't get into gaming rooms I used to have no problems with. In reading the forums on that site, it seems other Mac users are having the same issues and that it might be related to Java.


    I recently had my MacPro in for service (for a new video card) - it was updated to Snow Leopard 10.6.8. and the tech also updated everything else that needed updating.


    I tried rearranging the order of the JRE's in Java Preferences, but that didn't help. Wondering if I should try and go back to an older version of Java, if you did that and it worked?

  • Tim's Tree Level 2 Level 2



    Sorry to say nothing worked.  There are many instructions on how to uninstall Java.  You can kill it, so it no longer works, but as far as I've found (and I've studied this to death) you can't completely uninstall it.


    The problem is the OS still has a pointer somewhere indicating a certain Java installation is in place.  So, when you try to go back to an older version, it prevents you from installing it.  (If you want to reinstall the same version you had, you have to do it via the terminal command, downloading the update package does not work at that point.)


    I understand that Oracle has a version of Java out this week for the Mac.  Macworld had an article about it a few days ago.  I wondered if this might solve my problem, but there was a lot of confusion as to what you were supposed to actually install, so I decided to wait.  I use Adobe's Creative Suite which runs on Java, so I didn't want to create any more havoc.


    For my work that depends on the older Java to work, I am using Firefox in the Mint OS.  I run it via the free Virtualbox VM software.  I tried Ubuntu, but could never figure out how to get Java installed on it.  Mint came with the right version of Java and is so customizable you can make it look quite Mac-like, even down to using the Command key (instead of control) for copy, pasting, etc., etc.  It's not the ideal solution, but it works, is super easy to use and it's all free.

  • GGPP Level 1 Level 1

    Hmmm - well, I may have to just sit tight and hope a solution shows itself - it seems like it has to, at some point.


    I use Adobe design software as well, though I don't have the suite, just individual programs, so I don't want to mess anything up either. Though I imagine you might be talking more about web work, and I design primarily for print, so ...


    I confess to not really understanding a word of what you wrote in the last paragraph. I can get around my Mac pretty well, but some things are too "techy" for me - like Virtualbox VM ... I have no idea what that is. But I'll ask my Mac tech friend what he suggests.


    Thanks for the reply.

  • Tim's Tree Level 2 Level 2



    I use Adobe design software as well, though I don't have the suite, just individual programs, so I don't want to mess anything up either. Though I imagine you might be talking more about web work, and I design primarily for print, so ...



    I do print too.  When I do web design I don't use Adobe Dreamweaver or anything they offer.  (Don't get me started... )


    My point was if you take Java off your system, your Adobe apps will not even launch.  InDesign, Photoshop, etc.  They require Java to run, so that is very concerning to me going to Oracle's version without knowing more.

  • _smed Level 1 Level 1

    Hi all,


    I just got a new Mac and was trying to launch Adobe (Omniture) Discover.


    I found Apple support article that helped re-enable Java 6 SE.


    Basically you have to download latest release of Java, then follow steps in terminal to get Java 6 working.




    Good luck.  Worked for me.