5 Replies Latest reply: Jun 16, 2012 1:31 PM by albrad
albrad Level 1 (0 points)

Hey everybody,


Long story short, I erased my hard drive, and I don't have any way of re-installing OS X. All of the files and stuff I care about are backed up, so I'm not worried about that, I just don't have an OS (or even a partition) on my MacBook Pro anymore.


How did I get in such a stupid situation you might ask? Well, I'll tell you. I was having a kernal panic, which then turned into not properly booting, which then turned into not booting at all, even into safe mode. I then went in to recovery mode to try fix things, but this was to no avail. There were errors in the hard drive check, repair did nothing to fix them, and so I knew that I needed to reinstall since the computer wouldn't boot into OS X.


I thought that was going to be easy, since recovery mode comes with an option to reinstall. But, of course, this would not work. I should mention that I had FileVault encryption on, and could not manage to get it off (the option in Disk Utility was grayed out, I tried some of the terminal commands, but that didn't work either). What seemed to be happening is that the partition wouldn't mount. But whatever the reason, the reinstall option just would not work. I would try it, it would fail and say try again, I'd try again, it would fail, and so on. At this point, I was running low on options that I could do.  I (stupidly!) didn't make a Lion recovery disk (though, I should note, it's ridiculous for a computer not to come with a DVD), I didn't have any full backups. At this point, I figured that the errors on the hard drive or the encryption were what was preventing me from re-installing the OS using recovery mode, so I figured that I should just format the Mac OS partition. I assumed, wrongly, that the recovery mode was on a seperate partition (as it is, for example, on a Thinkpad), such that I could erase the partition with the OS actually on it but still boot into the recovery mode, and thereby install the OS on a pristine hard drive. I now recognize that I should have looked into this more, since apparently in erasing the Mac OS partition, I also erased the Recovery Partition, or at least when removing the the Mac OS partition I removed the ability to boot into the recovery mode. So basically, the computer won't boot at all (obviously) since all it has is a blank hard drive.


So, my question is, what should I do? I'm hoping that if I go to an Apple store, they can just give me a fresh install of Lion. Will they?


As I said, I have the files I care about backed up, so I'm not concerned about data loss per se, I just need an OS on the computer. But is there anything else I can do?


I guess the worst case scenario is that I have to buy the USB drive, but I'd really like to avoid that.

MacBook Pro (13-inch Early 2011), Mac OS X (10.7.2)
  • crampy Level 4 (1,135 points)

    I am thinking if it was me, I would telephone the apple store and set up an appointment with a Genius Bar worker...and be ready to pay for a new install.... But diagnose what went wrong.

    I would also be careful about that vault. Are you SURE you entered the right password? maybe all this is from entering the wrong password?

    Good Luck. Sorry I am no help at all. But hey- commiseration has helped me before....

  • softwater Level 5 (5,370 points)

    Your assumptions were right about Recovery being a separate partition. How did you erase the disk, from withing the recovery partition? If so, the recovery partition must still be there.


    Can you still boot into Recovery HD? Try restarting while holding down the 'Option' key rather than 'command-r'.

    Do you get any bootable disks? You should get the recovery partition.


    If so, boot into it. Go to Disk Utility and do 'Repair Disk'. Do it more than once if necessary, or until no more errors show. Once the disk is repaired, choose 'Reinstall OS X Lion' from within recovery. You need to have an active internet connection in order for this to work.


    In the event that you can't get any joy, an Apple store will reinstall it for you. If your machine is less than 12 months old, they should do this for free.

  • albrad Level 1 (0 points)



    The computer does not boot *at all* now. It goes to a white screen for a about 10 seconds, then goes to the question mark folder. Holding command+r, command+s, whatever, does nothing.


    If my original assumption was right, that the recovery utility is on a seperate partition, then why won't it allow me to boot to that partition? You're right that I erased the Macbook HD partition from the recovery utility. Did the boot table somehow get erased? I don't understand how erasing the OS partition should erase the boot table, but that would explain why it won't boot even in to recovery mode.


    All of the other stuff you mention I tried before formatting. None of it worked, even Reinstall OS X Lion option failed -- it would fail, tell me try again, then fail again, ad infinitum.


    Luckily, my machine is less than 12 months old, and I have a pretty convincing tale of woe to tell them as well.




    Thanks for the commiseration.

  • softwater Level 5 (5,370 points)

    I can't explain that either but if you can't even boot into single user mode something is very wrong and you're going to need another computer to sort it out. Hence, best thing I can suggest is take it to the shop and save yourself further ado.

  • albrad Level 1 (0 points)

    After doing some more research, I found out that actually even though Recovery HD is a different partition, it's a hidden partition which goes along with the OS partition. So in deleting the OS partition, you also delete the recovery partition.This of course defeats the entire purpose of making a seperate partition, or even having seperate partitions on the drive, and so I cannot understand why the engineers at Apple would do things this way, but this is the case. In deleting the OS partition, you also delete the recovery partition, hence my inability to boot at all. I just cannot understand why the Recovery partition would not show up on the disk utility. I could tell it was there because of the difference between the hard drive's reported size and the Macintosh HD partition's size. But it didn't show up on the list.