Previous 1 2 3 4 5 6 Next 81 Replies Latest reply: Dec 10, 2013 5:59 AM by SCM73 Go to original post Branched to a new discussion.
  • bugboi Level 1 Level 1 (0 points)

    I honestly think they are trying to kill USB 3. I went and bought a thunderbolt drive and it works perfectly. Twice as expensive and barely as fast as USB 3.0... Totally Apples MO these days fleece, fleece,fleece

  • wuc Level 1 Level 1 (0 points)

    Well, I finally got tired struggling with getting my WD passport working with the MBA, sold it and bought an Iomega Prestige 1TB USB 3.0 drive. Since that upgrade I haven't encountered any problems whatsoever. When looking at the system report, the drive correctly requests more power from the USB port (Currrent Required (mA): 900). I strongly believe the source of all this problems is on the drive side, the MBA just gives the device only that much power as the drive requests (224mA in the case of my old WD drive).

  • EJW Tas Level 1 Level 1 (0 points)

    The MacBook Air/Pro Update 2 dPatch idn't fix the problem - my MacBook Air (mid-2012) still can't handle externally-powered USB 3 hard drives; I still need to use a powered USB 3 or USB 2 hub to use large (3TB drives) !!!!

    no problems with WD 1TB USB3 bus-powered drives, but 3TB in powered external enclosure still u/a


    will be sending another bug report to Apple ...

  • davicastro Level 1 Level 1 (0 points)

    Same as here. My USB3.0 Toshiba Canvio drive (which is powered only by the bus), still does not work with the latest 2.0 update. Just tested it. (Only works as before: by using a 2.0 micro usb cable, which is not quite a real solution)

  • juliemeikle Level 1 Level 1 (0 points)

    My USB 3 drive still does not work despite all the updates. It is a Lexar. I am wary of throwing money down the rain and trying a different make as mine is a 64 gb so not cheap.

    I don't understand why these mbas are stilled billed as USB3 . Mine is not recognised. Why would I use a cable or a hub to down grade to USB 2? If so I would have bought a cheap USB 2 stick!

  • joshweiss Level 1 Level 1 (0 points)

    I've tried several USB3 drives as well, and in all cases, they do not work.  Oddly enough, I got an Esata to USB3 converter cable, and plugged drives in, in some cases, the same drives that did not work directly with the usb3, and they DID work.  And yes, these are all USB3 drives. ***?

  • chelidon Level 1 Level 1 (0 points)

    I can confirm problems with USB 3.0 drives and mid-2012 MBA.  I have been using external bus-powered USB 2.0 drives with no problem, but an external (powered) LaCie 3T drive I received yesterday was recognized and formatted (2 MacOS Journaled partitions, 1 FAT32), worked for a day, and then suddenly dismounted both MacOS-formatted partitions and stopped recognizing them, but (oddly) would recognize the FAT32 partition on the same drive. Unplugging/powering down/replugging the drive doesn't help, and the MBA won't even recognize the MacOS partitions again - I had to completely reboot the MBA, at which point it did recognize the drive again, just long enough for me to transfer all the data I had off it, and then it had the same issue yet again.


    I thought I just had a bad drive, but today I received a 1TB Transcend StoreJet USB 3.0 drive, and I am seeing the exact same issues (sudden dismount, warning message, drive partitions can't then be recognized or mounted, Verify/Repair fails, etc).


    I've tried this with and without a powered USB 3.0 hub, so that's not the problem.  Given the messages here, I'm beginning to suspect some sort of systematic USB 3.0 problem with at least some of the mid-2012 MBA. 

  • joshweiss Level 1 Level 1 (0 points)

    The USB3 support on current macs is atrocious, AT BEST!  I took my machine to the apple store to check it out, they tried their lacie 1tb rugged drive.  It worked great.  Then I gave them another drive, a newtech voyager q.  No luck on my system or their test machine.  Their answer...hmm, that's odd, I guess you'll have to wait for an update....




    Tried another drive as well.  No luck.


    Tried a usb3 hub, it works with usb2 devices.  Plugged in a usb3 card reader that works fine directly hooked up, and now that doesn't work either.  I never had a single problem with usb2.  Where is apple on this?  You take away the mac pro, or at least don't give any real updates for years, so now for my desktop I am looking toward an iMac. Which means, I need fast external storage.  Thunderbolt is still too expensive, and I have no confidence the usb3 drives will work properly.  Update the firmware, update the os, whatever you need to do, make this work!

  • chelidon Level 1 Level 1 (0 points)

    In any case, what I was planning to post is the follow-up that after my poor experiences with a mid-2012 MBA and USB 3.0 devices, I switched ports (the left USB port is now attached to the USB 3 hub and devices, and the right USB port is now attached to my USB 2 hub and devices), and so far, everything is working perfectly.  I plan to run some stress-tests to see if this holds up.


    <Edited by Host>

  • iliakeapple Level 1 Level 1 (0 points)

    could anyone help me with a problem too? pleaseeeee go to my profile and see it in my stuff... it's about if i can delete my files form the download folder which i have put them in other files too . but i don't want them deleted from the other files i want them deleted form the download folder. shall i delete them from the download folder or will they be deleted from the others too.... it's macbook air. thanks

  • fullframesf Level 1 Level 1 (0 points)

    You can add OWC Mercury Elite Pro mini USB 3 + eSata to the list of incompatible.  I can't get the 2012 Air to recognize it either as a USB 3 or USB 2 drive.  I plug it into my 2010 Air, 2008 Mac Pro, and they both recognize it and enables USB 2 mode.  My Windows desktop recognizes it as a USB 3 device.  I'm  quite disappointed.  I just got the Air today and was excited to see the speed as I transfer all my files to it, and the machine won't even see the device.  System report in about this mac doesn't even show the device listed off of any USB nodes.  I'm wondering if Apple will fix this problem for us or wait till the 2013 models to do so.


    I'll be chatting with both OWC and Apple support tomorrow.  I don't expect much, seeing how long and how many these threads are.  The fact that OWC keeps advertising these enclosures for the new 2012 machine seems very seedy.

  • KarenLynx Level 1 Level 1 (0 points)

    Yes, so far this is the only usb drive that has all functions on the MBA: LaCie 500GB Porsche Design P'9223 USB 3.0 portable drive. I have other usb 3.0 drives that are recognized and I can do some things with. But the LaCie is the only only that I can write to and boot from using usb 3.0

  • bugboi Level 1 Level 1 (0 points)

    It is a power issue and will NOT be fixed by an update.

  • KarenLynx Level 1 Level 1 (0 points)

    Yes, it is a power issue. So, in addition to the LaCie Porsche Design P'9223 USB 3.0 portable drive, the

    Silicon Power Stream S20 Portable 1 TB USB 3.0 External Hard Drive also works as a full fledged usb 3.0. However, cannot create a working bootable drive with this one. And most usb 3.0 flash drives will works because they do not require as much power.

  • fullframesf Level 1 Level 1 (0 points)

    How are you so sure it will not be fixed by an update?  Has Apple stated this?  It is possible to design circuits that output variable power, depending on firmware.  Apple even did this with their iPad before with the camera connector.


    Anyway, I have a WD My Passport USB 3 notebook drive, and it works flawlessly.  I know some people are having problems with A version of the Passport, but my version is the 1TB "My Passport" notebook drive, and it works great.  So, if anyone is looking for a drive that works, I can verify it works and runs at USB 3 speeds.