12 Replies Latest reply: Sep 15, 2012 8:58 AM by Kens Ipod Branched to a new discussion.
lkadlec Level 1 (10 points)

I discovered this problem on my desktop computer when I was having trouble updating iTunes, but I've now found that it is also happening on my laptop, which runs a different version of Windows.

 

When I run Apple Software Update, it checks for updates and says that new software is available, but then there aren't any updates listed to select.  I just noticed this behavior today when I tried to use USD to update iTunes on one of my machines to 10.6.3.  The last time I used USD it was working fine, and there were a couple of pieces of software (iCloud Control Panel, Safari) available, but I chose not to install them.  Now they don't show up on the list (or rather, there *is no list*).  I have this same issue with two different computers, one running Vista and one running Windows 7.

 

A search of the forums turned up multiple mentions of what sounds like the same problem, and the solution typically involved moving files from some Library folder to the desktop (which I guess in some way 'resets' the updater).  However, all of the examples I found involved Mac OS's, and I don't know where the relevant files would be found on my PC (assuming they are the same).

 

Has anyone had this problem with the Windows Software Update program and found a solution?

  • jckinnick Level 1 (10 points)

    I have the same problem just started this last update a week a go. I think its something on Safaris end hopefully they will fix this problem.

     

     

     

    Also this webiste is messed up i had to sign in three times before it could reply to this post.

  • jstageberg Level 1 (0 points)

    I'm experiencing the same issue -- "New software is available from Apple" but no items to select. I discovered it in the same way as well, trying to update to iTunes 10.6.3 on Windows 7.

  • ClearNexus Level 1 (55 points)

    I am experiencing a similar issue and so are some other users i know But i think the problem is on apples end because it sounds like both of our softwares try to connect to apple but their not sending information back.

     

    my thread is

    apple software update in windows help!!!!

  • Bill3 Level 2 (270 points)

    Me too, running windows 7 in Parallells

  • Steven Dodds Level 1 (75 points)

    Same problem.  not even trying to get me to install Quicktime of iTunes at all on this fresh install of Windows 7. Installed on BootCamp, currently running in VMware Fusion 4.

     

    Blank-Updater.jpg

  • KentMagnuson Level 1 (5 points)

    I get the same thing and always download/install. I see that I have about 20 downloads/installations same update. Apple could tweek the system a bit perhaps so it would recognize what we already have.

  • aschimke Level 1 (0 points)

    I have done some testing of this problem and it seems to be something on Apple's end.  I have had this problem of Apple Software Updater stating there are new updates available but doesn't display what they are.  I had a computer image that is a year old and hasn't had any of the recent updates applied to it.  When I loaded this image it has the same problem.  So it isn't a recent update from Microsoft or Apple that created this problem we are experiencing.  I really believe it has something to do with the way their update servers are displaying the information.

  • samrossi Level 1 (35 points)

    I'm having the same problem too.  I just clean installed Win 7 Home Premium x64 via bootcamp, installed the bootcamp drivers, installed all of the win 7 updates, then went to install apple software via software update and I'm getting the same message everyone else is. 

  • Apfelkacke Level 1 (10 points)

    That is unbelievable embarrasing for Apple... some hundred billion Dollars in cash, but can't afford somebody to fix this small problem!!

     

    A clever guy found the problem for them (DNS issue!), yet MONTHS later Apple hasn't FIXED this crap!

     

    Here's the workaround:

    https://discussions.apple.com/message/18935862#18935862

  • Kens Ipod Level 1 (0 points)

    I'm having the problem on six laptops. It is September 5th, 2012 and the issue is not solved. I used the work around listed above, adding IP address to host file. Not sure how the user figured this out but thankfully he/she did.

  • BlueBlood1978 Level 1 (0 points)

    SOLVED IT

     

    1. Right click on Apple Software Update in the Start Menu and bring up the Properties Window
    2. Select the Security tab
    3. Select your Username (don't worry about what rights the computer Administrators group has, it does not apply here) and select Edit
    4. After you pressed Edit, you should have a Window that shows all the computer groups (Administrators, etc.) and usernames (yours and other users (if any)) on your computer. Select yours.
    5. Change your Rights to Full Control, press OK.
    6. Press Apply, applying the changed settings to Apple Software Update, then press OK to close the Properties Window.

     

    You can now run Apple Software Update and see what programs (updates) there are to download. For some reason, the latest update which came down gave the computer user (in this case, you--meaning pitiful us) no rights other than deleting. This meant that we could not see anything--no updates, nothing. What we just did through this list was give the ability back to the user.

  • Kens Ipod Level 1 (0 points)

    Sorry this didn't work. Putting in the host address worked.

     

    Thanks for the info. Maybe it will work for others.