Previous 1 2 Next 18 Replies Latest reply: Jul 17, 2012 12:46 PM by prefuse77
msim20 Level 1 (0 points)

I allowed the Aperture upgrade to go through. New Aperture upgraded the library. The upgrade was not going through (stuck on step 6), so after searching on the web, I started Aperture with Cmd-Option key. I chose the Rebuild library option and that needed upgrade also, and the upgrade happened.


Now, I cannot see images in projects created over the last two years. The images are in Aperture I can tell - because in Library>Projects I can see all the images. However, if I chose a project in left panel, the project has zero images. If I navigate to Library>Photos, then no photos from last two years can be seen. The search box however shows "showing all" photos - so there does not appear to be an obvious filter on.


All processing, creating of previews, thumbnails, face detection post the library build has happened. Since then I have fixed permissions, repaired library, and again rebuilt library.


The images are definitely there - because I can see the images in the referenced location where I stored them.


Here are some snapshots of what I am facing.


One project in Library>Projects

project with zero.jpg

This one has photos. But this is how I view it in the left panel.



There are other threads with this problem, but I thought that if I elaborate, then maybe some of you can pinpoint the specific problem that I am facing.


Thank you!

Mac OS X (10.7.2)
  • prefuse77 Level 1 (0 points)

    I have the exact same problem. Over 120 GB of photos in the Aperture library but 95% of my projects showing zero images when I click on them : ( Any help much appreciated!

  • Kimberly1212 Level 1 (0 points)

    I guess I'm another one to add to the list.  I have the exact same problem.  All I can see are the thumbnails but nothing else.  When I click on the project which you can see images in, it shows nothing.  I've tried doing all the repairs but nothing has helped.  ??? I am so upset that my pics are stuck in never never land. 

  • bradybruton Level 1 (0 points)

    Exact same issue here - stuck on step six, rebuilt library. I see the images are still there but not showing up. Multiple rebuilds and repairs.

  • msim20 Level 1 (0 points)

    I launched Aperture after a few hours gap, and the thumbnail generation has begun again. This thumbnail generation appears to be for all images, and not necessarily from the projects that are missing photos.


    Here it is:



    Now, I do not know if my problem of missing images and this thumbnail generation are related. I will report back after all the generation has completed. Will quit Aperture and relaunch it. But I doubt this will help because I think these thumbnails were generated the first time I upgraded as well (because that upgrade only succeeded beyong step 6 when I chose the option of Rebuild Library).


    One other thing I noticed after I posted the message above - all the images were showing unconnected - I have a referenced image library for the most part. The Macintosh HD was showing offline when I tried to locate images in Finder. Now how is that possible - the MBPro is what Aperture is on. And I have not changed the HDD or anything like that.

    What I did do was launch in single user mode and ran /sbin/fsck -fy. Wondering if that had something to do with Macintosh HD showing as offline.


    All this may be extraneous detail, but I am hoping that somebody somewhere hopefully has solved this problem. Alternatively, may be Apple / Aperture pro support team will notice so many people are having this exact same problem.

  • msim20 Level 1 (0 points)

    I could figure no way of solving this problem. Neither are any experts on this forum able to solve this unique problems. So after hours and hours of trying various things, I have decided to roll back to the earlier state that I have backup of. And now will have to do hours and hours of work to get back to speed on new imports and library changes since my last backup.


    Lesson learnt - not to trust upgrades. This is not the first time that I have learnt it unfortunately. For a few years now, I try to wait a few weeks before upgrading any software. I did not realize that in this case I did the upgrade just a few days after release.


    The other bigger lesson learnt is to use Time Machine that runs hourly, as opposed to Carbon Copy Cloner that runs once a day - and that too in the last few days it had not run.


    I do have a catastrophe event backup but that is less frequent.


    Hope others here can also roll back.

  • msim20 Level 1 (0 points)

    Btw, I wonder if this is a sign of Apple beginning to drop the ball on customer experience.

  • léonie Level 10 (85,225 points)

    Your example shows "zero" images both in "projects" view (in the lower right corner) and in "library" view.


    The images are in Aperture I can tell - because in Library>Projects I can see all the images.

    Do you actually see images inside the project, if you click on one of the project icons, e.g. your "Panoramas" icon, in spite of the "zero" image count below the icon?


    The search box however shows "showing all" photos - so there does not appear to be an obvious filter on.

    Each library icon can have its own filter set. To be sure that there is no filter set, you need to check both filters (library tab, browser) for each of the library views and items - Projects View, Photos View, each project or album with missing images.

    But if you had a filter set, hiding the images, then the counts would/should be different from zero.


    Your library really seems to be corrupted in a way that even "Rebuild Database" cannot fix. Do you have a vault or a backup that you can use to restore the library?


    If yes, then restore it from the backup, and this time rebuild the library before you upgrade it to version 3.3.




  • prefuse77 Level 1 (0 points)

    Yes, it seems like the library got corrupted in the upgraded process. If I remember correctly Aperture stated that my library indeed was corrupt in some way when I tried to upgrade. It then attentempted a rebuild of the database and then continued with the upgrade process (or I started it again - don't remember). I have my 120 GB Aperture "file" on a raided drive but I do not have a time-machine backup or similar... I am a bit unsure what to do now being stuck with Aperture 3.3 showing only a few of my images in otherwise empty projects. This is how it looks for me:


    Mac Mini.jpg

    You can clearly see that something is wrong since all the projects shows "0" in the library list and the previews are beginning to behave strangely, displaying the same streched out picture for every project that I move the mouse over...


    What to do? Is this big database-solution such a great idea? I mean, that was one big reason why I left the windows platform a long time ago... They seem to haunt you : (

  • léonie Level 10 (85,225 points)

    If rebuilding the database does not work, and you have no backup of the Library from the time before the upgrade, you might try this:


    Make a backup of your Aperture Library - an exact copy on disk with enough space.


    1. Look at the projects with missing images and take not of the time these  projects have been imported. 
    2. Then ctrl-click he Aperture Library package and look inside by selecting "Show Package Contents" - look into the "Masters" folder. Your original image files should be stored there, files away by import date.
    3. Do you see your images inside? If your original images are still there, you now have two options:
      1. Create a new, empty library and import the original masters (for the missing images) from the "Masters" folder into this new Library. After checking if everything is o.k. import this into your other Library.
      2. Or try to manually fix the other library by removing the database files from within the package.

    To manually repair the library, if rebuild does not work:



    Caution, caution, caution:


    There is one one last desperate method to save some parts of your library that you might try - but that might wreck the library completely, so you need to make sure you have a backup copy before you even think about trying this:


    To manually repair a library see here:

          Re: Aperture 3 rebuild library - SQLITE MISUSE


    Frank Caggiano wrote about this method not long ago:

    That's really the option of last resort it is way to easy to totally wreck the library doing this.


    It's like the sign over the gates in the Inferno:


    Abandon all hope yee that enter here!

    I wouldn't advice to try that, unless seeing you are about to recreate the library completely from scratch.

  • prefuse77 Level 1 (0 points)

    Ok, thank you for your help!


    I looked inside the Masters-folder and noticed that there where only three years present (2010,2011,2012) even though I have images back from 2004... But I also knew that the images should all be in there somewhere. After looking around I found the majority of the pictures in 2011>01>31. There are hundreds of folders there named like "20110131-200901" but with pictures from all different kind of dates. The pictures are all together as I sorted them originally but with the wrong folder names and in the wrong place... I guess its back to manually rebuilding everything again (option 1). I don't see how removing the database-files could fix this specific problem (option 2).

  • léonie Level 10 (85,225 points)

    folder names and in the wrong place.

    The dates are the import session - the date you moved the images into Aperture, not the dates the images were taken. That is why I said - take note of the import sessions of your projects in the Info tab. Then you will know in which folder to look.


    I don't see how removing the database-files could fix this specific problem

    Sometimes it works. If a database file is corrupted, Aperture cannot bind the masters to the versions. Removing the databas file forces Aperture to recreate it by scanning the masters folder. But don't try it if you are not confident and do not have a copy of your database.

  • prefuse77 Level 1 (0 points)

    Now I understand! Sorry for being a bit slow... I'll make an attempt to manually repair the database then. Duplicating the whole aperture-folder now for backup. Three hours left... :- /


    Thanks again!

  • Sjohnson803 Level 1 (0 points)

    Let us know if this works. I have a 4 TB library and it will take a few days. Want to know if this is the right thing to do.

  • msim20 Level 1 (0 points)

    @leonieDF - huge thanks for taking the time to help and write the detailed suggestions.


    My library indeed became corrupted somehow. Apple could have avoided this by simply having the earlier version of Aperture first clean up the library and only then letting the library be handed over to 3.3 version Aperture.


    My eventual solution was to revert to my latest backup of the library, revert to the earlier version of Aperture, run all three library maintenance procedures using the earlier version of Aperture.


    And then I installed 3.3 version and upgraded. All went through smoothly.


    Definitely a lesson for me to do maintenance next time I upgrade. But a lesson for Apple and software developers also to only upgrade library format after maintenance.


    And also, I am switching my backup strategy on my travel backup drive - from CCC (carbon copy cloner) to Time Machine. If I had Time Machine I would not even have lost a few days of work.


    The flip side of Time Machine is that I do not have a bootable drive when I travel. That is a question for another day

Previous 1 2 Next