9 Replies Latest reply: Feb 4, 2013 11:49 PM by SirAdams
edoctor Level 1 Level 1 (0 points)

Hello.  I'm using GarageBand 6.0.5 (428.5) under Lion 10.7.4, 2.4 GHz Intel Core i7, 16gb memory.


Here's a description of my problem:


1. Start GarageBand

2. When the dialog comes up, select "Lesson Store".

3. When Lesson Store starts, select "Account" in the upper right hand corner.  The mouse cursor changes from the arrow to the Mickey Mouse glove.

4. Click "Account".

5. Nothing happens.  The cursor does not flash, and the button is not pressed.

6. Select "Guitar Lessons"

7. Select "Artist"

8. Select "The Spirit of Radio"

9. The sample video starts.

10. The buy button with the price $4.99 appears

11. Move the mouse cursor over the $4.99 price button.  The mouse cursor changes to the Mickey Mouse glove.  The button color changes to green and the text changes to "Buy Now".

12. Click "Buy Now".

13. Nothing happens.  The cursor does not flash, and the button is not pressed.

14. Select the Home Icon.

15. Select "Rock Guitar"

16. Move the mouse cursor to the "Download" button to the right of "Power Chords and Palm Muting" text.  The button color changes to green.

17. Click "Download".  The lesson downloads normally and can be run without incident.


It looks like GarageBand his bailing on authentication.  No surprises there, iTunes has done this to me in the past.  I tried the following fix:


1. Drag the GarageBand icon to the trash.  I use Noodesoft's "Hazel" program to broom up after app deletes.  Hazel found a packet of GarageBand related files that I deleted.  I do not know which files they were.

2. Using CCleaner, I ran a clean pass to root out any other files that could have been left over.  The Mac version of CCleaner isn't that mature yet, so it may have missed a thing or two.

3. Reboot.

4. Fire up App Store, download and re-install GarageBand.

5. Tried the same tests as above.  Fail. 


Any thoughts?

GarageBand (Mac) '11, Mac OS X (10.7.4), Can't sign into GarageBand