Previous 1 3 4 5 6 7 Next 137 Replies Latest reply: Oct 15, 2014 6:32 AM by turingtest2 Go to original post Branched to a new discussion.
  • iNexxFear Level 2 (385 points)

    Same thing happening here... However my condition is that I had a new computer, went to Apple's website downloaded the iTunes installer.  All went well, just now the software update routine does not get any additonal items (even things like Safari).


    The search to apple's website does not complete and I'm immediately returned to a blank window from the updater.

  • markarich159 Level 1 (10 points)

    I don't know what is going on now. It was working perfectly for 4 days. Now it's back to doing the same old dysfunctional idiocy. Apple BETTER get its act together or make an announcement that they are having an issue. This is absolutely intolerable!!!!! it looks like a Windows Tablet or Google tablet for me in the future.

  • orfew Level 1 (5 points)

    Well today I went to download a book on my IPAD. I get a message that said I have to update my IPAD software. I connect the IPAD and tried to download the IPAD software update. Then I get a message that says I need to download the newest Itunes in oreder to get the newest IPAD update. I have been having the same problem when I go to update...nothing happens. When I go to Apple Update I see what others have described as a box empty of any software updates.


    I am very glad I found this thread as I was about to download the update manually. I guess I will just have to wait until this is sorted out. Very frustrating since I cannot update my IPAD.

  • phillipfromct Level 1 (0 points)

    same thing here. worked again for a while now back to same ol. I know its not on my end. all the computers have the same condition.

  • daveash Level 1 (0 points)

    For some weeks I´ve been having the same problem, Win 7 64Bit, two machines. My neighbour keeps showing me all the FREE apps on his Samsung phone and all the other attributes, he keeps urging me to swap to Samsung. If Apple want to battle with other companies over copyrights and patents thats OK but when they treat their customers with disrespect as they are doing over this issue then its time to let them know that other huge companies have grown to the same size and fallen by the wayside for the same reason. I love my iphone and I love my ipad but love is a two way street.

  • lucid green Level 1 (0 points)

    I believe I am having the same problem. Let me see if I can give you a screenshot, since that is worth a thousand words.


    It seems to run through the check, but then comes back with this window that says I have new updates, but the fields are empty. Normally I get a message pop-up saying everything is up to date. When I click OK everything goes away and I'm good, or it lets me select my desired updates, etc. This new undocumented feature appears a little more ambiguous.


    This is in Windows 7 Pro 64-bit.

    I tried uninstalling and reinstalling Apple Software Update, no change.

    Also, other computers I have seem to work just fine. This leads me to believe that it's a local machine problem.

  • lucid green Level 1 (0 points)

    Nope, the update is available for manual download.

  • Michael Garvey Level 1 (0 points)

    Same problem here:  iTunes won't update on my Windows 7 64-bit machine.


    From reviewing all the above posts, I'm a bit stunned by Apple's lack of concern, their disinterest in even acknowledging the problem.

  • MiaJW Level 1 (0 points)

    Also the same thing happening here i tried to download the new itunes update as my Ipod was not syncing with my itunes at all after various attempts at restarting the apple mobile service and then stupidly I unistalled itunes to try and re-install it and now it won't re-install at all so I am now left with no itunes, I am also worried that when/if i do manage to re-install itunes all my music off of my library will have gone. I installed it on my netbook with no problem ( however i do not have any of my music on that machine!!)  but on my windows 7 64 bit laptop there is no hope, i have had this problem for 5 days now! desperate for help.

    Sorry i could not be any help to this thread jsut helping to express the issue and hoping to be another voice to tell Apple to try and do something!!!!

  • daveash Level 1 (0 points)

    After having had this same problem for some weeks now I did the following. I downloaded itunes manually and saved it, approx 75 Mbytes. Then loaded it normally and it overworte the original which I had not deleted. I then copied the file to my laptop and did the same. There was no message to say that I already had itunes or anything, it just updated the original and now both of my PC´s have ver. Everything works and I´ve lost no files, music, apps or anything.



  • MiaJW Level 1 (0 points)

    I keep getting this box at the end of each installation but it doesn't tell me why it failed.itunes s.png

  • bbolling Level 1 (0 points)

    Looks like it may be an issue with their CDN not having proper catalog (or not giving out proper catalog?) on all service points. By luck i found one that worked, Update your hosts file to include



    For those of you rightly paranoid by adding an IP to your hosts file from a forum post on the internet, will show it is Akamai (valid CDN).


    After updating this locally, SoftwareUpdate.exe was able to work without issue every time i closed and reopened.


    To udpate your hosts file in windows:

    1. Open command prompt (if windows 7/vista, right click and open as administrator).

    2. Type in  "notepad c:\windows\system32\drivers\etc\hosts" (without the quotes).

    3. Enter in a new line on the bottom of the file with "" (again, no quotes).

    4. Save. -- If you get an error about it being open already or you not having permission to save, you likely did not run as admin.

    5. Run software updater.


    Hope this helps others out there!

  • lucid green Level 1 (0 points)

    Interesting. When I ping that, I get some address assigned to the Utah Education Network (UEN) which is different every time. This doesn't surprise me since I work in Utah for a school district here as a network engineer. Our host networks are assigned by UEN, so just about everything goes through UEN, which is one of the main hubs for the Internet in the US located at the University of Utah. (Know your ARPAnet history?)


    Others might get different responses when pinging in their respective areas. I'd just be curious as to what results might be out there.


    For those who aren't technically saavvy, this is a workaround and not really a fix since it doesn't address the actual configuration of the Apple Software Update service. Instead it manipulates the local hosts file that bypasses network DNS lookups. People should never edit this file, let alone have to edit it since DNS is generally handled for very good reasons by their ISP for home and some small business users, and should be handled by internal DNS servers for most business and organizations. Rule of thumb, if you didn't understand a word I just said, don't change anything in the hosts file. If you must, create a shortcut to the file on your desktop and use a "# " in front of the changes, save the hosts file again and then try the updater again to see if it's working properly again. You can turn the change on and off by adding and removing the "# " in front of those settings. That's a pound symbol and a space, in case you were wondering.


    Also, if Apple decides it's in your best interests to change the IP address of their update service for Windows products, the updater will stop working again if you edit this file and you will need to remove that entry in your hosts file.


    For those concerned with workloads and fixing this on several computers, this will require you to edit the hosts file on all the computers you manage. You can see how this can get old fast.


    I also saw this article that relates to OS X with regards that updater service:



    I wonder what requirements Apple Software Update has for the Windows version.

  • frank_the_arch Level 1 (0 points)

    First, I havta clarify I'm no geek, so forgive me if I insult ayone's intelligence...


    After several weeks of unsuccesfully trying and on the verge of giving up, I just updated my iTunes to version 10.6.3 on my Windows Vista PC. When updating from iTunes, the same thing as to RDF1173 (June 18 post, this discussion) would happen. When updating from the Apple website, several times I would get the message that either Bonjour or Apple Software Update could not be found or whatever. The following steps might have to do with the fix or not, but the last thing I did, which apparently (a big "APPARENTLY") worked, was:


    1) Went to the Windows Control Panel/Programs/Uninstall.

    2) Selected Bonjour and clicked "Repair". The same thing with "Apple Software Update".

    3) From the Apple - iTunes website, downloaded the update.

    4) Started doing the update without closing iTunes (after the initial advisory), up until the download prompt window asked to close iTunes again (about halfway thru the process). Instead of hitting "ignore", closed iTunes at that point and then let the installation continue.

    5) Prayed.

    6) The download proceeded until complete, and prompted to restart my PC.

    7) Restarted, (prayed), loaded iTunes, (prayed), and voila, iTunes 10.6.3 finally came on, with my music library intact.


    As I write this, the iMatch process is ongoing (haven't stopped praying).


    Prior to that, and I couldn't tell if this influenced the process or not, I had turned on Home Sharing on all devices(which worked), and had added the desktop PC to the iCloud (which I don't think accomplished anything). This originally to try to copy my library from my iPod (I know, I know, it can't be done without 3rd party apps...) to the cloud or my laptop PC (which had also had problems with Bonjour and Apple Software Update programs, but which I had overcome by completely uninstalling iTunes and downloading it new from the website).


    Anyway, that's my lifetime contribution to society!!!


    Good luck!

  • mike-d157 Level 1 (0 points)

    FWIW, I just deployed a new Windows 7 Enterprise 64-bit system today. The hard drive image that was loaded isn't as updated as it could be, and it lacks (at least) updates since June. Before applying any Windows Updates, Apple Software Update (ASU) ran properly. I was offered and had it install the newest ASU, and after that was installed, I was offered and installed the newest QuickTime. Subsequent invocations performed properly. I applied all outstanding MS Office updates, and any/all updates related to .NET...still no problem with ASU. I then applied the only (two) updates listed for Internet Explorer for this system, which cite KB2544521 and KB2699988. After applying these and restarting, ASU no longer works. I tried backing out of these updates, but it doesn't help. As far as I can tell, these updates are applicable under (at least) IE7 and IE8 and Windows XP SP3, Windows Vista, and/or Windows 7.

Previous 1 3 4 5 6 7 Next