4 Replies Latest reply: Jun 18, 2012 1:13 PM by MusicmamJane
MusicmamJane Level 1 Level 1 (0 points)

I have a used ipod touch, 4th gen, I think and I'm trying to download some apps and get the message "this app requires iOS 4.3."  Is it possible to update my opperating system?


iPod touch, just had digitizer replaced