Previous 1 2 3 Next 43 Replies Latest reply: Oct 8, 2012 9:09 PM by SombraGuerrero
ClearNexus Level 1 (55 points)

apple software update in windows, loads and opens, has a good internet connection, but when it trys to check for an update the looking for update bar appears doesent check. Then it closes the update bar,and shows no updates like to install safari i know this because since i started using apple software update over 2 years ago it has shown this.


my issue is similar to that of lkadlec he wrote the question below the only difference my software doesnt say new updates are available and my issue started 4 days from 6/9/12

Software Update not showing available updates (but says new software is available)

apple software update in windows
  • ClearNexus Level 1 (55 points)

    if any one has any ideas to fix my issues or thinks the issue is on apples end please respond to this thread

  • b noir Level 9 (72,060 points)

    Yeah, there's been a sudden burst of reports of this. It's not clear what might be causing it yet (to me, at least).


    Folks with it can update to newer versions of their software using installers downloaded from the Apple Website:



    If you're interested in doing some basic principles troubleshooting, would you mind checking something for me? (No guarantees that we'd get anywhere, I'm afraid.)


    If you're game, could you download and AutoRuns and check to see if there's any LSPs (other than the Bonjour ones) appearing in the Winsock providers tab in Autoruns? Instructions in the following Apple KnowledgeBase document:


    Apple software on Windows: May see performance issues and blank iTunes Store


    (LSP-trouble symptoms are pretty multifarious, and not all of them are officially documented, hence the interest in checking to see if there might be a LSP issue afoot here.)

  • ClearNexus Level 1 (55 points)

    Thank you for replying. I cant believe it took 111 viewers for 1 person to respond and i will try and check for the lsp`s maybe this make my problem a little more clear or not. But i have removed all 4 apple products, apples itunes installer put on to my computer redownloaded the installer, then reinstalled them and the issue still persists.

  • ClearNexus Level 1 (55 points)

    no lsa providers but as a anivirus i use norton 360 and i am 100% sure it is letting the connnection pass from my computer

  • Micah Hunter Level 1 (5 points)

    I am also seeing this issue across varius machines running windows, apple hardare or not. It is kind of frustrating because I am trying to get some machines up to date. I am now left to downloading each update and then installing them one by one.

  • ClearNexus Level 1 (55 points)

    I knew it ,it's not a problem with windows it can only possibly be one of two problems 1. It's the new apple software or the iTunes update the has an issue or 2. Apples servers are not sending information to users either because their doing updates. I really would love to know which issue it is and if anyone from apple reads this. At least give us a hint at the issue at hand or release an official statement for this error in our systems. Thank you mr. hunter for the conformation on the issue.

  • markarich159 Level 1 (10 points)

    I , as well as many, many , many others are having this exact same issue. you can check here:



    and there are a few hundred other threads discussing the same issue in one way or another. As of yet, Apple has made no official comment of why this is occurring or when it wil be resolved; but I think it's safe to say that it IS a problem from their end - lets face it, all of us didn't just mysteriously happen to have our Apple Software Update utility go dead at the exact same time. I'm sure it must have something to do with the new rollout of itunes 10.6.3(which is the 1st itunes to allow iOS 6 to be downloaded through it). itunes 10.6.3 is also a fairly hefty update that adds a 2 new programs(Apple Application Support & Apple Mobile Device Support) that I've never seen in my list of Programs & Features before. I'm sure they'll smooth it out in time. I just wish they wouldn't be so tight lipped about the whole affair.


    P.S. I also did AutoRuns and the only other LSP running under WinSock is my ESET antivirus/antispyware and that has been there for 2 years with no problems(I'm sure it's not the issue). I've tried every conceivable suggestion that I've seen mentioned on the forums and elsewhere.  I also have seen the EXACT same problem now on THREE seperate machines(one running Win 7 64bit; one running Win Vista 32 bit and one running Win 7 32 bit) at 2 seperate locations. At this point, I think it's completely safe to say that it is an issue that has it's origin at Apple's end.

  • ClearNexus Level 1 (55 points)

    Thank you for your information contribution the amassing amount has made it very clear that this issue is something apparently apple would not like to discuss, their system impeded one of my first posts. I hope a future update can resolve this issues and hope the readers of this thread bring this to as many iTunes users attentions as possible so we can resolve this issue for future posts for future readers do not continue to post issues with your own system instead try to tell apple our problem. And post that this is a issue on apples end on other forms thank you readers for your time and effort to fix our beloved apple software.

  • markarich159 Level 1 (10 points)

    I FIXED IT!! I can't believe it . I actually figured out how to make it work(well sort of). My Apple Software Updater now works (almost) perfectly and I just successfully downloaded and installed itunes through it!!!


    Ok , the way I see it, either the latest itunes update or the recent Windows Patch Tuesday on June 12th, 2012 must have inadvertently removed the Administrative Rights from the Apple Software Update Tool .lnk file.


    So you must go to where the file resides on your hard drive - for me that was C:\Program Data\Microsoft\Windows\Start Menu\Programs - Right click on the Apple software Tool icon and choose properties. Click on the compatibility tab. At the bottom of this tab click on "change settings for all users" and hit Yes at the UAC pop-up. Now make sure you place a check in the "Run this program as Administrator" under the Privilege level section at the bottom. Hit Apply and then OK. The hit Ok again to get off the properties pop-up.


    When I went back and clicked on the Apple Software Update shortcut, I got a UAC pop-up asking me if I wanted to proceed(something I had always, in the past, gotten but haven't since this problem started). The Apple Software Update tool came up and to my suprise the progress bar STAYED and started to slowly fill up partially with the green progress bar. Viola, the itunes 10.6.3 update showed up on the top part of the screen as a new update needing to be installed - the bottom screen, as usual, had the changelog info for the 10.6.3 update. I clicked on install and , again, Viola. the update downloaded and installed flawlessly. I had to reboot my computer and when it restarted, itunes was working perfectly and it was correctly showing as itunes v10.6.3.25.


    I say it is almost or sort of fixed because when you click on the Apple Software Update shortcut after the 10.6.3 install it goes back to doing the same thing it did before(i.e. processing for a second and then saying there are new updates but showing a blank field). Maybe this is the way the software now looks if there are no updates available to install - maybe Apple is working on this to eventually get it back to normal. All I know is the process I outlined above worked for me(at least to get the ASU to recognize and properly download and install itunes 10.6.3). It's certainly not perfect, but it worked. Please try this method and let me know what results you have with it. Good luck.

  • ClearNexus Level 1 (55 points)

    Tell everyone!!!!!!!!!! And see this proves it was apples fault and not an issue on our parts. This issue only started on the latest update so they have to fix this issue in the new software this clearly proves apple software update worked in windows before they did their update.

  • markarich159 Level 1 (10 points)

    Yeah, I agree. It's definitely still broken from Apple's end. But at least most of the feedback I've seen from the method I posted last night is positive in the sense that people are at least able to get the newest iTunes update. Hopefully Apple will completely fix the issue within a few days and get this ASU issue straight. I've posted the instructions on every thread I can think of relating to this topic. Most people say they can get and install the iTunes update but the ASU goes right back to the "dead" state it was in prior.

  • ClearNexus Level 1 (55 points)

    At least this gives this issue the attention it needs, now all we need is for apple to open its ears and listen to the issue and have its developers turn a little bit of their attention from their maps. To the software so we can get the updates passed to all users not just the tech savy users who can work around the problem.

  • b noir Level 9 (72,060 points)

    Many thanks for the report, markarich!


    Trialling a slight variation on your instructions over in the following post:


    Re: iTunes says there is an update 10.6.3 but when I click to update nothing happens?


    (Effectively I'm doing a "one-time" Run as Administrator, whereas your technique runs ASU as an administrator at every launch.)

  • markarich159 Level 1 (10 points)

    Hi b Noir;

      I've seen your many helpful posts on this issue in several other threads and must give you a huge collective thanks for your selflessness in attempting to address & assist the plethora of users having this ASU problem.  The reason I chose to raise the ASU.lnk file to administrative privilege rather than the SoftwareUpdate.exe file was that(at least on my system) the "Run as Administrator" tick box was alrady checked under the properties/compatibility tab for the SoftwareUpdate.exe file. Right clicking on the software update.exe file and choosing run as administrator was not successful.  This is what gave me the initial idea to look at the shortcut (ASU.lnk) file and raise that to administrative privilege. You would think that since the SU.exe file has administrative privilege already, and the ASU.lnk shotrtcut simply points to the SU.exe file; none of this would be necessary anyway. This whole situation has me completely baffled and, again, at this point I can only surmise the issue lies at Apple's end. Thanks again for your help and your willingness to provide assistance throughout this forum.

Previous 1 2 3 Next