Previous 1 2 3 Next 66 Replies Latest reply: Oct 14, 2012 10:13 PM by Craig Luis
lavintek Level 1 Level 1



I am experiencing a wide-spread issue with apple software update on windows. In an attempt to update itunes and quicktime, apple software update is run but comes up with a blank list (see figure 1). This has happened on 3 machines that were freshly imaged (with an older version of itunes), and 5 machines that have been in use for months/years. Operating systems include windows vista, 7 and 8 Release Preview; they all have varying internal specifications.Some computers are x32 others are x64. I have also had a friend who is outside of the network system the other mentioned computers are in, in an attempt to use software update. He came across the same results. Also as a note, the current versions of itunes that are being targeted to be updated range from 10.5 to


I have attempted running a repair on apple software update on one machine, with no change.


Has anyone else experience this issue? I see one other similar discussion post at the moment found here:


But no where else am I seeing mention of issues of this sort.


Thanks for any input!



  • jb@faithpca Level 1 Level 1

    I've been experiencing the same problems/issues. I also tried repairing the Apple Software Update (ASU) but to no avail. I also uninstalled all my Windows Apple Software, rebooted and reinstalled iTunes...and still have the same issue. One interesting thing...after reinstalling the software, I opened ASU and noticed that under "preferences" and "installed updates" it had a list of updates from the past. I didn't expect to find a list of past updates (thought it would be wiped with the uninstall) but I guess it's an archived file. The list only included updates up to 5/23/2012. It did not include the latest iTunes update. Looking for other threads that give a solution.

  • b noir Level 9 Level 9

    There's been a sudden burst of reports of this. It's not clear what might be causing it yet (to me, at least).


    Folks with it can update to newer versions of their software using installers downloaded from the Apple Website:



    If you're interested in doing some basic principles troubleshooting, would you mind checking something for me? (No guarantees that we'd get anywhere, I'm afraid.)


    If you're game, could you download and AutoRuns and check to see if there's any LSPs (other than the Bonjour ones) appearing in the Winsock providers tab in Autoruns? Instructions in the following Apple KnowledgeBase document:


    Apple software on Windows: May see performance issues and blank iTunes Store


    (LSP-trouble symptoms are pretty multifarious, and not all of them are officially documented, hence the interest in checking to see if there might be a LSP issue afoot here.)

  • lavintek Level 1 Level 1



    Thanks for the response. After running autoruns, I can confirm that there are no winsock providers active, with the exception of bonjour (as expected). This is the case on multiple machines that are experiencing the software update issue.



  • charles from eau claire Level 1 Level 1

    Same thing here on several machines with different versions of Windows, 7, and XP. 

  • BobP1776 Level 3 Level 3

    Same problem here attempting to run Apple's Software Update under Windows 7 in a Bootcamp partition on a 10.7.4 Mac.


    NOTE:  I *WAS* able to get the recent Safari for Windows and iTunes for Windows installs via Software Update back on the day they came out, so whatever's gotten broken here is not specific to those updates.


    When you launch Software Update, it brings up the normal progress bar display showing the search for updates, but BEFORE any progress is displayed in that bar, that bar is dismissed and you are left with the empty list (instead of the dialog box saying no updates are available).  There is no error message.


    I'm hoping this is just a problem at Apple's end with the update server, as otherwise, getting the right fix without the ability to use Software Update will be fun.


    I thought the problem might be related to Apple's widespread network service outage today (6/20) that affected iCloud, iMessage and apparently other services.  But those are fixed now and Software Update for Windows still isn't working.  In addition, those problems apparently were limited to just today, and the first reports here of problems with Software Update for Windows came in before that.


  • markarich159 Level 1 Level 1

    I FIXED IT!! I can't believe it . I actually figured out how to make it work(well sort of). My Apple Software Updater now works (almost) perfectly and I just successfully downloaded and installed itunes through it!!!


    Ok , the way I see it, either the latest itunes update or the recent Windows Patch Tuesday on June 12th, 2012 must have inadvertently removed the Administrative Rights from the Apple Software Update Tool .lnk file.


    So you must go to where the file resides on your hard drive - for me that was C:\Program Data\Microsoft\Windows\Start Menu\Programs - Right click on the Apple software Tool icon and choose properties. Click on the compatibility tab. At the bottom of this tab click on "change settings for all users" and hit Yes at the UAC pop-up. Now make sure you place a check in the "Run this program as Administrator" under the Privilege level section at the bottom. Hit Apply and then OK. The hit Ok again to get off the properties pop-up.


    When I went back and clicked on the Apple Software Update shortcut, I got a UAC pop-up asking me if I wanted to proceed(something I had always, in the past, gotten but haven't since this problem started). The Apple Software Update tool came up and to my suprise the progress bar STAYED and started to slowly fill up partially with the green progress bar. Viola, the itunes 10.6.3 update showed up on the top part of the screen as a new update needing to be installed - the bottom screen, as usual, had the changelog info for the 10.6.3 update. I clicked on install and , again, Viola. the update downloaded and installed flawlessly. I had to reboot my computer and when it restarted, itunes was working perfectly and it was correctly showing as itunes v10.6.3.25.


    I say it is almost or sort of fixed because when you click on the Apple Software Update shortcut after the 10.6.3 install it goes back to doing the same thing it did before(i.e. processing for a second and then saying there are new updates but showing a blank field). Maybe this is the way the software now looks if there are no updates available to install - maybe Apple is working on this to eventually get it back to normal. All I know is the process I outlined above worked for me(at least to get the ASU to recognize and properly download and install itunes 10.6.3). It's certainly not perfect, but it worked. Please try this method and let me know what results you have with it. Good luck.

  • BobP1776 Level 3 Level 3

    I believe Apple's Software Update for Windows gets distributed as part of an iTunes install (and possibly also a Safari or QuickTime install), which may explain why your fix stopped working after you did that install.


    Evidently something that Apple did, or more likely something that Microsoft did as part of its last Patch Tuesday, undid some privilege settings Software Update needs to do its job.


    Microsoft has been scrambling to close the barn door on the method the Flame virus used to pretend to be an official update from Microsoft, and in the course of tightening up on things to try to fix that they may have also screwed up something Software Update depends on.


    If the REAL fix were as easy as just re-establishing Administrator privileges, I'd think we would have seen a Knowledge Base article from Apple stating that by now.  So I suspect what you've got is a workaround but not a fix.


  • markarich159 Level 1 Level 1

    I agree BobP1776; Apple is going to have be the entity that ultimately comes up with the fix. I sincerely hope they are fully aware of the issue and are working on it at this time. I have sent a CS email to them and I'm hoping many others have as well.

  • Royalh13 Level 1 Level 1

    I am having this same issue with Windows 7 x64.


    I tried changing the settings to run as administrator for everyone, but it still doesn't work.


    Hope they get it fixed soon...

  • anthonyiu Level 1 Level 1

    What I did was go to C:\Program Files\Apple Software Update

    Make a shortcut of SoftwareUpdate

    Rename the  shortcut "Apple Software Update"

    Move this shortcut to C:\Documents and Settings\All Users\Start Menu\Programs  and replace the shortcut there

    And Voila it works

  • alfuture Level 1 Level 1

    doesnt work for me... the list is still blank, but it said there are some new software.

  • BobP1776 Level 3 Level 3

    I agree.  Neither of the two suggested workarounds fixes Apple Software Update for me, either.  (Windows 7 running in a Boot Camp partition.)  Nor does doing a "Repair" re-install of Apple Software Update in Windows' Add/Remove Programs section of Control Panel.




    By the way, folks are getting confused by the fact that the panel left behind on screen says there are updates to install at the top.


    That Apple Software Update panel *ALWAYS* reads that way.  That text never changes even when things are working correctly.


    In normal operation, that panel is first overlaid by the progress bar while Apple Software Update looks for things that need installation.  But the panel, in the background, has an empty list and also that text at the top that says there are updates to install.


    In normal operation, if the search finds nothing that needs to be installed, then the progress bar goes away and a 2nd overlay appears saying your software is up to date.  But the panel behind it still shows an empty list with the text at the top saying their are updates to install.  When you click OK to dismiss that 2nd overlay, Apple Software Update quits.  Again, this is how it operates when working correctly.


    What's happening now is that something is aborting the processing by Apple Software Update before it ever does the search -- so no advance of the progress bar.  That progress bar gets dismissed -- way too fast to have actually completed the search -- but the second overlay never appears, presumably because the search itself never produced a result.  So you are left with the bogus, empty list pane with that text at top saying there are updates to install.  I.e., that text is meaningless because Apple Software Update never did its search in the first place.


  • lavintek Level 1 Level 1

    I agree with BobP1776 and alfuture. Suggested workaround fixes do not work. Also, this issue is occuring in machines that do not have the latest windows update patches (as well as those that do). It does not appear to be an issue related to Microsofts sweeping patches last patch tuesday.


    Thanks for the comments everyone! Still looking for an answer though...

  • Bill3 Level 2 Level 2

    I have same issue running Windows 7 64bit in Parallells on MBP with Lion.  I too tried uninstalling all Apple apps and reinstalling.  Did not work.  In addition the iCloud control panel will no longer open, however, when I reinstaled Safari, the bookmarks were synced via iCloud.

Previous 1 2 3 Next