1 Reply Latest reply: Jun 19, 2012 6:53 PM by b noir
rowan12355 Level 1 Level 1 (0 points)

i dont know how to work my ipod touch it tells me that there was an error on updating and i need the ios 5


iPod touch, iOS 4.3.3