3 Replies Latest reply: Jun 19, 2012 7:29 PM by sanjayfromcoimbatore
Jamestowner2 Level 1 (0 points)

Ive been trying to update my iPhone 4 OS. To 5

It is 4.3.3 now


Each time I've tried, I get the error that my firmware is not compatible.

I've tried to restore---- first-- same error code


Deleted preferences on my computer (pc) and tried again----- same error


I just wanna update.... Any ideas??


iPhone 4, iOS 5.1.1