14 Replies Latest reply: Jan 12, 2015 1:29 PM by zMakUzr
Tony Barone Level 2 Level 2 (220 points)

I have an Early 2008 Mac Pro and it will not sleep.  When selecting sleep from the menu, it appears to go to sleep but then "wakes up" a few seconds later.

 

Sometimes, hitting the power button will put it to sleep, but seems to randomly work.

 

I have tried selecting sleep even without any apps running to make sure none of them are preventing it.  Also checked that "wake on network activity" is not turned on.

 

I'm running OSX Lion 10.7.4.


Mac Pro, Mac OS X (10.7.4), Early 2008 Quad 2.8Ghz, 14 GB Ram
  • X423424X Level 6 Level 6 (14,205 points)

    Assuming this is only a recent problem on your machine try a smc and pram reset.

     

    This happens to my 2010 mac pro if I do any hardware configuration changes (change a hard drive for example).  A smc and pram reset clears it for me.

  • The hatter Level 9 Level 9 (60,030 points)

    external devices and cables, drivers are all 10.7.4 friendly

    started with the update?

    you didn't keep prior OS around?

    does it happen with a Safe Boot?

  • Linc Davis Level 10 Level 10 (143,340 points)

    Test after each of the following steps that you haven’t already tried:

     

    Step 1

     

    ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

     

    Step 2

     

    ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

     

    Step 3

     

    ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

    Check all printers for unfinished jobs. Deal with any you find.

     

    Step 4

     

    Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

     

    Step 5

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

     

    Step 6

     

    Boot in safe mode and log in. The instructions provided by Apple are as follows:

     

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Note: If FileVault is enabled under Mac OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the Mac OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

     

    If sleep now works as expected, go on to the next step.

     

    Step 7

     

    Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

     

    Step 8

     

    If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

     

    If you still have the sleep issue after booting out of safe mode, post again.

  • Brian 2 Level 1 Level 1 (115 points)

    erase everything in the launch daemons and launch agent folders in your macintosh - library. That fixed my problem!

  • robogobo Level 2 Level 2 (290 points)

    I had this same problem.  The fix for me was deleting outdated startup items in System Preferences > Users & Groups > Login Items.  They'll have a warning icon next to them.  Also, one startup item that was not outdated but is causing sleep hangs is the i1ProfilerD2LionEdition and i1ProfilerD2LionEditionTray.  I had to get rid of those too.

     

    hope this helps.

  • Tony Barone Level 2 Level 2 (220 points)

    I'm not really sure what happened, but my computer is sleeping again, although it won't go to sleep unless I tell it to.  The "sleep after x minutes" doesn't appear to work except for putting the screen to sleep.

     

    I didn't reply sooned as I've had my system turned off the past 2 days during the heat wave.  When I started up, I tested it again and it worked.  I never reset the SMC or anything, so it seems as though an App that I had running and then closed somehow prevented it from sleeping previously.

     

    Thanks for all the help, I will certainly try the suggestions when/if the problem comes back!

  • MadHgts Level 1 Level 1 (0 points)

    You are an F*&&&^%%$^^ GENIUS!!!!

     

    This was driving me totally crazy. I've done everything I could think of and then I read your post (I read about 50 before most of which provided the same type of actions, none of which worked).

     

    THE STUPID PRINTER (I have two)!!!!

     

    They were both in "paused" mode and I quit them. It worked!

     

    SLEEP....Glorious Sleep.

     

    Thanks for giving me back my sanity...until the next problem occurs anyway (smile)!

  • X423424X Level 6 Level 6 (14,205 points)

    Tony Barone wrote:

     

    I'm not really sure what happened, but my computer is sleeping again, although it won't go to sleep unless I tell it to.  The "sleep after x minutes" doesn't appear to work except for putting the screen to sleep.

     

    Try using PleaseSleep.  It tries to force the system to obey the energy saver preferences.

  • Rainßird Level 2 Level 2 (355 points)

    I have four hard drives installed in my Mac Pro. The computer won't sleep. I traced the problem to "Drive Pulse" a component of the Drive Genius 3 software utility . Turning off the drive pulse feature of this utility solved the problem.

  • The hatter Level 9 Level 9 (60,030 points)

    Less is more. Too many of those background type utilities, having more than one even, and 'testing' the drive SMART or whatever, if you want, build a "maintenance' system for all those. If you want to insure your drive's sectors are okay, SoftRAID 4 does so during idle time to scan - and will alert if there are I/O read/write attempts.

     

    Monitoring the system temps and manual control to increase the fans is about as far as I will go.

  • k00ld00dz Level 1 Level 1 (0 points)

    I have found that I was sharing an internet connection.  As soon as I stopped sharing, sleep worked perfectly.

     

    This is where I found the idea to stop sharing:

    http://support.apple.com/kb/HT1776?viewlocale=en_US&locale=en_US

  • Tunanas Level 1 Level 1 (0 points)

    Hi, Thanks k00ld00dz. You're suggestion worked for me too.

     

    I had the same problem with my Mac Pro mid 2010 (5,1) dual 2.66  12core running OS X 10.7.5. When I tried putting it to sleep, the screen would sleep but the Mac stayed on. (No pulsing light or "Off" click sound). I was sharing the internet connection using airport. When I switched that off. The Mac would sleep again. Please note that simply powering Wi-Fi off did not do the trick. I had to go to the "SHARING" control panel in the System preferences and UN-check the "Internet Sharing" item in the list. That did it.

     

    Thanks again.

  • Wildatheart Level 1 Level 1 (30 points)

    Thanks so much for mentioning Internet Sharing - it was driving me crazy and I read the support doc you mention a while ago, but as it doesn't mention turning  Internet Sharing off specifically (thanks Apple), I am very grateful that you *have*!

  • zMakUzr Level 1 Level 1 (5 points)

    We have multiple 27" iMacs (2011-2013) that are still running 10.8.5 and none of them will wake from sleep because all have VLANs configured for networking.  That seems to be fatal, when it comes to sleeping ... the system will sleep but will not wake and must be powered down, rebooted, (filesystem repaired and rebooted).  This issue is 100% reproducible.

     

    Frankly, the reason we're still using 10.8.5 is that each OS version's quality seems to be declining.  The most table OS X release was actually 10.4.  Ran 10.4 client systems as servers that ran for hundreds of days without rebooting.  Have never been able to do that since (10.5 seems to have VM leaks so eventually gets into "swap itself to death" mode, 10.6 has more crashing issues, 10.7 we skipped entirely, 10.9 we skipped entirely and 10.10 still has _way_ too may issues).  Unfortunately, the same thing seems to be happening with iOS, in terms of reliability.

     

    As a 35+ year software developer veteran, it seems obvious that Apple is trying to do too many releases and/or has lost its ability to properly test its software.  Unfortunately, this has recently spawned the grasp for a fix by opening up beta releases to the general public.  While this could be slightly better than the M$ approach of just letting the purchasing customers test the product, it's far from professional.

     

    I really wish people would think "hey, we have hundreds of millions of users so, if we cause people to waste an hour each year with hard-to-use and/or buggy software, we waste hundreds of millions of hours of people's time!" ... and, hopefully, that would put "gee, maybe testing is worthwhile" into perspective (and having only wasted an hour per year would be dozens of times better than I personally experience each month).

     

    ... and, interestingly enough, I was unable to post this using Safari (just "hung" at "Loading..." the posting) -- had to use FireFox (shame on you Apple!).