14 Replies Latest reply: Aug 6, 2013 8:15 PM by rh93
pmckeever Level 1 Level 1

I have internet access as I just finished downloading and installing iTunes but I cannot get to the store through it

Windows 7
  • wiclee Level 5 Level 5

    Close your iTunes,

    Go to command Prompt -


    (Win 7/Vista) - START/ALL PROGRAMS/ACCESSORIES, right mouse click "Command Prompt", choose "Run as Administrator".


    (Win XP SP2 n above) - START/ALL PROGRAMS/ACCESSORIES/Command Prompt


    In the "Command Prompt" screen, type in


    netsh winsock reset


    Hit "ENTER" key

    Restart your computer.

    If you do get a prompt after restart windows to remap LSP, just click NO.


    Now launch your iTunes and see if it is working now.


    If you are still having these type of problems after trying the winsock reset, refer to this article to identify which software in your system is inserting LSP:


    iTunes 10.5 for Windows: May see performance issues and blank iTunes Store


  • pacharnevijay Level 1 Level 1

    @ wiclee: Thank you so much, I had the same problem and finally it got fixed after an effort of almost a month.

  • Gregorthegiant Level 1 Level 1

    Hi wiclee - thanks so much. How frustrating not to get access - new computer and all. Worked a treat.

  • sevenwonders Level 1 Level 1

    wiclee - I cannot thank you enough for this SUPER EASY fix!  I have not been able to access the iTunes Store since Feb '12.  After I ran this command prompt, my iTunes Store opened right away - no problems at all!

  • sampleme Level 1 Level 1

    wiclee, very good man! Thank you!!!

  • e-lad Level 1 Level 1

    Worked for me.  Thanks a lot!!!

  • alhooper81 Level 1 Level 1

    wiclee is a LEGEND  had itunes (but no istore in itunes)  followed his link and MAGIC  there it is thanx wiclee

  • moomoochoo Level 1 Level 1

    One day I found I couldn't connect to the apple store. My itunes was perpetually stuck trying to access the itunes store and not connecting and not showing an error message. After running diagnostics I found that I was unable to connect securely. wiclee's answer above solved my problem. Thank you very much!!!!! I've been searching for a good 3 months for this solution.

  • Labsyut Level 1 Level 1

    I have windows 8 enterprise OS and iTunes ver. I was upgrading my iPad to IOS 6.1.3. After finishing the upgrade my iPad Reboot and currently stucked-up in a plug-in screen and iTunes Logo. When I try to connect it to the iTunes pop-up message appear saying " iTunes has detected iPad in recovery mode. You must restore this iPad before it can be used with iTunes." In short, I push the restore button then another pop-up message appear saying " The iPad software update server could not be contacted. Make sure your network settings are correct and your network connection is active, or try again later." I tried many ways but still no luck. I repeatedly reboot the iPad and open the iTunes still the same problem. I try also to uninstall the iTunes and installed the lower version but still the same problem, I even check the firewall if the ITunes was block or My privileges is administrator to run the iTunes or even reset my winsock but the problem still remain. PLEASE HELP! Thank you in advance!!!

  • Seidan1 Level 1 Level 1

    Fixed the issue I was having. Thanks a bunch!

  • tommatteson Level 1 Level 1

    Timeless information it appears. Not sure what caused this to happen. But, I was unable to connect to the iTunes store for a week or more ... until I found this thread. Your cmd prompt command to reset the winsock catalog did the trick. Thanks

  • MBurn52 Level 1 Level 1

    I know this is a relatively old post, but like Tom said above.... this still works!


    I have a Win7x64 PC and was using a Bigfoot Killer NIC (gaming NIC), as opposed to the integrated NIC on the motherboard (Broadcom, LOM).  The Killer NIC that I am using is no longer supported (no new drivers are being written/released).  I wanted to use the BCOM NIC with new drivers and firmware that I recently installed to help resolve a few 'annoying' issues.


    iTunes would connect to the store without issue, but was suffering from quite a few network resets during file downloads (purchased movies or music).  So, I wanted to test my BCOM NIC.  I could not connect to the iTunes store with my BCOM network adapter for the life of me.


    Like many others, I tried quite a few things.  I fumbled around with my firewall, router, antivirus software, etc.,... The steps provided in this forum thread provided a quick and accurate solution.



  • tapan317 Level 1 Level 1

    Helped a bunch! THANK YOU!

  • rh93 Level 1 Level 1

    I was having this issue for a while also.  The only way I could get access to the iTunes store was to run the diagnostic test, and then click cancel on the dialogue box where it told me "secure link to iTunes store failed". By canceling the diagnostic box the store would load, but I'd have to do that everytime I wanted to access the store.


    I tried doing what wiclee suggested however it never worked.


    I was also having trouble in the store actually loading.  It would take forever, if it ever would load and always, the genius setting was trying to send information to Apple about my library  but always froze at like 3% or so.


    I went looking through my control panel thinking that maybe it was my firewall and after about three hours of searching through it all I came across a message that told me that iTunes had stopped working a few times - the dates were from decemeber 2012, but it also said that iTunes needed an update; evern though iTunes was telling me that it was up to date.

    I clicked on the link that took me to the apple page on the net to download iTunes again, and in the dowload box it had either a 'repair' option or an 'uninstall' option.  I clicked on repair and let it do its thing and my itunes seems to work perfectly fine now.  My access to the store is a fast as a cheeter and I no longer have issues with genius getting stuck in sending data. Having said that however, I did only do this about ten minutes ago and haven't reset my computer yet.


    If what wiclee suggested worked thats great, but if you ever have any issues with it again, maybe try repairing your itunes.