6 Replies Latest reply: Jun 20, 2012 10:51 AM by Tomp2
Tomp2 Level 1 Level 1 (10 points)

Reading these forums, and judging from my own experiences since upgrading to v3.3, it seems to me fair to suggest that Apple have once again prematurely released an inadequately tested turkey, leaving us poor users to do the testing and point out the bugs.

 

I upgraded a few days ago. I had nothing in iPhoto to merge, and the upgrade seemed to go well.  However, using the new version, three things were apparent:

 

1) The "auto-correct" function does absolutely nothing. I persevered and tried it with over 100 shots freshly downloaded from my Nikon D3S and it altered nothing whatsoever on any of them. I can live without the function, ultimately, of course, but if it's a feature, it ought to work.

 

2) As I have posted elsewhere in a separate discussion (no replies yet, though), v3.3 seems to have problems with Nik plug-ins. Now, every photo I open in a Nik plug-in that handles colour has pink skies. This did not happen before the upgrade. The photos look fine in Aperture and are fine when exported, but when loaded to any Nik plugin, I get pink skies. All my plugins are up to date, too.

 

3) I too have had the experience of Aperture uploading photos to Photostream even though, initially, I tried to pause this and eventually switched it off altogether. Aperture just seems to be pressing on with the upgrades regardless. Others have been posting in these discussions about this, so the problem is not just mine.

 

Then, today, Aperture just hung on opening. I wasn't in a hurry, so left it for 30 minutes. Nothing. Force Quit said it "was not responding". I could not exit the usual way, and was left needing to force quit the app. When I restarted it, I got the message saying that Aperture had "detected inconsistencies in my Library". Well, be that as it may, the only way they got there was by something Aperture had, or had not done, because I had not touched the application, or anything using the photo library, since yesterday.

 

I began the instructed repair process for the library, and an hour or so later, it was clear it had hung at "99%". again, Force Quit was the only apparent option. Next time, Aperture opened - eventually. A full ten minute wait, and a further 30 second pause before any Project will open. Oh, and uploading to PhotoStream seems still to be going on, against my wishes.

 

And that's only to date. What on earth is going on?

 

Tom


iMac, Mac OS X (10.7.2)
  • William Lloyd Level 7 Level 7 (20,645 points)

    Do keep in mind that most people only come to forums if they have a problem.  So judging from the volume of complaints here isn't a reasonable reflection on the state of affairs.

     

    As far as your other comments:

     

    1)  Auto-enhance works quite well for me.  Do the images you're enhancing already have adjustments?  I notice it bumps up the shadows on the majority of my photos.  Try resetting one to defaults first.

     

    2)  I'm not seeing any issues with Nik Color Efex Pro, with pink skies.  Well, unless I choose the thermal camera preset but that's another issue ;-)

     

    3)  I'm not seeing Photostream uploads, either.  I'm not sure what's going on there :-/

     

    Unsure on why Aperture hung on opening, but force quitting could cause database problems which is why you needed to rebuild.

     

    There were a lot of changes under the hood with the 3.3 update, and some people in some configurations may have issues.  I'd say reporting the feedback is good in addition to reporting it here, as the Apple engineers may not be reading these forums regularly.

  • Tomp2 Level 1 Level 1 (10 points)

    William,

     

    Thanks for the comments.

     

    No, the photos I tried to "enhance" were exactly as downloaded and imported from my D3S. They were plain and ordinary jpegs, not  RAW either.

     

    The Nik problem is one of the biggest irritants. It happens with any photo I try to edit using a Nik plugin - not just photos that have been imported since the Aperture 3.3 upgrade. That is to say, a photo I have previously edited using a Nik plug in with no problems at all now imports with a pink sky. See my separate post about this.

     

    And no, I don't know why Aperture failed on opening, but it had not done so before, and I have been using it for a couple of years now. Not personally prepared to put it off to coincidence that it has begun after upgrading to 3.3.

     

    Tom

  • William Lloyd Level 7 Level 7 (20,645 points)

    I just tried auto-enhance and NIK Color Efex again with JPEG shots from my Canon D60 (yes, it's old ;-) to see if JPEG versus RAW was an issue.  Both worked OK so that doesn't seem to be it.  Maybe the Nikon JPEGs are so perfect Aperture doesn't need to see a need to enhance them ;-)  OK that wasn't helpful, sorry.

     

    That's really weird about the Nik software.  I wonder if there's a way to figure out what's going on.  Does it happen with Silver Efex Pro too?  That would obviously be very strange if it happened on B&W conversion or with something like their sharpening plug-ins.

     

    Hopefully rebuilding the library will cure up any issue you're seeing.  I haven't seen the problem so I guess I"m happy for that.

  • Tomp2 Level 1 Level 1 (10 points)

    The library has rebuilt. Stuff seems to load ok, but the NIK problem remains. I need to update my post about this, because I've found it isn't just skies that render pink, it is all white areas. I tried with some cityscape shots - white buildings etc, all pink. It's not just screen effect either. If a photo imported to NIK is then saved, the version in Aperture shows the pink.

     

    I mentioned in my post that the problem only relates to colour plug-ins. Silver Efex Pro works fine. It is an issue about how the pluins interpret white from Aperture imports, and it was most definitely not there before the 3.3 upgrade, because I use the plugins regularly. Even an old plugin, like Color Efex Pro3, which I still have installed, as well as v4, does this.

     

    I'll be reporting it to Apple and NIK. I expect both will blame the other.

  • Ernie Stamper Level 8 Level 8 (37,550 points)

    With regard to Auto Enhance, see the discussion at:

     

    https://discussions.apple.com/message/18627319#18627319

     

    If you ever customized anthing, there is likely corruption following the upgrade.

     

    The same might be true of plugins, but I have not tested in that regard.

     

    Ernie

  • Tomp2 Level 1 Level 1 (10 points)

    William, Ernie,

     

    Thanks for your interest and support.

     

    At least I have solved the "pink" issue in the last half-hour. See separate thread about this. Answer there was that the 3.3 upgrade had replaced my chosen "Export" color space in Aperture Preferences (Adobe RGB) with the color space for my Canon printer. I had not asked it to. It just did, as part of the upgrade, I assume. Resetting it to Adobe has stopped any pink hues replacing white when shots are exported to NIK plugins.

     

    One down, several still to go....

     

    Tom