7 Replies Latest reply: Jul 15, 2012 12:11 PM by Ace2kidh
Ace2kidh Level 1 (0 points)

Hi everyone!


I've recently updated my windows 64-bit version of iTunes to 10.6.3 and ever since I'm getting slow response times (ok, that actually occured in the preceding version, too) and lock ups by not doinig anything special other than flipping through my music and deleting or adding files. I'm not even talking about synchronization with other devices here, but simple managing tasks.


Has anybody the same issues or ist it just me. Mr. Google could not help me out on this one


I'm pretty dissappointed and haven't had any othe bad experience with Apple yet. But this is unbearable...

iTunes, Windows 7, 64-bit, Int. Q9550 @2.83, 8GB RAM
  • whatheck Level 5 (4,085 points)

    You may be seeing something like what is described in this Apple article -> Apple software on Windows: May see performance issues and blank iTunes Store

    If it's what you're seeing, you can try resetting Winsock as a temporary fix or folllow along with the article.

    1. To do so, please do the following in an administrator user:
    Windows Vista and Windows 7: Right click All Programs and choose Accessories > Command Prompt. Choose to open as an administrator.

    Windows XP: Click Start > Run and type in cmd.


    2. Enter the following command: 
    netsh winsock reset


    3. Restart the computer and test the issue.
    Note:  If the issue returns, third-party software may be reinserting the LSP.

  • Ace2kidh Level 1 (0 points)

    Hey! Thank you very much for the quick response. I'll try your suggestion out when I get home and give a feedback...


  • Ace2kidh Level 1 (0 points)

    Hm, doesn't seem to do anything. I've tried your temporary fix and the one from the article, but still...

    Anyone else with a suggestion? I'm not keen on a windows reinstall...

  • whatheck Level 5 (4,085 points)

    Another thing that could cause iTunes slowness is old iTunes plug-ins.


    Take a look at this Apple document for more info -> iTunes: Troubleshooting issues with third-party iTunes plug-ins

    Does iTunes start normally in safe mode?

    Does it run like other apps on the computer after removing old plug-ins?

  • Ace2kidh Level 1 (0 points)

    In the meantime I've installed iTunes on my HTPC which basically has not much Software on it except for xbmc and Antivir. Same issues here - even worse, it seems. I'll actually disable Antivir tonight and try again since the Apple guy on the hotline told me there may be an issue with Avira (stupid I didn't think of it myself).


    I'll also try the plug-in stuff, thanks for that. Though I don't believe the issues would occure on my HTPC then...


    But theres another thing I forgot to mention so far: my iTunes media is stored on a NAS so i can connect to it via different clients. The Apple guy didn't see that as a problem since the library is loading and all. But maybe you know better...?



  • cbaker3108 Level 1 (0 points)

    Hello, I have the same problem with ITunes lockups on my PC using a NAS drive.  I have not yet updated to 10.6.3 (I actually found your post looking to see if 10.6.3 would resolve my issue!)  The winsock fix has not solved my problem either.  I don't have third party iTunes plug ins that I know of and have tried the tip from Apple above with no luck.


    I suspect my NAS is some part of the issue.  I recently replaced my PC and "upgraded" to having all files on the NAS.  On my older system I had my files on the local drive and did not have these same types of issues.  However, that was also an older version of iTunes so the NAS is not the only difference.

  • Ace2kidh Level 1 (0 points)



    In the meantime I've reinstalled Windows, which brought no change to the Problem. Instead, starting iTunes in safe mode (ctrl+shift for Windows) somehow did. Curious, cause I have no 3rd party plug-ins installed. In fact I akways had a clean install when experiencing those issues. So however safe mode solves the lock-ups and crashes for me. Nevertheless it's only a workaround.


    Hope it'll be fixed with the next release...