9 Replies Latest reply: Jul 1, 2012 8:19 AM by Allan Mitchell1
gravelmuncha2K Level 1 Level 1 (0 points)

Hello there,

 

I've installed Snow Leopard from 0 to get my MacBook 3.1 white working with a new harddrive but i'm facing a lot of problems with some apps, like iLife '11. I've installed from a disk my copy of iLife, everything went fine, but after updating OS X to 10.6.8 (this was installed using 10.6.3 from Mac Box Set) I can not open iPhoto because it's not compatible with 10.6.8, what the ****? What I've saw is that no iLife products are being updated from Software Updates app, what to do? is not going to be supported any more on Snow Leopard?

 

Please help!


MacBook, Mac OS X (10.6.8)
  • 1. Re: iLife '11 it's not updating
    seventy one Level 6 Level 6 (8,990 points)

    No-one can speak on behalf of Apple but this has come up recently and there is nothing official that I've seen.   I updated my iPhoto from the App store some months ago to 9.2.3. which was an improvement on the original iLife version.  The new update, and the only one on offer now, is 9.3 which is not suitable for OS X less than 10.7 Lion.

     

    So it would appear that in preparation for Mountain Lion, the reduction in support for Snow Leopard is under way and that is probably why you cannot update further than the original.   But its only a guess.

     

    Just a thought.   Have you tried software update since you reinstalled?

  • 2. Re: iLife '11 it's not updating
    gravelmuncha2K Level 1 Level 1 (0 points)

    Dear seventy one,

     

    I think it should be helpful for you or any one that want to help me to new the "steps", so here I go:

     

    • Mac OS X 10.6.3 clean install on a new HDD.
    • iLife' 11 install, without updating Mac OS X.
    • Looked for new updates on Software Updates.
    • Install available software updates (these were only for Snow Leopard).
    • Looked for more updates on Software Updates (few updates founded, only for Snow Leopard).

     

    I've tried to install OS X over 3 times, always same results, no iLife updates from Software Updates. What do you suggest?

     

    The most annoying from this issue, is that I'm not able to open iPhoto because it requests me a newer version to run on OS X 10.6.8...

  • 3. Re: iLife '11 it's not updating
    seventy one Level 6 Level 6 (8,990 points)

    I would have liked to have been more helpful but I'm afraid I am as much in the dark as you.   The second paragraph of my post was as good a guide as I could have given you.   If we are lucky, one of the more senior people will know the answer ... mine was an educated guess.

  • 4. Re: iLife '11 it's not updating
    noondaywitch Level 6 Level 6 (8,130 points)

    I'm somewhat puzzled, because iLife '11 (all of it) should work happily in 10.6.8.

     

    Nevertheless, try this one (iPhoto 9.2.3).

    They're all there if you use the search on Support Downloads.

     

    Message was edited by: noondaywitch

  • 5. Re: iLife '11 it's not updating
    m.yousef Level 1 Level 1 (0 points)

    same issue i have with me early macbook pro 2011

    i install lion for one day and restore it back to the original OS using snow leopard disks with ilife 9.1

     

    the following message is come when update iphoto 9.1  '' your software is up to date ''

     

    any help wil be appriciate

  • 6. Re: iLife '11 it's not updating
    gravelmuncha2K Level 1 Level 1 (0 points)

    It's not possible to update directly to 9.2.3 you need an earlier version to do that, but the built-in iPhoto version from iLife '11 disk it's not valid.

     

    Is Apple forgetting the users from Snow Leopard?

  • 7. Re: iLife '11 it's not updating
    noondaywitch Level 6 Level 6 (8,130 points)

    Is it only iPhoto that is refusing to install?

    There have been problems reported where the whole iLife '11 DVD wouldn't install due to a certificate problem.

  • 8. Re: iLife '11 it's not updating
    gravelmuncha2K Level 1 Level 1 (0 points)

    Dear noondaywitch,

     

    The whole suite is installed on the Mac, and any products are receiving updates. The software update you mean has been installed in the begin of the Mac OS X updates. It's very annoying because I can not make use of my iPhoto Library due to iPhoto version it's not up to date.

  • 9. Re: iLife '11 it's not updating
    Allan Mitchell1 Level 1 Level 1 (20 points)

    I ran into a similar problem. I upgrade to a new drive so i could install 10.6. I then upgrade to iLife 11 with an older version because the new versions require 10.7 and I am not sure if I will like how it runs on my early 2008 black macbook. Everything installed fine except iPhoto. I received an error message that said I had to update my photo library and to run software update. Software update did not show any updates. I went to the application and right clicked on iPhoto and chose "show contents". In the Mac OS folder you will see iPhoto. Double click on that and iPhoto will open. That does not solve the problem. I went to Apple support and downloaded all the updates for iPhoto 9, 9.1 thru 9.2.3. After installing the the 9.1 update, iPhoto opened normally and updated the library. I ran each update thru 9.2.3. All further updates require 10.7. Apple has some kind of code that stops iPhoto from update further. Maybe some Unix folks know of an easier work around.