Previous 1 2 Next 25 Replies Latest reply: Jul 25, 2013 11:51 AM by Brian Choong Go to original post
  • léonie Level 10 Level 10
    Photos for Mac

    That is what I was hoping for.


    If you do not press the "upgrade" button you now should have again an Aperture 3.2 library that you can open with Aperture 3.2.x.  If you press the upgrade botton, hopefully this time - with the new 3.3.1 version, the upgrade will be successful.


    It is up to you what you try now.

  • marwandese Level 1 Level 1

    So i have to install aperture 3.2.4?

  • léonie Level 10 Level 10
    Photos for Mac

    So i have to install aperture 3.2.4?

    no, only if you want to stay with Aperture 3.2.4.

    The screenshot you showed was Aperture 3.3 asking you for permission to upgrade the library to Aperture 3.3 format.


    If you double-click your Library again, Aperture 3.3.1 (you upgraded to 3.3.1, didn't you?) will now upgrade the library and hopefully better than the last time, since they fixed a bug and your library is now repaired.

  • marwandese Level 1 Level 1
  • léonie Level 10 Level 10
    Photos for Mac

    Are there any diagnostic messages in the Console Window?

  • marwandese Level 1 Level 1

    Well, performing the tasks you told me to do no, but then I tried to rebuild the library, after deleting the library file, and aperture started doing it but then hung, so I closed it and it corrupted it even more. i deleted the whole thing and I'm restoring the backup from my external hard drive again (exactly the same as the file I had this moring).


    i'll get back to you as soon as the file finishes copying (i'ts almost 100 gb on slow usb 2.0)

  • marwandese Level 1 Level 1


    this is a log from activity monitor.


    anyways this is what I did.


    1) I restored the aperture library file i had this morning

    2) I opened it with CMD and ALT to get the repair window

    3) I chose "repair database"

    4) this went on for about 5 minutes, after that I got my file open with all my photos, the only problem is that they're all in one project called "recovered project", so it's the same problem i've had since the beginning, i have to manually sort out 15k photos...

  • Erik Veland Level 1 Level 1

    Yikes. At least my photos are there, but I have 10K photos to sort out. Any chance of saving my projects?

  • hoodcj1 Level 1 Level 1

    I have had the same experience, but what it took to restore functionality to Aperture, was change permissions to the disk that had the Aperture Library.  I pressed CMD I and checked sharing & permissions.  Although I had Read & Write permissions, I still couldn't open the library without the same error message you are receiving.  I then changed the sharing & permissions for "everyone" to read & write.  I then clicked the gearwheel to apply changes to enclosed items (or a similar message).  After I did this Aperture opened as normal

    I am not sure what caused this, but I had recently backed up to an external HD.

  • Tescum Level 1 Level 1

    Well I had the same problem. And after try a lot of things... I quit.


    After a month I tried in another computer with the original library. I updated it and then, the same....


    But this time I tried looking in "trash".

    And... All the time was in there.


    I hope that everybody in here have the same luck.

  • Brian Choong Level 1 Level 1

    I got this problem too, but I able to find the solution my self

    This issue happen because of the Aperture trying to upgrade/open a corrupted library file

    e.g. You got a Library call Library A

    And then when you try to open it with Aperture, aperture detect this library is from older version and then ask you to upgrade it

    Then you say yes, this is the most interesting part, if the upgrade fail, then you will get this message, and no way to open the Aperture again

    Aperture will always prompt that error message

    Why? Because everytime when you trying to start Aperture, Aperture will try open the Library A

    And the worst part is, Library A is set as default library for Aperture

    But, library A is corrupted and cannot be open

    This is a dead lock


    To solve the dead lock, we need to change the default library for the Aperture, so that it able to load smoothly


    Well, we know the new Aperture able to open iphoto library,

    Also, there is a shortcut for iphoto to launch Aperture at it menu


    To solve the problem

    1. Launch the iphoto

    2. Create a photo album, let say Album A, import some photo to it

    3. At iphoto, highlight the Album A, and then go to File/Open Library in Aperture

    4. Yes, now Aperture will be launch and opening the iphoto library, which is Album A now

    5. Once Aperture able to open Album A, it mean it will lock the default library as Album A, problem solve!

Previous 1 2 Next