Previous 1 2 Next 25 Replies Latest reply: Jul 25, 2013 11:51 AM by Brian Choong
marwandese Level 1 Level 1

Hello, I have a problem with my Aperture library.


I had Aperture 3.2.4, and a perfectly working library. I copied the library to an external hard disk, and reinstalled my OS, since I had just added an SSD.


I then installed Aperture 3.2.4, and tried to open the library, that I had copied back in Pictures, but I got this message.


To open this iPhoto library in Aperture, it first needs to be upgraded. Verify that you have iPhoto 9.3 or later. Then open the library in iPhoto to upgrade it.


Since I had not used iPhoto in a while, I don't understand why I get this message, especially since the library is called Aperture Library.aplibrary


I then tried to update Aperture to version 3.3, hoping this would help, but I got no reslut, I still get the same message.


I installed iPhoto 9.3, and tried to open the library, this time getting a different message.


Your photo library is either in use by another application or has become unreadable. Shut down and restart your computer, and then open iPhoto again. If the problem persists, try rebuilding your photo library. To do this, quit iPhoto, and then reopen it while keeping the Option and Command keys pressed. You can also try restoring your photo library from a backup.


I get the same message if I try to rebuild the library, I tried in Aperture and in iPhoto.



BTW, the masters are safe, I tried to recover them in a new Aperture library in the meanwhile, and I have all my pictures, the only problem is that they are about 15 thousand and they were divided into hundreds of different Projects. Now I have them in one project called "Recovered Files".


What should I do?

iMac, Mac OS X (10.7.4), 128 GB SSD and 1 TB HDD
Previous 1 2 Next